summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-11 22:06:52 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-11 22:06:52 +0000
commitdb70da22458ca571213eb1ee256096f563dc9bef (patch)
treea847ec81a4826d5c0a454712772e4ac12ed8bbe8 /net-mail/fetchmail/fetchmail-5.9.14.ebuild
parentNew qmail ebuild! Added tls, smtp-auth, and ldap support. ldap and tls (diff)
downloadgentoo-2-db70da22458ca571213eb1ee256096f563dc9bef.tar.gz
gentoo-2-db70da22458ca571213eb1ee256096f563dc9bef.tar.bz2
gentoo-2-db70da22458ca571213eb1ee256096f563dc9bef.zip
Version bump. Fixed configure scripts so gcc3 doesn't complain about
-I/usr/include being specified. Fixed ebuild problems as mentioned in bug #7338. Changed to econf and einstall.
Diffstat (limited to 'net-mail/fetchmail/fetchmail-5.9.14.ebuild')
-rw-r--r--net-mail/fetchmail/fetchmail-5.9.14.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-5.9.14.ebuild b/net-mail/fetchmail/fetchmail-5.9.14.ebuild
new file mode 100644
index 000000000000..af564377b90a
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.9.14.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.9.14.ebuild,v 1.1 2002/09/11 22:06:52 raker Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 sparc sparc64"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/configure-5.9.14.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="{myconf} --enable-inet6"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+
+}
+
+src_install() {
+
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+}