summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-05-03 16:59:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-05-03 16:59:36 +0000
commit315a6f5fe163b79ee23857009030d74e6270f65c (patch)
treedca24421ca37e7e042322bd4de14d9f91880dce9 /net-mail/altermime
parentBugs 274529, 317583 (diff)
downloadgentoo-2-315a6f5fe163b79ee23857009030d74e6270f65c.tar.gz
gentoo-2-315a6f5fe163b79ee23857009030d74e6270f65c.tar.bz2
gentoo-2-315a6f5fe163b79ee23857009030d74e6270f65c.zip
Bump for #317955 with compile fix by Kerin Millar
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/altermime')
-rw-r--r--net-mail/altermime/ChangeLog10
-rw-r--r--net-mail/altermime/altermime-0.3.10.ebuild31
-rw-r--r--net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch46
3 files changed, 85 insertions, 2 deletions
diff --git a/net-mail/altermime/ChangeLog b/net-mail/altermime/ChangeLog
index a088686fd595..aa13c717ffcb 100644
--- a/net-mail/altermime/ChangeLog
+++ b/net-mail/altermime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/altermime
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/ChangeLog,v 1.14 2007/07/14 12:08:58 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/ChangeLog,v 1.15 2010/05/03 16:59:35 patrick Exp $
+
+*altermime-0.3.10 (03 May 2010)
+
+ 03 May 2010; Patrick Lauer <patrick@gentoo.org> +altermime-0.3.10.ebuild,
+ +files/altermime-0.3.10-fprintf-fixes.patch:
+ Bump for #317955 with compile fix by Kerin Millar
*altermime-0.3.8 (14 Jul 2007)
diff --git a/net-mail/altermime/altermime-0.3.10.ebuild b/net-mail/altermime/altermime-0.3.10.ebuild
new file mode 100644
index 000000000000..660da03bb604
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/altermime-0.3.10.ebuild,v 1.1 2010/05/03 16:59:35 patrick Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
+HOMEPAGE="http://pldaniels.com/altermime/"
+
+LICENSE="Sendmail"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "/^CFLAGS[[:space:]]*=/ s/-O2/${CFLAGS}/" \
+ -e 's/${CFLAGS} altermime.c/${CFLAGS} ${LDFLAGS} altermime.c/' \
+ "${S}"/Makefile || die "sed failed."
+ epatch "${FILESDIR}/${P}-fprintf-fixes.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install () {
+ dobin altermime || die "dobin failed."
+ dodoc CHANGELOG LICENCE README || die "dodoc failed."
+}
diff --git a/net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch b/net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch
new file mode 100644
index 000000000000..74d32f375a6e
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.10-fprintf-fixes.patch
@@ -0,0 +1,46 @@
+diff -urp altermime-0.3.10.orig/qpe.c altermime-0.3.10/qpe.c
+--- altermime-0.3.10.orig/qpe.c 2010-04-30 23:11:15.564697415 +0100
++++ altermime-0.3.10/qpe.c 2010-04-30 23:17:22.368691711 +0100
+@@ -97,7 +97,7 @@ int qp_encode( char *out, size_t out_siz
+ op+= strlen(paragraph);// +3; /** jump the output + =\r\n **/
+ out_remaining-= (strlen(paragraph)); // Was +3, updated to fix Outlook problems
+
+- QPD fprintf(stdout, "Soft break (%d + %d > 76 char) for '%s'\n", current_line_length, charout_size, paragraph);
++ QPD fprintf(stdout, "Soft break (%lu + %d > 76 char) for '%s'\n", (unsigned long)current_line_length, charout_size, paragraph);
+
+ /** reinitialize the paragraph **/
+ paragraph[0] = '\0';
+@@ -108,7 +108,7 @@ int qp_encode( char *out, size_t out_siz
+ }
+
+ snprintf(pp, pp_remaining, "%s", charout);
+- QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%d result='%s'\n", charout, charout_size, pp_remaining, paragraph);
++ QPD fprintf(stdout,"charout='%s', size=%d, pp_remain=%lu result='%s'\n", charout, charout_size, (unsigned long)pp_remaining, paragraph);
+ pp += charout_size;
+ pp_remaining -= charout_size;
+ p++;
+@@ -149,13 +149,13 @@ int qp_encode_from_file( char *fname )
+ out_size = in_size *3;
+ in_buffer = malloc( sizeof(char) *in_size +1);
+ if (in_buffer == NULL) {
+- QPD fprintf(stdout,"Error allocating %d bytes for input buffer\n", in_size);
++ QPD fprintf(stdout,"Error allocating %lu bytes for input buffer\n", (unsigned long)in_size);
+ return -1;
+ }
+
+ out_buffer = malloc( sizeof(char) *out_size *3 +1);
+ if (in_buffer == NULL) {
+- QPD fprintf(stdout,"Error allocating %d bytes for output buffer\n", out_size);
++ QPD fprintf(stdout,"Error allocating %lu bytes for output buffer\n", (unsigned long)out_size);
+ return -1;
+ }
+
+@@ -169,7 +169,7 @@ int qp_encode_from_file( char *fname )
+ ** we segfault ;) **/
+ *(in_buffer +in_size) = '\0';
+
+- QPD fprintf(stdout,"file %s is loaded, size = %d\n", fname, in_size);
++ QPD fprintf(stdout,"file %s is loaded, size = %lu\n", fname, (unsigned long)in_size);
+
+ qp_encode( out_buffer, out_size, in_buffer, in_size );
+