summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-28 04:18:53 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-28 04:18:53 +0000
commitfd23cd8009c26db9970aab9830801276f4b0bb2c (patch)
treef39882fd24d07c6a584e6d773585e962f41c6543 /net-libs
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-fd23cd8009c26db9970aab9830801276f4b0bb2c.tar.gz
gentoo-2-fd23cd8009c26db9970aab9830801276f4b0bb2c.tar.bz2
gentoo-2-fd23cd8009c26db9970aab9830801276f4b0bb2c.zip
Apply LDFLAGS patch to 1.18. Add dev-libs/glib dependency to 1.24 thanks to Francis Norberg (bug #325005).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnids/ChangeLog9
-rw-r--r--net-libs/libnids/libnids-1.18-r1.ebuild34
-rw-r--r--net-libs/libnids/libnids-1.24.ebuild3
3 files changed, 44 insertions, 2 deletions
diff --git a/net-libs/libnids/ChangeLog b/net-libs/libnids/ChangeLog
index 4f4e621de1c1..b3f50f49e9b6 100644
--- a/net-libs/libnids/ChangeLog
+++ b/net-libs/libnids/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libnids
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/ChangeLog,v 1.40 2010/06/28 04:09:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/ChangeLog,v 1.41 2010/06/28 04:18:53 jer Exp $
+
+*libnids-1.18-r1 (28 Jun 2010)
+
+ 28 Jun 2010; Jeroen Roovers <jer@gentoo.org> +libnids-1.18-r1.ebuild,
+ libnids-1.24.ebuild:
+ Apply LDFLAGS patch to 1.18. Add dev-libs/glib dependency to 1.24 thanks
+ to Francis Norberg (bug #325005).
28 Jun 2010; Jeroen Roovers <jer@gentoo.org> libnids-1.18.ebuild,
-files/libnids-1.20-chksum.c-ebx.patch, -libnids-1.23-r1.ebuild,
diff --git a/net-libs/libnids/libnids-1.18-r1.ebuild b/net-libs/libnids/libnids-1.18-r1.ebuild
new file mode 100644
index 000000000000..5a901b84fffc
--- /dev/null
+++ b/net-libs/libnids/libnids-1.18-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.18-r1.ebuild,v 1.1 2010/06/28 04:18:53 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="emulates the IP stack of Linux 2.0.x and offers IP defragmentation, TCP stream assembly and TCP port scan detection."
+HOMEPAGE="http://www.packetfactory.net/Projects/libnids/"
+SRC_URI="http://www.packetfactory.net/Projects/libnids/dist/${P/_}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.0-r3"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-chksum.c-ebx.patch \
+ "${FILESDIR}"/${PN}-1.24-ldflags.patch
+}
+
+src_configure() {
+ econf --enable-shared || die "econf failed"
+}
+
+src_install() {
+ emake install_prefix="${D}" install || die "emake install failed"
+ dodoc CHANGES CREDITS MISC README
+}
diff --git a/net-libs/libnids/libnids-1.24.ebuild b/net-libs/libnids/libnids-1.24.ebuild
index 38fcc1a84afd..6b90f9cc600c 100644
--- a/net-libs/libnids/libnids-1.24.ebuild
+++ b/net-libs/libnids/libnids-1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.24.ebuild,v 1.6 2010/05/04 18:53:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.24.ebuild,v 1.7 2010/06/28 04:18:53 jer Exp $
EAPI=2
inherit eutils
@@ -15,6 +15,7 @@ KEYWORDS="alpha amd64 ppc sparc x86"
IUSE=""
DEPEND="net-libs/libpcap
+ dev-libs/glib
>=net-libs/libnet-1.1.0-r3"
RDEPEND="${DEPEND}
!net-libs/libnids:1.1"