summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-10-23 09:48:03 +0000
committerMart Raudsepp <leio@gentoo.org>2008-10-23 09:48:03 +0000
commita97c32d0ca5a3536cb623da7575a33c7fc9fb6dc (patch)
treece9f5bb60929eb8c3e6beea44641e129c4986ad6 /net-libs
parentx11-misc/xkeyboard-config: add missing dep on dev-util/intltool (fixes bug #2... (diff)
downloadgentoo-2-a97c32d0ca5a3536cb623da7575a33c7fc9fb6dc.tar.gz
gentoo-2-a97c32d0ca5a3536cb623da7575a33c7fc9fb6dc.tar.bz2
gentoo-2-a97c32d0ca5a3536cb623da7575a33c7fc9fb6dc.zip
New revision that disables asyncns code for now, as it currently segfaults on some machines
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/loudmouth/ChangeLog8
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.2-r1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 9cbda4202152..fef26db42cac 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/loudmouth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.77 2008/09/20 20:14:53 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.78 2008/10/23 09:48:03 leio Exp $
+
+*loudmouth-1.4.2-r1 (23 Oct 2008)
+
+ 23 Oct 2008; Mart Raudsepp <leio@gentoo.org> +loudmouth-1.4.2-r1.ebuild:
+ New revision that disables asyncns code for now, as it currently segfaults
+ on some machines
20 Sep 2008; Gilles Dartiguelongue <eva@gentoo.org>
-loudmouth-1.3.4.ebuild, -loudmouth-1.4.0.ebuild, -loudmouth-1.4.1.ebuild:
diff --git a/net-libs/loudmouth/loudmouth-1.4.2-r1.ebuild b/net-libs/loudmouth/loudmouth-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..fbb90fc1306b
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.4.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.2-r1.ebuild,v 1.1 2008/10/23 09:48:03 leio Exp $
+
+inherit gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://www.loudmouth-project.org/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc ssl debug test"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1.4.0 )"
+# FIXME: can't build against system lib
+# asyncns? ( net-libs/libasyncns )"
+# openssl dropped because of bug #216705
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug)
+ --without-asyncns"
+ # Currently asyncns segfaults on some machines and breaks XMPP for telepathy, disabled till fixed
+
+ if use ssl; then
+ G2CONF="${G2CONF} --with-ssl=gnutls"
+ else
+ G2CONF="${G2CONF} --with-ssl=no"
+ fi
+}