summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-03-03 22:24:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-03-03 22:24:13 +0000
commit9d5635115db29be1648af52ae848ef1225331bdc (patch)
tree5b817a4be8667a18fb5eac4735c58dd1071d6f25 /net-libs
parentadd ~arm, bug #540540 (diff)
downloadgentoo-2-9d5635115db29be1648af52ae848ef1225331bdc.tar.gz
gentoo-2-9d5635115db29be1648af52ae848ef1225331bdc.tar.bz2
gentoo-2-9d5635115db29be1648af52ae848ef1225331bdc.zip
Fix openssl deps and move libtool to DEPEND. Bug #539368
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog6
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild10
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild10
3 files changed, 15 insertions, 11 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 9eb9845b0179..b4de13a978f9 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.185 2015/03/03 22:11:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.186 2015/03/03 22:24:13 hwoarang Exp $
+
+ 03 Mar 2015; Markos Chandras <hwoarang@gentoo.org>
+ rb_libtorrent-0.16.17-r1.ebuild, rb_libtorrent-1.0.3.ebuild:
+ Fix openssl deps and move libtool to DEPEND. Bug #539368
03 Mar 2015; Markos Chandras <hwoarang@gentoo.org>
rb_libtorrent-0.16.17-r1.ebuild, rb_libtorrent-1.0.3.ebuild:
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild
index 863453bad139..09a77cfae0a7 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild,v 1.2 2015/03/03 22:11:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild,v 1.3 2015/03/03 22:24:13 hwoarang Exp $
EAPI="5"
PYTHON_DEPEND="python? 2:2.7"
@@ -23,12 +23,12 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc examples python ssl static-libs test"
RESTRICT="test"
-DEPEND=">=dev-libs/boost-1.48:=[python?,threads(+)]
- >=sys-devel/libtool-2.2
+RDEPEND=">=dev-libs/boost-1.48:=[python?,threads(+)]
sys-libs/zlib
examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2"
pkg_setup() {
if use python; then
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
index bebed1555b2d..522ceddc91f7 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild,v 1.2 2015/03/03 22:11:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.3.ebuild,v 1.3 2015/03/03 22:24:13 hwoarang Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -23,16 +23,16 @@ IUSE="debug doc examples python ssl static-libs test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND=">=dev-libs/boost-1.53:=[threads]
- >=sys-devel/libtool-2.2
+RDEPEND=">=dev-libs/boost-1.53:=[threads]
sys-libs/zlib
examples? ( !net-p2p/mldonkey )
python? (
${PYTHON_DEPS}
dev-libs/boost[python,${PYTHON_USEDEP}]
)
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2"
src_prepare() {
use python && python_copy_sources