summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-10-15 06:20:51 +0000
committerMichael Weber <xmw@gentoo.org>2012-10-15 06:20:51 +0000
commit7b4aba9f4990bac16310f258c2882c814368f1eb (patch)
treed98d76527da176a520c153c0e37d25542f1466a9 /net-libs
parentVersion bump (euscan) (diff)
downloadgentoo-2-7b4aba9f4990bac16310f258c2882c814368f1eb.tar.gz
gentoo-2-7b4aba9f4990bac16310f258c2882c814368f1eb.tar.bz2
gentoo-2-7b4aba9f4990bac16310f258c2882c814368f1eb.zip
Version bump (euscan)
(Portage version: 2.1.11.26/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/enet/ChangeLog7
-rw-r--r--net-libs/enet/enet-1.3.5.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/net-libs/enet/ChangeLog b/net-libs/enet/ChangeLog
index aeaf5b8c6493..56e6e279f083 100644
--- a/net-libs/enet/ChangeLog
+++ b/net-libs/enet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/enet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/ChangeLog,v 1.26 2012/07/06 05:54:23 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/ChangeLog,v 1.27 2012/10/15 06:20:51 xmw Exp $
+
+*enet-1.3.5 (15 Oct 2012)
+
+ 15 Oct 2012; Michael Weber <xmw@gentoo.org> +enet-1.3.5.ebuild:
+ Version bump (euscan)
06 Jul 2012; Michael Weber <xmw@gentoo.org> enet-1.2.2.ebuild:
ppc stable (bug 424341)
diff --git a/net-libs/enet/enet-1.3.5.ebuild b/net-libs/enet/enet-1.3.5.ebuild
new file mode 100644
index 000000000000..ef8f8756e48c
--- /dev/null
+++ b/net-libs/enet/enet-1.3.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/enet/enet-1.3.5.ebuild,v 1.1 2012/10/15 06:20:51 xmw Exp $
+
+EAPI=3
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="!${CATEGORY}/${PN}:0"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ base_src_install
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}