summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-06 20:32:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-06 20:32:13 +0000
commit62b61ccc6b54e04aef695bb7ef66e66bc1b3f7a6 (patch)
tree9cd695acf7c3b4fb476b297b475815811fd2e8c9 /net-libs
parentVersion bump KDE 4.3.2 (diff)
downloadgentoo-2-62b61ccc6b54e04aef695bb7ef66e66bc1b3f7a6.tar.gz
gentoo-2-62b61ccc6b54e04aef695bb7ef66e66bc1b3f7a6.tar.bz2
gentoo-2-62b61ccc6b54e04aef695bb7ef66e66bc1b3f7a6.zip
Bump. fixes #287386
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-1.2.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 05645168328a..906f8b261af1 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.21 2009/06/26 11:25:30 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.22 2009/10/06 20:32:13 patrick Exp $
+
+*libssh2-1.2.1 (06 Oct 2009)
+
+ 06 Oct 2009; Patrick Lauer <patrick@gentoo.org> +libssh2-1.2.1.ebuild:
+ Bump. fixes #287386
26 Jun 2009; Peter Volkov <pva@gentoo.org> -libssh2-0.14.ebuild,
-libssh2-0.15.ebuild, -libssh2-0.17.ebuild, libssh2-0.18.ebuild,
diff --git a/net-libs/libssh2/libssh2-1.2.1.ebuild b/net-libs/libssh2/libssh2-1.2.1.ebuild
new file mode 100644
index 000000000000..d45e0ea76a35
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.2.1.ebuild,v 1.1 2009/10/06 20:32:13 patrick Exp $
+
+EAPI="2"
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="mirror://sourceforge/libssh2/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gcrypt zlib"
+
+DEPEND="!gcrypt? ( dev-libs/openssl )
+ gcrypt? ( dev-libs/libgcrypt )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+
+ if use gcrypt ; then
+ myconf="--with-libgcrypt"
+ else
+ myconf="--with-openssl"
+ fi
+
+ econf \
+ $(use_with zlib libz) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}