summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-20 12:20:03 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-20 12:20:03 +0000
commit5353cc8f0e7aa42389d6e38575f6569fdbace092 (patch)
treeb4fe166f864b2e7efb671976919fcb187fb1fd74 /net-libs
parentAdd ~x86-fbsd wrt #171198 (diff)
downloadgentoo-2-5353cc8f0e7aa42389d6e38575f6569fdbace092.tar.gz
gentoo-2-5353cc8f0e7aa42389d6e38575f6569fdbace092.tar.bz2
gentoo-2-5353cc8f0e7aa42389d6e38575f6569fdbace092.zip
Version bump.
(Portage version: 2.1.10.47/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-glib/ChangeLog7
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.16.5.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index dc3e0892e9b6..711a819553e4 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.99 2012/01/18 20:58:34 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.100 2012/02/20 12:20:03 pacho Exp $
+
+*telepathy-glib-0.16.5 (20 Feb 2012)
+
+ 20 Feb 2012; Pacho Ramos <pacho@gentoo.org> +telepathy-glib-0.16.5.ebuild:
+ Version bump.
18 Jan 2012; Markus Meier <maekke@gentoo.org> telepathy-glib-0.16.3.ebuild:
arm stable, bug #393007
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.16.5.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.16.5.ebuild
new file mode 100644
index 000000000000..09fff1174eaf
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.16.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.16.5.ebuild,v 1.1 2012/02/20 12:20:03 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+
+inherit python virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="debug +introspection +vala"
+
+RDEPEND=">=dev-libs/glib-2.28.0:2
+ >=dev-libs/dbus-glib-0.82
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+ vala? (
+ >=dev-lang/vala-0.14.0:0.14[vapigen]
+ >=dev-libs/gobject-introspection-1.30 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_prepare() {
+ python_convert_shebangs -r 2 examples tests tools
+ default_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.14)
+ VAPIGEN=$(type -p vapigen-0.14)"
+ fi
+
+ econf --disable-static \
+ PYTHON=$(PYTHON -2 -a) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings) \
+ ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Needs dbus for tests (auto-launched)
+ Xemake -j1 check
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}