summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-10-24 16:00:46 +0000
committerJohannes Huber <johu@gentoo.org>2013-10-24 16:00:46 +0000
commitaf795db6dfa5384f11fa1014756963594bb39617 (patch)
treed3e614f79d1c08f6899c21f918f1c620b1027bdf /net-libs/telepathy-qt
parentStable for HPPA (bug #488708). (diff)
downloadgentoo-2-af795db6dfa5384f11fa1014756963594bb39617.tar.gz
gentoo-2-af795db6dfa5384f11fa1014756963594bb39617.tar.bz2
gentoo-2-af795db6dfa5384f11fa1014756963594bb39617.zip
Add upstream patch to fix configure phase with dev-util/cmake-2.8.12 wrt bug #489220.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/ChangeLog7
-rw-r--r--net-libs/telepathy-qt/files/telepathy-qt-0.9.3-cmake-2.8.12.patch36
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.3-r1.ebuild3
3 files changed, 44 insertions, 2 deletions
diff --git a/net-libs/telepathy-qt/ChangeLog b/net-libs/telepathy-qt/ChangeLog
index a400334b7f2f..efc9eed61954 100644
--- a/net-libs/telepathy-qt/ChangeLog
+++ b/net-libs/telepathy-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-qt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.22 2013/09/05 19:01:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.23 2013/10/24 16:00:46 johu Exp $
+
+ 24 Oct 2013; Johannes Huber <johu@gentoo.org>
+ +files/telepathy-qt-0.9.3-cmake-2.8.12.patch, telepathy-qt-0.9.3-r1.ebuild:
+ Add upstream patch to fix configure phase with dev-util/cmake-2.8.12 wrt bug
+ #489220.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> telepathy-qt-0.9.3-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/net-libs/telepathy-qt/files/telepathy-qt-0.9.3-cmake-2.8.12.patch b/net-libs/telepathy-qt/files/telepathy-qt-0.9.3-cmake-2.8.12.patch
new file mode 100644
index 000000000000..d490bfc927e2
--- /dev/null
+++ b/net-libs/telepathy-qt/files/telepathy-qt-0.9.3-cmake-2.8.12.patch
@@ -0,0 +1,36 @@
+commit 05fe3f4980bbc6b016e25dcf07e44afe29e377c0
+Author: David Edmundson <kde@davidedmundson.co.uk>
+Date: Sun Sep 29 22:19:27 2013 +0000
+
+ Fix compilation on new versions of cmake
+
+ Recent cmake has changed the argument count to
+ qt4_create_moc_command, we need to adjust accordingly
+
+ Reviewed-by: Dario Freddi <dario.freddi@ispirata.com>
+
+diff --git a/cmake/modules/FindQt.cmake b/cmake/modules/FindQt.cmake
+index c2eac76..b3131f0 100644
+--- a/cmake/modules/FindQt.cmake
++++ b/cmake/modules/FindQt.cmake
+@@ -74,10 +74,18 @@ ENDMACRO(QT_GET_MOC_FLAGS)
+
+ MACRO(QT_CREATE_MOC_COMMAND infile outfile moc_flags moc_options)
+ IF(QT_VERSION_MAJOR MATCHES 4)
+- QT4_CREATE_MOC_COMMAND(${infile} ${outfile} "${moc_flags}" "${moc_options}")
++ IF(CMAKE_VERSION VERSION_GREATER 2.8.11.20130607)
++ QT4_CREATE_MOC_COMMAND(${infile} ${outfile} "${moc_flags}" "${moc_options}" "")
++ ELSE(CMAKE_VERSION VERSION_GREATER 2.8.11.20130607)
++ QT4_CREATE_MOC_COMMAND(${infile} ${outfile} "${moc_flags}" "${moc_options}")
++ ENDIF(CMAKE_VERSION VERSION_GREATER 2.8.11.20130607)
+ ELSE(QT_VERSION_MAJOR MATCHES 4)
+ IF(QT_VERSION_MAJOR MATCHES 5)
+- QT5_CREATE_MOC_COMMAND(${infile} ${outfile} "${moc_flags}" "${moc_options}")
++ IF(CMAKE_VERSION VERSION_GREATER 2.8.11.20130607)
++ QT5_CREATE_MOC_COMMAND(${infile} ${outfile} "${moc_flags}" "${moc_options}" "")
++ ELSE(CMAKE_VERSION VERSION_GREATER 2.8.11.20130607)
++ QT5_CREATE_MOC_COMMAND(${infile} ${outfile} "${moc_flags}" "${moc_options}")
++ ENDIF(CMAKE_VERSION VERSION_GREATER 2.8.11.20130607)
+ ENDIF(QT_VERSION_MAJOR MATCHES 5)
+ ENDIF(QT_VERSION_MAJOR MATCHES 4)
+ ENDMACRO(QT_CREATE_MOC_COMMAND)
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.3-r1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.3-r1.ebuild
index 6ba350dbdb6c..9f4709442f1a 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.3-r1.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.3-r1.ebuild,v 1.2 2013/09/05 19:01:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.3-r1.ebuild,v 1.3 2013/10/24 16:00:46 johu Exp $
EAPI=5
@@ -46,6 +46,7 @@ DOCS=( AUTHORS ChangeLog HACKING NEWS README )
PATCHES=(
"${FILESDIR}/${P}-tp-glib-0.18-tests.patch"
"${FILESDIR}/${P}-avatar-duplication.patch"
+ "${FILESDIR}/${P}-cmake-2.8.12.patch"
)
pkg_setup() {