summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-08-01 19:34:07 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-08-01 19:34:07 +0000
commit9b6a8234ef84d3de88843c5a1c0fb990be314e7d (patch)
tree1ffedc3620499b22a4c31f741139a3c04fa0c016 /net-libs/soup/soup-0.7.11-r1.ebuild
parentStable on x86, bug #117153. (diff)
downloadgentoo-2-9b6a8234ef84d3de88843c5a1c0fb990be314e7d.tar.gz
gentoo-2-9b6a8234ef84d3de88843c5a1c0fb990be314e7d.tar.bz2
gentoo-2-9b6a8234ef84d3de88843c5a1c0fb990be314e7d.zip
New revision, add patch to fix compilation with gcc-4.1.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'net-libs/soup/soup-0.7.11-r1.ebuild')
-rw-r--r--net-libs/soup/soup-0.7.11-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/soup/soup-0.7.11-r1.ebuild b/net-libs/soup/soup-0.7.11-r1.ebuild
new file mode 100644
index 000000000000..2ad59deda363
--- /dev/null
+++ b/net-libs/soup/soup-0.7.11-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.11-r1.ebuild,v 1.1 2006/08/01 19:34:07 chutzpah Exp $
+
+inherit gnome.org libtool eutils
+
+DESCRIPTION="Soup is a SOAP implementation"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ =dev-libs/glib-1.2*
+ dev-libs/libxml
+ dev-libs/popt
+ ssl? ( dev-libs/openssl )
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+IUSE="ssl doc"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~hppa ~ppc ~sparc ~x86"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fix gcc bailing (#68047)
+ epatch "${FILESDIR}/${P}-gcc3.patch"
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+
+}
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use ssl \
+ && myconf="--enable-ssl" \
+ || myconf="--disable-ssl"
+
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ # disable apache support. too much trouble than
+ # it is worth. it only works with apache1.
+ export ac_cv_path_APXS=no
+ econf \
+ ${myconf} \
+ --with-libxml=1 || die
+ # Evolution 1.1 and 1.2 need it with libxml1
+ unset ac_cv_path_APXS
+
+ # dont always work with -j4 -- <azarah@gentoo.org> 9 Nov 2002
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ABOUT-NLS COPYING* ChangeLog README* INSTALL NEWS TODO
+}