summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-07-10 09:05:50 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-07-10 09:05:50 +0000
commit08317898b51882ad2def85e2e536a5a1f0736a7d (patch)
tree3f34ac6e5b42e538c3f8ba31c3d6019f8ecf0213 /net-libs/socket++
parentVersion bump. (diff)
downloadgentoo-2-08317898b51882ad2def85e2e536a5a1f0736a7d.tar.gz
gentoo-2-08317898b51882ad2def85e2e536a5a1f0736a7d.tar.bz2
gentoo-2-08317898b51882ad2def85e2e536a5a1f0736a7d.zip
Revision bump: EAPI 5, migrate to autotools-utils eclass, do not generate broken HTML documentation, do not install non-upstream pkgconfig file, fix building with new texinfo, wrt bug #514246
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x60C0742D1F357D42)
Diffstat (limited to 'net-libs/socket++')
-rw-r--r--net-libs/socket++/ChangeLog11
-rw-r--r--net-libs/socket++/socket++-1.12.12-r2.ebuild41
2 files changed, 50 insertions, 2 deletions
diff --git a/net-libs/socket++/ChangeLog b/net-libs/socket++/ChangeLog
index 05e1807bb4df..fbf415305076 100644
--- a/net-libs/socket++/ChangeLog
+++ b/net-libs/socket++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/socket++
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/ChangeLog,v 1.17 2013/09/07 08:35:52 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/ChangeLog,v 1.18 2015/07/10 09:05:50 pinkbyte Exp $
+
+*socket++-1.12.12-r2 (10 Jul 2015)
+
+ 10 Jul 2015; Sergey Popov <pinkbyte@gentoo.org> +socket++-1.12.12-r2.ebuild:
+ Revision bump: EAPI 5, migrate to autotools-utils eclass, do not generate
+ broken HTML documentation, do not install non-upstream pkgconfig file, fix
+ building with new texinfo, wrt bug #514246
07 Sep 2013; Pacho Ramos <pacho@gentoo.org>
+files/socket++-1.12.12-gcc47.patch, socket++-1.12.12-r1.ebuild:
diff --git a/net-libs/socket++/socket++-1.12.12-r2.ebuild b/net-libs/socket++/socket++-1.12.12-r2.ebuild
new file mode 100644
index 000000000000..7e20f7713525
--- /dev/null
+++ b/net-libs/socket++/socket++-1.12.12-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12-r2.ebuild,v 1.1 2015/07/10 09:05:50 pinkbyte Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="C++ Socket Library"
+HOMEPAGE="http://www.linuxhacker.at/socketxx/"
+SRC_URI="http://www.linuxhacker.at/linux/downloads/src/${P}.tar.gz"
+
+LICENSE="freedist GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~x86"
+
+IUSE="debug static-libs"
+
+RESTRICT="bindist"
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README README2 README3 THANKS )
+
+PATCHES=( "${FILESDIR}/${P}-gcc47.patch" )
+
+src_prepare() {
+ # bug #514246
+ sed -i -e 's/@subsection t/@section t/g' doc/socket++.texi || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}