summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-11-02 20:06:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-11-02 20:06:46 +0000
commite9479f493d17b14905eb76e8476c88af9d108f4b (patch)
tree1783e2d11f8ca57d30b886ee9202870b9e9573a4 /net-libs/rb_libtorrent
parenthonour arm cflags and properly autodetect thumb2 support in 1.8.5 for gentoo ... (diff)
downloadgentoo-2-e9479f493d17b14905eb76e8476c88af9d108f4b.tar.gz
gentoo-2-e9479f493d17b14905eb76e8476c88af9d108f4b.tar.bz2
gentoo-2-e9479f493d17b14905eb76e8476c88af9d108f4b.zip
Backport fix from 0.16.5. Bug #440976
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog6
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild17
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.4.ebuild77
3 files changed, 9 insertions, 91 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 586b6e640e45..a7b0e8e36847 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.137 2012/10/31 17:26:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.138 2012/11/02 20:06:46 hwoarang Exp $
+
+ 02 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
+ -rb_libtorrent-0.16.4.ebuild, rb_libtorrent-0.16.3.ebuild:
+ Backport fix from 0.16.5. Bug #440976
31 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org>
rb_libtorrent-0.16.5.ebuild:
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild
index 717ae32b3669..b823a650f4a0 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild,v 1.1 2012/08/24 23:59:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.3.ebuild,v 1.2 2012/11/02 20:06:46 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.6"
@@ -43,17 +43,11 @@ src_prepare() {
src_configure() {
# use multi-threading versions of boost libs
- local BOOST_LIBS="--with-boost-system=boost_system-mt \
+ local myconf="--with-boost-system=boost_system-mt \
--with-boost-python=boost_python-${PYTHON_ABI}-mt"
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="${EPREFIX}/usr/$(get_libdir)/boost-${BOOST_VER}"
local LOGGING
- use debug && LOGGING="--enable-logging=verbose"
+ use debug && myconf+=" --enable-logging=verbose"
econf $(use_enable debug) \
$(use_enable test tests) \
@@ -61,10 +55,7 @@ src_configure() {
$(use_enable python python-binding) \
$(use_enable ssl encryption) \
$(use_enable static-libs static) \
- ${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
- ${BOOST_LIBS}
+ ${myconf}
}
src_install() {
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.4.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.4.ebuild
deleted file mode 100644
index 0701e49fe8e0..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.4.ebuild,v 1.1 2012/10/02 18:19:57 hwoarang Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH="threads"
-PYTHON_USE_WITH_OPT="python"
-
-inherit multilib python versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
-RESTRICT="test"
-
-DEPEND=">=dev-libs/boost-1.48[python?]
- >=sys-devel/libtool-2.2
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- use python && python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- # use multi-threading versions of boost libs
- local BOOST_LIBS="--with-boost-system=boost_system-mt \
- --with-boost-python=boost_python-${PYTHON_ABI}-mt"
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="${EPREFIX}/usr/$(get_libdir)/boost-${BOOST_VER}"
-
- local LOGGING
- use debug && LOGGING="--enable-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- $(use_enable ssl encryption) \
- $(use_enable static-libs static) \
- ${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
- ${BOOST_LIBS}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
- dodoc ChangeLog AUTHORS NEWS README
- if use doc; then
- dohtml docs/*
- fi
-}