summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-11-15 08:33:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-11-15 08:33:02 +0000
commitd65ee27463f9abd375206d974124696e8051f7f5 (patch)
tree1ad2facb07de06891403682b27b25369d250f127 /net-libs/rb_libtorrent
parentUpdate HOMEPAGE/SRC_URI #515528 by Manfred Knick. (diff)
downloadgentoo-2-d65ee27463f9abd375206d974124696e8051f7f5.tar.gz
gentoo-2-d65ee27463f9abd375206d974124696e8051f7f5.tar.bz2
gentoo-2-d65ee27463f9abd375206d974124696e8051f7f5.zip
Revbump to EAPI=5 so we can add boost subslot dependencies in order to trigger rebuilds on boost bumps. Bug #529034
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog10
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.10.ebuild4
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild78
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild4
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild4
5 files changed, 93 insertions, 7 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index fa911fe1c61c..bb99b53a2a98 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.180 2014/10/18 19:35:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.181 2014/11/15 08:33:02 hwoarang Exp $
+
+*rb_libtorrent-0.16.17-r1 (15 Nov 2014)
+
+ 15 Nov 2014; Markos Chandras <hwoarang@gentoo.org>
+ +rb_libtorrent-0.16.17-r1.ebuild, rb_libtorrent-0.16.10.ebuild,
+ rb_libtorrent-0.16.17.ebuild, rb_libtorrent-1.0.2.ebuild:
+ Revbump to EAPI=5 so we can add boost subslot dependencies in order to trigger
+ rebuilds on boost bumps. Bug #529034
*rb_libtorrent-1.0.2 (18 Oct 2014)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.10.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.10.ebuild
index ced8ba5c4d8e..861f4f89847b 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.10.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.10.ebuild,v 1.9 2014/10/10 18:06:43 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.10.ebuild,v 1.10 2014/11/15 08:33:02 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.7"
@@ -20,7 +20,7 @@ SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
+IUSE="debug doc examples python ssl static-libs test"
RESTRICT="test"
DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild
new file mode 100644
index 000000000000..36da9bed4f61
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17-r1.ebuild,v 1.1 2014/11/15 08:33:02 hwoarang Exp $
+
+EAPI="5"
+PYTHON_DEPEND="python? 2:2.7"
+PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH_OPT="python"
+
+inherit multilib python versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs test"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/boost-1.48:=[python?,threads(+)]
+ >=sys-devel/libtool-2.2
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ local myconf
+
+ # bug 441842
+ myconf="--disable-silent-rules"
+
+ # use multi-threading versions of boost libs
+ if has_version '>=dev-libs/boost-1.52.0-r1'; then
+ myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
+ else
+ myconf+=" --with-boost-system=boost_system-mt \
+ --with-boost-python=boost_python-${PYTHON_ABI}-mt"
+ fi
+
+ local LOGGING
+ use debug && myconf+=" --enable-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
+ $(use_enable static-libs static) \
+ --with-boost-libdir=/usr/$(get_libdir) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc ChangeLog AUTHORS NEWS README
+ if use doc; then
+ dohtml docs/*
+ fi
+}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild
index 2209382f0b44..5253f486a0cb 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild,v 1.5 2014/10/10 18:06:43 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.17.ebuild,v 1.6 2014/11/15 08:33:02 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.7"
@@ -20,7 +20,7 @@ SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
+IUSE="debug doc examples python ssl static-libs test"
RESTRICT="test"
DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild
index 6c775cfda868..12f7e3accfb3 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild,v 1.1 2014/10/18 19:35:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.2.ebuild,v 1.2 2014/11/15 08:33:02 hwoarang Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -23,7 +23,7 @@ IUSE="debug doc examples python ssl static-libs test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND=">=dev-libs/boost-1.53[threads]
+DEPEND=">=dev-libs/boost-1.53:=[threads]
>=sys-devel/libtool-2.2
sys-libs/zlib
examples? ( !net-p2p/mldonkey )