summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-01 08:32:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-01 08:32:25 +0000
commit07181a4b56cb8dfe72c6f7eaecb5b937aa6569f5 (patch)
tree20ad77eefaf847ee9ab3552f88f9bbfedb140e8a /net-libs/rb_libtorrent/rb_libtorrent-0.15.1.ebuild
parentDrop gzip gloable USE flag, bug 326405 (diff)
downloadgentoo-2-07181a4b56cb8dfe72c6f7eaecb5b937aa6569f5.tar.gz
gentoo-2-07181a4b56cb8dfe72c6f7eaecb5b937aa6569f5.tar.bz2
gentoo-2-07181a4b56cb8dfe72c6f7eaecb5b937aa6569f5.zip
Version bump.Fixes bug #325313. Remove old configure options. FIx pthread linking
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-0.15.1.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.1.ebuild
new file mode 100644
index 000000000000..ffd99d893628
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.1.ebuild,v 1.1 2010/07/01 08:32:25 hwoarang Exp $
+
+EAPI="2"
+WANT_AUTOMAKE="1.11.1"
+inherit autotools eutils versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug doc examples python"
+RESTRICT="test"
+
+DEPEND="|| ( >=dev-libs/boost-1.35
+ ( ~dev-libs/boost-1.34.1 dev-cpp/asio ) )
+ python? ( >=dev-libs/boost-1.35.0-r5[python] dev-lang/python:2.6[threads] )
+ =sys-devel/libtool-2.2*
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )" #292998
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ax_pthread_asneeded.patch
+ eautoreconf
+}
+
+src_configure() {
+ # use multi-threading versions of boost libs
+ local BOOST_LIBS="--with-boost-system=boost_system-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-python=boost_python-mt"
+
+ # detect boost version and location, bug 295474
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ local LOGGING
+ use debug && LOGGING="--with-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ --with-zlib=system \
+ ${LOGGING} \
+ --with-boost=${BOOST_INC} \
+ --with-boost-libdir=${BOOST_LIB} \
+ ${BOOST_LIBS}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'emake install failed'
+ dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
+ if use doc ; then
+ dohtml docs/* || die "Could not install HTML documentation"
+ fi
+}