summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-12-31 10:15:54 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-12-31 10:15:54 +0000
commit90e1d6716b815d3deee3cb0efac63f4c2502fb42 (patch)
tree7e3c1e038c20789633b1c1e9cb6793c11fcd4a7a /net-libs/pjsip
parentVersion bump. (diff)
downloadgentoo-2-90e1d6716b815d3deee3cb0efac63f4c2502fb42.tar.gz
gentoo-2-90e1d6716b815d3deee3cb0efac63f4c2502fb42.tar.bz2
gentoo-2-90e1d6716b815d3deee3cb0efac63f4c2502fb42.zip
Revision bump: fix pkgconfig file generation, respect lib directory, wrt bug #496430. Thanks to Nikoli <nikoli AT gmx.us> for discovering this issues
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-libs/pjsip')
-rw-r--r--net-libs/pjsip/ChangeLog9
-rw-r--r--net-libs/pjsip/files/pjsip-2.1-multilib.patch49
-rw-r--r--net-libs/pjsip/pjsip-2.1-r2.ebuild85
3 files changed, 142 insertions, 1 deletions
diff --git a/net-libs/pjsip/ChangeLog b/net-libs/pjsip/ChangeLog
index a3ac0c5729ba..4015aa471dfb 100644
--- a/net-libs/pjsip/ChangeLog
+++ b/net-libs/pjsip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/pjsip
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/ChangeLog,v 1.14 2013/06/17 07:19:34 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/ChangeLog,v 1.15 2013/12/31 10:15:54 pinkbyte Exp $
+
+*pjsip-2.1-r2 (31 Dec 2013)
+
+ 31 Dec 2013; Sergey Popov <pinkbyte@gentoo.org> +pjsip-2.1-r2.ebuild,
+ +files/pjsip-2.1-multilib.patch:
+ Revision bump: fix pkgconfig file generation, respect lib directory, wrt bug
+ #496430. Thanks to Nikoli <nikoli AT gmx.us> for discovering this issues
*pjsip-2.1-r1 (17 Jun 2013)
diff --git a/net-libs/pjsip/files/pjsip-2.1-multilib.patch b/net-libs/pjsip/files/pjsip-2.1-multilib.patch
new file mode 100644
index 000000000000..101476c362b6
--- /dev/null
+++ b/net-libs/pjsip/files/pjsip-2.1-multilib.patch
@@ -0,0 +1,49 @@
+Buildsystem fixes for proper respecting multilib-aware systems
+
+Gentoo bugreport: https://bugs.gentoo.org/show_bug.cgi?id=496430
+
+--- Makefile.orig 2012-03-22 15:15:59.000000000 +0400
++++ Makefile 2013-12-31 13:50:16.434307159 +0400
+@@ -108,14 +108,15 @@
+ prefix = $(ac_prefix)
+
+ install:
+- mkdir -p $(DESTDIR)$(prefix)/lib
+- cp -f $(APP_LIB_FILES) $(DESTDIR)$(prefix)/lib/
++ mkdir -p $(DESTDIR)$(PJ_INSTALL_LIB_DIR)
++ cp -f $(APP_LIB_FILES) $(DESTDIR)$(PJ_INSTALL_LIB_DIR)/
+ mkdir -p $(DESTDIR)$(prefix)/include
+ for d in pjlib pjlib-util pjnath pjmedia pjsip; do \
+ cp -RLf $$d/include/* $(DESTDIR)$(prefix)/include/; \
+ done
+- mkdir -p $(DESTDIR)$(prefix)/lib/pkgconfig
+- sed -e "s!@PREFIX@!$(DESTDIR)$(prefix)!" libpjproject.pc.in | \
++ mkdir -p $(DESTDIR)$(PJ_INSTALL_LIB_DIR)/pkgconfig
++ sed -e "s!@PREFIX@!$(prefix)!" libpjproject.pc.in | \
++ sed -e "s!@LIBDIR@!$(PJ_INSTALL_LIB_DIR)!" | \
+ sed -e "s/@PJ_VERSION@/$(PJ_VERSION)/" | \
+ sed -e "s!@PJ_LDLIBS@!$(PJ_LDLIBS)!" | \
+- sed -e "s!@PJ_INSTALL_CFLAGS@!$(PJ_INSTALL_CFLAGS)!" > $(DESTDIR)/$(prefix)/lib/pkgconfig/libpjproject.pc
++ sed -e "s!@PJ_INSTALL_CFLAGS@!$(PJ_INSTALL_CFLAGS)!" > $(DESTDIR)/$(PJ_INSTALL_LIB_DIR)/pkgconfig/libpjproject.pc
+--- libpjproject.pc.in.orig 2013-12-31 13:51:08.459302831 +0400
++++ libpjproject.pc.in 2013-12-31 13:51:16.857302132 +0400
+@@ -2,7 +2,7 @@
+
+ prefix=@PREFIX@
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
++libdir=@LIBDIR@
+ includedir=${prefix}/include
+
+ Name: libpjproject
+--- build.mak.in.orig 2013-12-31 13:52:22.492296672 +0400
++++ build.mak.in 2013-12-31 13:52:06.722297984 +0400
+@@ -163,7 +163,7 @@
+ # library from the install location (i.e. --prefix)
+ export PJ_INSTALL_DIR := @prefix@
+ export PJ_INSTALL_INC_DIR := $(PJ_INSTALL_DIR)/include
+-export PJ_INSTALL_LIB_DIR := $(PJ_INSTALL_DIR)/lib
++export PJ_INSTALL_LIB_DIR := @libdir@
+ export PJ_INSTALL_CFLAGS := -I$(PJ_INSTALL_INC_DIR) -DPJ_AUTOCONF=1 @CFLAGS@
+ export PJ_INSTALL_CXXFLAGS := $(PJ_INSTALL_CFLAGS)
+ export PJ_INSTALL_LDFLAGS := -L$(PJ_INSTALL_LIB_DIR) $(APP_LDLIBS)
diff --git a/net-libs/pjsip/pjsip-2.1-r2.ebuild b/net-libs/pjsip/pjsip-2.1-r2.ebuild
new file mode 100644
index 000000000000..cc367ca8877f
--- /dev/null
+++ b/net-libs/pjsip/pjsip-2.1-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/pjsip-2.1-r2.ebuild,v 1.1 2013/12/31 10:15:54 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Multimedia communication libraries written in C language for building VoIP applications"
+HOMEPAGE="http://www.pjsip.org/"
+SRC_URI="http://www.pjsip.org/release/${PV}/pjproject-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cli doc examples ext-sound ffmpeg g711 g722 g7221 gsm ilbc l16 oss python speex"
+#small-filter large-filter speex-aec ssl
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ ffmpeg? ( virtual/ffmpeg )
+ gsm? ( media-sound/gsm )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ speex? ( media-libs/speex )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/pjproject-${PV}.0"
+
+src_prepare() {
+ # bug #469582
+ epatch "${FILESDIR}/${P}-new-ffmpeg-workaround.patch"
+ # bug #496430
+ epatch "${FILESDIR}/${P}-multilib.patch"
+
+ epatch_user
+}
+
+src_configure() {
+ # Disable through portage available codecs
+ econf --disable-gsm-codec \
+ --disable-speex-codec \
+ --disable-ilbc-codec \
+ --disable-speex-aec \
+ $(use_enable alsa sound) \
+ $(use_enable oss) \
+ $(use_enable ext-sound) \
+ $(use ffmpeg || echo '--disable-ffmpeg') \
+ $(use_enable g711 g711-codec) \
+ $(use_enable l16 l16-codec) \
+ $(use_enable g722 g722-codec) \
+ $(use_enable g7221 g7221-codec)
+ #$(use_enable small-filter) \
+ #$(use_enable large-filter) \
+ #$(use_enable speex-aec) \
+ #$(use_enable ssl tls) #broken? sflphone doesn't compile if enabled or disabled
+}
+
+src_compile() {
+ emake dep
+ emake -j1
+}
+
+src_install() {
+ DESTDIR="${D}" emake install
+
+ if use cli; then
+ newbin pjsip-apps/bin/pjsua* pjsua
+ fi
+
+ if use python; then
+ pushd pjsip-apps/src/python
+ python setup.py install --prefix="${D}/usr/"
+ popd
+ fi
+
+ if use doc; then
+ dodoc README.txt README-RTEMS
+ fi
+
+ if use examples; then
+ docinto examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc pjsip-apps/src/samples/*
+ fi
+}