summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-08 14:41:21 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-08 14:41:21 +0000
commit9e2519ce93e2b4c0baec428e50bf04e9f30e5305 (patch)
tree7bc1ec8947e4e4e4cfa25218d6441ef802b6e8fa /net-libs/opal
parentversion bump (diff)
downloadgentoo-2-9e2519ce93e2b4c0baec428e50bf04e9f30e5305.tar.gz
gentoo-2-9e2519ce93e2b4c0baec428e50bf04e9f30e5305.tar.bz2
gentoo-2-9e2519ce93e2b4c0baec428e50bf04e9f30e5305.zip
version bump
(Portage version: 2.1.3.12)
Diffstat (limited to 'net-libs/opal')
-rw-r--r--net-libs/opal/ChangeLog7
-rw-r--r--net-libs/opal/files/digest-opal-2.2.113
-rw-r--r--net-libs/opal/opal-2.2.11.ebuild105
3 files changed, 114 insertions, 1 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index 4f47c99c03ff..44399c482232 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.34 2007/06/03 21:58:58 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.35 2007/10/08 14:41:21 genstef Exp $
+
+*opal-2.2.11 (08 Oct 2007)
+
+ 08 Oct 2007; Stefan Schweizer <genstef@gentoo.org> +opal-2.2.11.ebuild:
+ version bump
03 Jun 2007; Stefan Schweizer <genstef@gentoo.org> opal-2.2.8.ebuild:
replace-flags -Os -O2 for bug 180718
diff --git a/net-libs/opal/files/digest-opal-2.2.11 b/net-libs/opal/files/digest-opal-2.2.11
new file mode 100644
index 000000000000..03dc37f8fb44
--- /dev/null
+++ b/net-libs/opal/files/digest-opal-2.2.11
@@ -0,0 +1,3 @@
+MD5 eb4a9c0c9ea93ec95c876aaeadf83936 opal-2.2.11.tar.gz 4165191
+RMD160 7ef2d505cc52eca9136ca10a865c7b7f3a8dc2b5 opal-2.2.11.tar.gz 4165191
+SHA256 0990ead39728f23a1ce39997f41a8484c59809ccec0e770b9bc4f795a85a29c4 opal-2.2.11.tar.gz 4165191
diff --git a/net-libs/opal/opal-2.2.11.ebuild b/net-libs/opal/opal-2.2.11.ebuild
new file mode 100644
index 000000000000..754b93b2bed2
--- /dev/null
+++ b/net-libs/opal/opal-2.2.11.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-2.2.11.ebuild,v 1.1 2007/10/08 14:41:21 genstef Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="OPAL library, used by Ekiga"
+HOMEPAGE="http://www.ekiga.org"
+SRC_URI="http://www.ekiga.org/admin/downloads/latest/sources/sources/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="novideo noaudio debug"
+
+RDEPEND="~dev-libs/pwlib-1.10.$((${PV##*.}-1))
+ >=media-video/ffmpeg-0.4.7"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # Makefile is currently broken with NOTRACE=1, fix that
+ epatch "${FILESDIR}"/${PN}-2.1.1-notrace.diff
+}
+
+src_compile() {
+ tc-export CC CXX
+ local makeopts
+ local myconf
+
+ # remove -fstack-protector, may cause problems (bug #75259)
+ filter-flags -fstack-protector
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ # compile with PTRACING if the user wants to debug stuff
+ if ! use debug; then
+ makeopts="${makeopts} NOTRACE=1"
+ fi
+
+ # doesn't work with osptoolkit-3.3.1
+ # iax2 support is missing in the tarball, disable it too
+ myconf="--disable-transnexusosp --disable-iax --enable-localspeex"
+
+ use novideo \
+ && myconf="${myconf} --disable-video"
+
+ use noaudio \
+ && myconf="${myconf} --disable-audio"
+
+ econf \
+ PWLIBDIR=/usr/share/pwlib \
+ OPALDIR="${S}" \
+ ${myconf} || die "configure failed"
+
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPAL_ARCH ALT_ARCH OPAL_SUFFIX
+ local makeopts libdir libname
+
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ if ! use debug; then
+ OPAL_SUFFIX="n"
+ makeopts="NOTRACE=1"
+ else
+ OPAL_SUFFIX="r"
+ fi
+
+ # use ptlib-config to get the right values here (for hppa, amd64 ...)
+ OPAL_ARCH="$(ptlib-config --ostype)_$(ptlib-config --machtype)_${OPAL_SUFFIX}"
+
+ # set ALT_ARCH
+ if use debug; then
+ ALT_ARCH=${OPAL_ARCH/_r/_n}
+ else
+ ALT_ARCH=${OPAL_ARCH/_n/_r}
+ fi
+
+ ###
+ # Install stuff
+ #
+ make PREFIX=/usr DESTDIR="${D}" \
+ ${makeopts} install || die "install failed"
+
+ libdir=$(get_libdir)
+ libname="libopal_${OPAL_ARCH}.so.${PV}"
+
+ # compat symlinks
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so.${pv}
+ done
+ dosym ${libname} /usr/${libdir}/libopal_${OPAL_ARCH}.so
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so
+
+ ###
+ # Compatibility "hacks"
+ #
+
+ # install version.h into $OPALDIR
+ insinto /usr/share/opal
+ doins version.h
+}