summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
commit541f14235634ec9414e89e8089beca533ffca899 (patch)
tree86d726368da8d5082e4e7b43278d3a356de0605c /net-libs/nss_ldap
parent*** empty log message *** (diff)
downloadgentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.gz
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.bz2
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.zip
*** empty log message ***
Diffstat (limited to 'net-libs/nss_ldap')
-rw-r--r--net-libs/nss_ldap/files/digest-nss_ldap-1231
-rw-r--r--net-libs/nss_ldap/nss_ldap-123.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/nss_ldap/files/digest-nss_ldap-123 b/net-libs/nss_ldap/files/digest-nss_ldap-123
new file mode 100644
index 000000000000..a0b10d1a8580
--- /dev/null
+++ b/net-libs/nss_ldap/files/digest-nss_ldap-123
@@ -0,0 +1 @@
+MD5 b33dbfbdee22d1d6dd29888431ff4304 nss_ldap-123.tar.gz
diff --git a/net-libs/nss_ldap/nss_ldap-123.ebuild b/net-libs/nss_ldap/nss_ldap-123.ebuild
new file mode 100644
index 000000000000..46746b01ed6f
--- /dev/null
+++ b/net-libs/nss_ldap/nss_ldap-123.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nss_ldap/nss_ldap-123.ebuild,v 1.1 2000/11/26 20:54:19 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/nss_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/"${A}
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=net-nds/openldap-1.2.11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s/^NSFLAGS/#NSFLAGS/" \
+ -e "s/-lsasl//" \
+ -e "s/-O/${CFLAGS}/" Makefile.linux.openldap2 > Makefile
+}
+
+src_compile() {
+ cd ${S}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dolib.so libnss_ldap-2.*.so
+ preplib /
+ into /usr
+ doman *.1
+ insinto /etc
+ doins nsswitch.ldap
+ insinto /usr/bin
+ insopts -m755
+ doins ldaptest.pl
+ dodoc ldap.conf ANNOUNCE BUGS ChangeLog CONTRIBUTORS COPYING.LIB
+ dodoc CVSVersionInfo.txt README rfc*.txt nsswitch.test
+}
+
+
+
+
+
+