summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-16 01:21:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-16 01:21:35 +0000
commitc96c860c5105216186862365c548912342226fcf (patch)
treed1ef44f8eb57e1b2002a5c420e0ca91e0315b727 /net-libs/neon
parentRemove useless code and simplify doc handling (diff)
downloadgentoo-2-c96c860c5105216186862365c548912342226fcf.tar.gz
gentoo-2-c96c860c5105216186862365c548912342226fcf.tar.bz2
gentoo-2-c96c860c5105216186862365c548912342226fcf.zip
Version bump.
(Portage version: 2.2_rc96_p20/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/neon')
-rw-r--r--net-libs/neon/ChangeLog8
-rw-r--r--net-libs/neon/neon-0.29.5.ebuild104
2 files changed, 111 insertions, 1 deletions
diff --git a/net-libs/neon/ChangeLog b/net-libs/neon/ChangeLog
index f15befc55ed2..d21246a2d907 100644
--- a/net-libs/neon/ChangeLog
+++ b/net-libs/neon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/neon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/ChangeLog,v 1.4 2010/10/01 19:37:47 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/ChangeLog,v 1.5 2010/10/16 01:21:35 arfrever Exp $
+
+*neon-0.29.5 (16 Oct 2010)
+
+ 16 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +neon-0.29.5.ebuild:
+ Version bump.
*neon-0.29.4 (01 Oct 2010)
diff --git a/net-libs/neon/neon-0.29.5.ebuild b/net-libs/neon/neon-0.29.5.ebuild
new file mode 100644
index 000000000000..9939e863c099
--- /dev/null
+++ b/net-libs/neon/neon-0.29.5.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/neon-0.29.5.ebuild,v 1.1 2010/10/16 01:21:35 arfrever Exp $
+
+EAPI="3"
+
+inherit autotools libtool versionator
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc expat gnutls kerberos libproxy nls pkcs11 ssl zlib"
+IUSE_LINGUAS="cs de fr ja nn pl ru tr zh_CN"
+for lingua in ${IUSE_LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+unset lingua
+RESTRICT="test"
+
+RDEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ gnutls? (
+ >=net-libs/gnutls-2.0
+ pkcs11? ( dev-libs/pakchois )
+ )
+ !gnutls? ( ssl? (
+ >=dev-libs/openssl-0.9.6f
+ pkcs11? ( dev-libs/pakchois )
+ ) )
+ kerberos? ( virtual/krb5 )
+ libproxy? ( net-libs/libproxy )
+ nls? ( virtual/libintl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local lingua linguas
+ for lingua in ${IUSE_LINGUAS}; do
+ use linguas_${lingua} && linguas+=" ${lingua}"
+ done
+ sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
+
+ AT_M4DIR="macros" eautoreconf
+
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+
+ if has_version sys-libs/glibc; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf+=" --enable-threadsafe-ssl=posix"
+ fi
+
+ if use expat; then
+ myconf+=" --with-expat"
+ else
+ myconf+=" --with-libxml2"
+ fi
+
+ if use gnutls; then
+ myconf+=" --with-ssl=gnutls --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use ssl; then
+ myconf+=" --with-ssl=openssl"
+ fi
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with kerberos gssapi) \
+ $(use_with libproxy) \
+ $(use_enable nls) \
+ $(use_with pkcs11 pakchois) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-lib install-headers install-config install-nls || die "emake install failed"
+
+ if use doc; then
+ emake DESTDIR="${D}" install-docs || die "emake install-docs failed"
+ fi
+
+ dodoc AUTHORS BUGS NEWS README THANKS TODO
+ doman doc/man/*.[1-8]
+}
+
+pkg_postinst() {
+ ewarn "Neon has a policy of breaking API across minor versions, this means"
+ ewarn "that any package that links against Neon may be broken after"
+ ewarn "updating. They will remain broken until they are ported to the"
+ ewarn "new API. You can downgrade Neon to the previous version by doing:"
+ ewarn
+ ewarn " emerge --oneshot '<${CATEGORY}/${PN}-$(get_version_component_range 1-2 ${PV})'"
+ ewarn
+ ewarn "You may also have to downgrade any package that has not been"
+ ewarn "ported to the new API yet."
+}