summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-07-05 17:13:31 +0000
committerOlivier Crête <tester@gentoo.org>2009-07-05 17:13:31 +0000
commit4b311e090d926fde21551a9c29ca1da6fb1af1ab (patch)
tree8786f4365d5114e7083721cc91a83e51a827256b /net-libs/loudmouth
parentinitial ebuild, bug #224985 (diff)
downloadgentoo-2-4b311e090d926fde21551a9c29ca1da6fb1af1ab.tar.gz
gentoo-2-4b311e090d926fde21551a9c29ca1da6fb1af1ab.tar.bz2
gentoo-2-4b311e090d926fde21551a9c29ca1da6fb1af1ab.zip
Import patches from debian
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/ChangeLog10
-rw-r--r--net-libs/loudmouth/files/loudmouth-1.4.3-drop-stanzas-on-fail.patch47
-rw-r--r--net-libs/loudmouth/files/loudmouth-1.4.3-fix-sasl-md5-digest-uri.patch24
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild65
4 files changed, 145 insertions, 1 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 1eb5a82d0e10..9dfffbd4b911 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/loudmouth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.88 2009/06/17 22:09:46 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.89 2009/07/05 17:13:31 tester Exp $
+
+*loudmouth-1.4.3-r1 (05 Jul 2009)
+
+ 05 Jul 2009; Olivier Crête <tester@gentoo.org>
+ +files/loudmouth-1.4.3-drop-stanzas-on-fail.patch,
+ +files/loudmouth-1.4.3-fix-sasl-md5-digest-uri.patch,
+ +loudmouth-1.4.3-r1.ebuild:
+ Import patches from debian
17 Jun 2009; Gilles Dartiguelongue <eva@gentoo.org>
-loudmouth-1.2.3.ebuild, -loudmouth-1.4.2.ebuild,
diff --git a/net-libs/loudmouth/files/loudmouth-1.4.3-drop-stanzas-on-fail.patch b/net-libs/loudmouth/files/loudmouth-1.4.3-drop-stanzas-on-fail.patch
new file mode 100644
index 000000000000..05c76c590b58
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-1.4.3-drop-stanzas-on-fail.patch
@@ -0,0 +1,47 @@
+
+From: Sjoerd Simons <sjoerd.simons@collabora.co.uk>
+Date: Tue, 13 Jan 2009 11:28:44 +0000
+Subject: [PATCH] Drop stanzas when failing to convert them to LmMessages
+
+when a stanza comes in that for some reason can't be parsed into an LmMessage,
+just drop them on the floor instead of blocking the parser. I've seen this
+issue happen in practise because some (buggy?) client sending an iq with a
+prefix e.g. <client:iq xmlns:client="jabber:client" ... />
+---
+ loudmouth/lm-parser.c | 15 ++++++---------
+ 1 files changed, 6 insertions(+), 9 deletions(-)
+
+diff --git a/loudmouth/lm-parser.c b/loudmouth/lm-parser.c
+index 1938d56..89f6675 100644
+--- a/loudmouth/lm-parser.c
++++ b/loudmouth/lm-parser.c
+@@ -151,19 +151,16 @@ parser_end_node_cb (GMarkupParseContext *context,
+ if (!m) {
+ g_warning ("Couldn't create message: %s\n",
+ parser->cur_root->name);
+- return;
+- }
+-
+- g_log (LM_LOG_DOMAIN, LM_LOG_LEVEL_PARSER,
++ } else {
++ g_log (LM_LOG_DOMAIN, LM_LOG_LEVEL_PARSER,
+ "Have a new message\n");
+- if (parser->function) {
+- (* parser->function) (parser, m, parser->user_data);
++ if (parser->function) {
++ (* parser->function) (parser, m, parser->user_data);
++ }
++ lm_message_unref (m);
+ }
+
+- lm_message_unref (m);
+ lm_message_node_unref (parser->cur_root);
+-
+-
+ parser->cur_node = parser->cur_root = NULL;
+ } else {
+ LmMessageNode *tmp_node;
+--
+1.5.6.5
+
+
diff --git a/net-libs/loudmouth/files/loudmouth-1.4.3-fix-sasl-md5-digest-uri.patch b/net-libs/loudmouth/files/loudmouth-1.4.3-fix-sasl-md5-digest-uri.patch
new file mode 100644
index 000000000000..5bca69c0c15e
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-1.4.3-fix-sasl-md5-digest-uri.patch
@@ -0,0 +1,24 @@
+diff --git a/loudmouth/lm-connection.c b/loudmouth/lm-connection.c
+index 21c1bc2..ae8de94 100644
+--- a/loudmouth/lm-connection.c
++++ b/loudmouth/lm-connection.c
+@@ -1441,11 +1441,18 @@ lm_connection_authenticate (LmConnection *connection,
+ connection->effective_jid = g_strdup_printf ("%s/%s",
+ connection->jid, connection->resource);
+
+ if (connection->use_sasl) {
++ gchar *domain = NULL;
++
++ if (!connection_get_server_from_jid (connection->jid, &domain)) {
++ domain = g_strdup (connection->server);
++ }
++
+ lm_sasl_authenticate (connection->sasl,
+ username, password,
+- connection->server,
++ domain,
+ connection_sasl_auth_finished);
++ g_free (domain);
+
+ connection->features_cb =
+ lm_message_handler_new (connection_features_cb,
diff --git a/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild b/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..761a4e842007
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild,v 1.1 2009/07/05 17:13:31 tester Exp $
+
+inherit autotools gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://www.loudmouth-project.org/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="asyncns doc ssl debug test"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1.4.0 )
+ asyncns? ( net-libs/libasyncns )"
+# FIXME:
+# openssl dropped because of bug #216705
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )
+ >=dev-util/gtk-doc-am-1"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug)"
+
+ if use ssl; then
+ G2CONF="${G2CONF} --with-ssl=gnutls"
+ else
+ G2CONF="${G2CONF} --with-ssl=no"
+ fi
+
+ if use asyncns; then
+ G2CONF="${G2CONF} --with-asyncns=system"
+ else
+ G2CONF="${G2CONF} --without-asyncns"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Use system libasyncns, bug #236844
+ epatch "${FILESDIR}/${P}-asyncns-system.patch"
+
+ # Fix detection of gnutls-2.8, bug #272027
+ epatch "${FILESDIR}/${P}-gnutls28.patch"
+
+ # Fix digest auth with SRV (or similar)
+ # Upstream: http://loudmouth.lighthouseapp.com/projects/17276-libloudmouth/tickets/44-md5-digest-uri-not-set-correctly-when-using-srv
+ epatch "${FILESDIR}/${P}-fix-sasl-md5-digest-uri.patch"
+
+ # Drop stanzas when failing to convert them to LmMessages
+ # From debian..
+ epatch "${FILESDIR}/${P}-drop-stanzas-on-fail.patch"
+
+ eautoreconf
+}