summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-04-07 13:52:01 +0000
committerIan Delaney <idella4@gentoo.org>2015-04-07 13:52:01 +0000
commitd176820d432ed99d5ce81be9239de36591a8c399 (patch)
treead471580974665f15c03e98289930ed1e9f59b32 /net-libs/libvncserver
parentAdd missing dependency (diff)
downloadgentoo-2-d176820d432ed99d5ce81be9239de36591a8c399.tar.gz
gentoo-2-d176820d432ed99d5ce81be9239de36591a8c399.tar.bz2
gentoo-2-d176820d432ed99d5ce81be9239de36591a8c399.zip
bump; add required patch sourced from upstream, setting herd to proxy-maintainers and proxy maintainer to Alex Xu, all wrt sec bug #523590
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'net-libs/libvncserver')
-rw-r--r--net-libs/libvncserver/ChangeLog10
-rw-r--r--net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch52
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.10.ebuild67
-rw-r--r--net-libs/libvncserver/metadata.xml5
4 files changed, 132 insertions, 2 deletions
diff --git a/net-libs/libvncserver/ChangeLog b/net-libs/libvncserver/ChangeLog
index 1664a288dddc..74d3ca212634 100644
--- a/net-libs/libvncserver/ChangeLog
+++ b/net-libs/libvncserver/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libvncserver
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/ChangeLog,v 1.86 2015/03/02 09:29:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/ChangeLog,v 1.87 2015/04/07 13:52:01 idella4 Exp $
+
+*libvncserver-0.9.10 (07 Apr 2015)
+
+ 07 Apr 2015; Ian Delaney <idella4@gentoo.org>
+ +files/libvncserver-0.9.10-libva-1.0.patch, +libvncserver-0.9.10.ebuild,
+ metadata.xml:
+ bump; add required patch sourced from upstream, setting herd to proxy-
+ maintainers and proxy maintainer to Alex Xu, all wrt sec bug #523590
02 Mar 2015; Agostino Sarubbo <ago@gentoo.org> libvncserver-0.9.9-r3.ebuild:
Stable for ppc, wrt bug #526032
diff --git a/net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch b/net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch
new file mode 100644
index 000000000000..2e6939e8860f
--- /dev/null
+++ b/net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch
@@ -0,0 +1,52 @@
+commit 7b6243157f042a7bde353abc6fb22aadad6d9e2d
+Author: Floris Bos <bos@je-eigen-domein.nl>
+Date: 2014-12-29 00:02:33 +0100
+
+ Fix libva related compile errors
+
+ - Make h264.c compile with recent libva version by including va_compat.h
+ - Only enable libva if libva-x11 is installed
+ - Modified configure help text
+ Previous help text suggested libva was only build when --with-libva
+ was specified, while actual behavior is to build it by default.
+
+ Warning: THIS CODE IS UNTESTED. Lacking a h.264 capable VNC server
+ Also no attempt is made to support platforms not using X11
+
+ Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
+
+diff --git a/configure.ac b/configure.ac
+index ca9f3b3..fe8b1de 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -150,12 +150,11 @@ AM_CONDITIONAL(HAVE_LIBSSL, test ! -z "$SSL_LIBS")
+
+
+ # See if we want libva support
+-# TODO: check if library actually exists
+ AH_TEMPLATE(CONFIG_LIBVA, [Build libva support])
+ AC_ARG_WITH(libva,
+-[ --with-libva build libva support],,)
++[ --without-libva disable support for libva],,)
+ if test "x$with_libva" != "xno"; then
+- AC_CHECK_LIB(va, vaInitialize,
++ AC_CHECK_LIB(va-x11, vaGetDisplay,
+ VA_LIBS="-lva -lva-x11"
+ [AC_DEFINE(CONFIG_LIBVA) CONFIG_LIBVA="true"], ,)
+ fi
+diff --git a/libvncclient/h264.c b/libvncclient/h264.c
+index 1d94454..c63a713 100644
+--- a/libvncclient/h264.c
++++ b/libvncclient/h264.c
+@@ -20,6 +20,10 @@
+ #ifdef LIBVNCSERVER_CONFIG_LIBVA
+
+ #include <X11/Xlib.h>
++#include <va/va_version.h>
++#if VA_CHECK_VERSION(0,34,0)
++#include <va/va_compat.h>
++#endif
+ #include <va/va_x11.h>
+
+ enum _slice_types {
+
diff --git a/net-libs/libvncserver/libvncserver-0.9.10.ebuild b/net-libs/libvncserver/libvncserver-0.9.10.ebuild
new file mode 100644
index 000000000000..922bde3f4451
--- /dev/null
+++ b/net-libs/libvncserver/libvncserver-0.9.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libvncserver/libvncserver-0.9.10.ebuild,v 1.1 2015/04/07 13:52:01 idella4 Exp $
+
+EAPI="5"
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="library for creating vnc servers"
+HOMEPAGE="http://libvncserver.sourceforge.net/"
+SRC_URI="https://github.com/LibVNC/libvncserver/archive/LibVNCServer-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+24bpp gcrypt gnutls ipv6 +jpeg +png ssl static-libs test threads vaapi +zlib"
+
+DEPEND="
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gnutls? (
+ >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}]
+ )
+ !gnutls? (
+ ssl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+ )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ vaapi? ( >=x11-libs/libva-1.2.1-r1[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-LibVNCServer-${PV}
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ # https://github.com/LibVNC/libvncserver/issues/11
+ epatch "${FILESDIR}/${P}-libva-1.0.patch"
+
+ sed -i -r \
+ -e "/^SUBDIRS/s:\<$(usex test 'test|' '')client_examples|examples\>::g" \
+ Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(use_with 24bpp) \
+ $(use_with gnutls) \
+ $(usex gnutls --with-gcrypt $(use_with gcrypt)) \
+ $(usex gnutls --without-ssl $(use_with ssl)) \
+ $(use_with ipv6) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with zlib)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/net-libs/libvncserver/metadata.xml b/net-libs/libvncserver/metadata.xml
index 2b9b4012438a..816febc93599 100644
--- a/net-libs/libvncserver/metadata.xml
+++ b/net-libs/libvncserver/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <herd>proxy-maintainers</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ <description>Proxy maintainer</description>
</maintainer>
<longdescription>
If you don't know VNC, have a look at the original VNC or at Tridia