summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-22 10:34:55 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-22 10:34:55 +0000
commit20de9431a6f46f70e7dccd2c970bc302d9c61f9a (patch)
treec18b8715a983b089ec73b0fbd1669d6b338c905c /net-libs/libnice
parentfix typo (diff)
downloadgentoo-2-20de9431a6f46f70e7dccd2c970bc302d9c61f9a.tar.gz
gentoo-2-20de9431a6f46f70e7dccd2c970bc302d9c61f9a.tar.bz2
gentoo-2-20de9431a6f46f70e7dccd2c970bc302d9c61f9a.zip
Version bump
(Portage version: 2.1.11.19/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libnice')
-rw-r--r--net-libs/libnice/ChangeLog7
-rw-r--r--net-libs/libnice/libnice-0.1.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/net-libs/libnice/ChangeLog b/net-libs/libnice/ChangeLog
index a183f81e77df..a9e03da5e38b 100644
--- a/net-libs/libnice/ChangeLog
+++ b/net-libs/libnice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.33 2012/06/30 13:05:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.34 2012/09/22 10:34:55 pacho Exp $
+
+*libnice-0.1.3 (22 Sep 2012)
+
+ 22 Sep 2012; Pacho Ramos <pacho@gentoo.org> +libnice-0.1.3.ebuild:
+ Version bump
*libnice-0.1.2 (30 Jun 2012)
diff --git a/net-libs/libnice/libnice-0.1.3.ebuild b/net-libs/libnice/libnice-0.1.3.ebuild
new file mode 100644
index 000000000000..6ee7aa17e5c4
--- /dev/null
+++ b/net-libs/libnice/libnice-0.1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.3.ebuild,v 1.1 2012/09/22 10:34:55 pacho Exp $
+
+EAPI="4"
+
+DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
+HOMEPAGE="http://nice.freedesktop.org/wiki/"
+SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+gstreamer upnp"
+
+RDEPEND=">=dev-libs/glib-2.13:2
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ upnp? ( >=net-libs/gupnp-igd-0.1.3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --disable-static \
+ $(use_with gstreamer gstreamer-0.10) \
+ $(use_enable upnp gupnp)
+}
+
+src_install() {
+ default
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}