summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-28 10:22:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-28 10:22:41 +0000
commite5efc7f8d5bf09af7b59fb8af517dc84a4d2173c (patch)
treeee6b88de163e78f4966bf27c9ff725fe9f9e5114 /net-libs/libesmtp
parentVersion bump. (diff)
downloadgentoo-2-e5efc7f8d5bf09af7b59fb8af517dc84a4d2173c.tar.gz
gentoo-2-e5efc7f8d5bf09af7b59fb8af517dc84a4d2173c.tar.bz2
gentoo-2-e5efc7f8d5bf09af7b59fb8af517dc84a4d2173c.zip
USE="static-libs" and keep .la files (they are used for loading plugins). Fix documentation installation.
(Portage version: 2.2_rc87/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libesmtp')
-rw-r--r--net-libs/libesmtp/ChangeLog6
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.6.ebuild33
2 files changed, 17 insertions, 22 deletions
diff --git a/net-libs/libesmtp/ChangeLog b/net-libs/libesmtp/ChangeLog
index 4fd96741e367..3a472accba98 100644
--- a/net-libs/libesmtp/ChangeLog
+++ b/net-libs/libesmtp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libesmtp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/ChangeLog,v 1.45 2010/09/25 02:37:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/ChangeLog,v 1.46 2010/09/28 10:22:41 ssuominen Exp $
+
+ 28 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> libesmtp-1.0.6.ebuild:
+ USE="static-libs" and keep .la files (they are used for loading plugins).
+ Fix documentation installation.
*libesmtp-1.0.6 (25 Sep 2010)
diff --git a/net-libs/libesmtp/libesmtp-1.0.6.ebuild b/net-libs/libesmtp/libesmtp-1.0.6.ebuild
index f8ff3613050c..95949698808d 100644
--- a/net-libs/libesmtp/libesmtp-1.0.6.ebuild
+++ b/net-libs/libesmtp/libesmtp-1.0.6.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-1.0.6.ebuild,v 1.1 2010/09/25 02:37:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-1.0.6.ebuild,v 1.2 2010/09/28 10:22:41 ssuominen Exp $
EAPI=3
-
-inherit toolchain-funcs libtool
+inherit libtool
DESCRIPTION="lib that implements the client side of the SMTP protocol"
HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/"
@@ -13,36 +12,28 @@ SRC_URI="http://www.stafford.uklinux.net/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="debug ssl threads"
+IUSE="debug ssl static-libs threads"
-DEPEND="ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
src_prepare() {
elibtoolize
}
src_configure() {
- local myconf
-
- if [[ $(gcc-major-version) == 2 ]]; then
- myconf="${myconf} --disable-isoc"
- fi
-
econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
--enable-all \
- $(use_with ssl openssl) \
$(use_enable threads pthreads) \
$(use_enable debug) \
- ${myconf}
-
- if [[ $(gcc-major-version) == 3 ]] && [[ $(gcc-minor-version) == 3 ]]; then
- sed -i "s:-Wsign-promo::g" Makefile
- fi
+ $(use_with ssl openssl)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS INSTALL ChangeLog NEWS Notes README TODO
- dohtml doc/api.xml
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS Notes README TODO
+ insinto /usr/share/doc/${PF}/xml
+ doins doc/api.xml
}