summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-11-15 13:01:55 +0000
committerMichael Weber <xmw@gentoo.org>2014-11-15 13:01:55 +0000
commitd4778a60eb1870ed47e0bc2724726704bba8f08e (patch)
tree2ac0cf5295df37071be7fffce60bfdb73f90e65a /net-libs/libdom
parentnew ebuild written by B-Man, new RDEP for bump of enaml, to be proxy maintain... (diff)
downloadgentoo-2-d4778a60eb1870ed47e0bc2724726704bba8f08e.tar.gz
gentoo-2-d4778a60eb1870ed47e0bc2724726704bba8f08e.tar.bz2
gentoo-2-d4778a60eb1870ed47e0bc2724726704bba8f08e.zip
Version bump, new build system version, glib2.20 issue
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-libs/libdom')
-rw-r--r--net-libs/libdom/ChangeLog8
-rw-r--r--net-libs/libdom/files/libdom-0.1.1-glibc2.20.patch19
-rw-r--r--net-libs/libdom/libdom-0.1.1.ebuild42
3 files changed, 68 insertions, 1 deletions
diff --git a/net-libs/libdom/ChangeLog b/net-libs/libdom/ChangeLog
index 7c426cb8529b..6407056a733c 100644
--- a/net-libs/libdom/ChangeLog
+++ b/net-libs/libdom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libdom
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libdom/ChangeLog,v 1.8 2014/07/26 11:46:40 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdom/ChangeLog,v 1.9 2014/11/15 13:01:55 xmw Exp $
+
+*libdom-0.1.1 (15 Nov 2014)
+
+ 15 Nov 2014; Michael Weber <xmw@gentoo.org>
+ +files/libdom-0.1.1-glibc2.20.patch, +libdom-0.1.1.ebuild:
+ Version bump, new build system version, glib2.20 issue
26 Jul 2014; Andreas K. Huettel <dilfridge@gentoo.org>
libdom-0.0.1_pre20120705.ebuild, libdom-0.0.1.ebuild:
diff --git a/net-libs/libdom/files/libdom-0.1.1-glibc2.20.patch b/net-libs/libdom/files/libdom-0.1.1-glibc2.20.patch
new file mode 100644
index 000000000000..8a8f4e31349e
--- /dev/null
+++ b/net-libs/libdom/files/libdom-0.1.1-glibc2.20.patch
@@ -0,0 +1,19 @@
+--- libdom-0.1.1/Makefile
++++ libdom-0.1.1/Makefile
+@@ -15,15 +15,11 @@
+ WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wnested-externs
+-# BeOS/Haiku standard library headers generate warnings
+-ifneq ($(TARGET),beos)
+- WARNFLAGS := $(WARNFLAGS) -Werror
+-endif
+ # AmigaOS needs this to avoid warnings
+ ifeq ($(TARGET),amiga)
+ CFLAGS := -U__STRICT_ANSI__ $(CFLAGS)
+ endif
+-CFLAGS := -D_BSD_SOURCE -I$(CURDIR)/include/ \
++CFLAGS := -D_DEFAULT_SOURCE -I$(CURDIR)/include/ \
+ -I$(CURDIR)/src -I$(CURDIR)/binding $(WARNFLAGS) $(CFLAGS)
+ # Some gcc2 versions choke on -std=c99, and it doesn't know about it anyway
+ ifneq ($(GCCVER),2)
diff --git a/net-libs/libdom/libdom-0.1.1.ebuild b/net-libs/libdom/libdom-0.1.1.ebuild
new file mode 100644
index 000000000000..d46f339efac0
--- /dev/null
+++ b/net-libs/libdom/libdom-0.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdom/libdom-0.1.1.ebuild,v 1.1 2014/11/15 13:01:55 xmw Exp $
+
+EAPI=5
+
+NETSURF_BUILDSYSTEM=buildsystem-1.2
+inherit netsurf
+
+DESCRIPTION="implementation of the W3C DOM, written in C"
+HOMEPAGE="http://www.netsurf-browser.org/projects/libdom/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k-mint"
+IUSE="expat test xml"
+
+RDEPEND=">=dev-libs/libparserutils-0.2.0-r1[static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/libwapcaplet-0.2.1-r1[static-libs?,${MULTILIB_USEDEP}]
+ >=net-libs/libhubbub-0.3.0-r1[static-libs?,${MULTILIB_USEDEP}]
+ xml? (
+ expat? ( >=dev-libs/expat-2.1.0-r3[static-libs?,${MULTILIB_USEDEP}] )
+ !expat? ( >=dev-libs/libxml2-2.9.1-r4[static-libs?,${MULTILIB_USEDEP}] )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-perl/XML-XPath
+ dev-perl/libxml-perl
+ dev-perl/Switch )"
+
+REQUIRED_USE="test? ( xml )"
+
+PATCHES=( "${FILESDIR}"/${P}-glibc2.20.patch )
+
+src_configure() {
+ netsurf_src_configure
+
+ netsurf_makeconf+=(
+ WITH_EXPAT_BINDING=$(usex xml $(usex expat yes no) no)
+ WITH_LIBXML_BINDING=$(usex xml $(usex expat no yes) no)
+ )
+}