summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-22 18:24:14 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-22 18:24:14 +0000
commit96554281c9977454e76e88ff6fb03a3e3ce8e17a (patch)
tree6ef51d2da7fa51f4b2e0e6c80f2c2e66d6eda3fc /net-libs/libdmapsharing
parentUpdate evolution-data-server dependency to include only versions with the old... (diff)
downloadgentoo-2-96554281c9977454e76e88ff6fb03a3e3ce8e17a.tar.gz
gentoo-2-96554281c9977454e76e88ff6fb03a3e3ce8e17a.tar.bz2
gentoo-2-96554281c9977454e76e88ff6fb03a3e3ce8e17a.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/libdmapsharing')
-rw-r--r--net-libs/libdmapsharing/ChangeLog7
-rw-r--r--net-libs/libdmapsharing/libdmapsharing-2.9.17.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/net-libs/libdmapsharing/ChangeLog b/net-libs/libdmapsharing/ChangeLog
index d624c2181bce..5119b7105f44 100644
--- a/net-libs/libdmapsharing/ChangeLog
+++ b/net-libs/libdmapsharing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libdmapsharing
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libdmapsharing/ChangeLog,v 1.16 2013/02/02 23:03:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdmapsharing/ChangeLog,v 1.17 2013/04/22 18:24:14 pacho Exp $
+
+*libdmapsharing-2.9.17 (22 Apr 2013)
+
+ 22 Apr 2013; Pacho Ramos <pacho@gentoo.org> +libdmapsharing-2.9.17.ebuild:
+ Version bump
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> libdmapsharing-2.9.15.ebuild:
Add ~arm, wrt bug #449220
diff --git a/net-libs/libdmapsharing/libdmapsharing-2.9.17.ebuild b/net-libs/libdmapsharing/libdmapsharing-2.9.17.ebuild
new file mode 100644
index 000000000000..c385b2027518
--- /dev/null
+++ b/net-libs/libdmapsharing/libdmapsharing-2.9.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdmapsharing/libdmapsharing-2.9.17.ebuild,v 1.1 2013/04/22 18:24:14 pacho Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A library that implements the DMAP family of protocols"
+HOMEPAGE="http://www.flyn.org/projects/libdmapsharing"
+SRC_URI="http://www.flyn.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Vala/libgee/gtk+:2 is only used when maintainer-mode is enabled
+# Doesn't seem to be used for anything...
+# TODO: implement tests (requires dev-libs/check)
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+
+ >=net-dns/avahi-0.6
+ >=net-libs/libsoup-2.32:2.4
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Fix documentation slotting
+ sed "s/^\(DOC_MODULE\).*/\1 = ${PN}-${SLOT}/" \
+ -i doc/Makefile.am doc/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf --disable-maintainer-mode \
+ --with-mdns=avahi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}