summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-11-30 11:19:07 +0000
committerMichał Górny <mgorny@gentoo.org>2014-11-30 11:19:07 +0000
commitb116cc52019f4021a132957162cdaf3e13a4014b (patch)
tree26b2c6933f58a1431069e879d4368189e8e6683a /net-libs/farstream
parentConvert to distutils-r1. (diff)
downloadgentoo-2-b116cc52019f4021a132957162cdaf3e13a4014b.tar.gz
gentoo-2-b116cc52019f4021a132957162cdaf3e13a4014b.tar.bz2
gentoo-2-b116cc52019f4021a132957162cdaf3e13a4014b.zip
Convert the old slot into python-single-r1.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs/farstream')
-rw-r--r--net-libs/farstream/ChangeLog7
-rw-r--r--net-libs/farstream/farstream-0.1.2-r2.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/net-libs/farstream/ChangeLog b/net-libs/farstream/ChangeLog
index 0fd2b261cc5d..d131ef7d06af 100644
--- a/net-libs/farstream/ChangeLog
+++ b/net-libs/farstream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/farstream
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.40 2014/08/07 19:19:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.41 2014/11/30 11:19:07 mgorny Exp $
+
+*farstream-0.1.2-r2 (30 Nov 2014)
+
+ 30 Nov 2014; Michał Górny <mgorny@gentoo.org> +farstream-0.1.2-r2.ebuild:
+ Convert the old slot into python-single-r1.
07 Aug 2014; Jeroen Roovers <jer@gentoo.org> farstream-0.2.4.ebuild:
Stable for HPPA (bug #512012).
diff --git a/net-libs/farstream/farstream-0.1.2-r2.ebuild b/net-libs/farstream/farstream-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..4a6aa10457ea
--- /dev/null
+++ b/net-libs/farstream/farstream-0.1.2-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.1.2-r2.ebuild,v 1.1 2014/11/30 11:19:07 mgorny Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="http://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection python msn test upnp"
+
+SLOT="0.1"
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-0.10.33:0.10
+ >=media-libs/gst-plugins-base-0.10.33:0.10
+ >=dev-libs/glib-2.30:2
+ >=net-libs/libnice-0.1.0
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11 )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-0.10.10:0.10[${PYTHON_USEDEP}] )
+ upnp? ( net-libs/gupnp-igd )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.17:0.10
+ >=media-libs/gst-plugins-bad-0.10.17:0.10
+ || (
+ >=media-plugins/gst-plugins-libnice-0.1.0:0.10
+ <=net-libs/libnice-0.1.3[gstreamer] )
+ msn? ( >=media-plugins/gst-plugins-mimic-0.10.17:0.10 )
+ !net-libs/farsight2
+"
+# This package is just a rename from farsight2
+
+MAKEOPTS="${MAKEOPTS} -j1" # Parallel is completely broken on this slot, bug #434618
+
+DEPEND="${COMMONDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix building with gobject-introspection-1.33.x, bug #425096
+ epatch "${FILESDIR}/${P}-introspection-tag-order.patch"
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ use msn && plugins="${plugins},fsmsnconference"
+ econf --disable-static \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ # Parallel install fails, bug #434618 (fixed in latest slot)
+ emake -j1 install DESTDIR="${D}"
+ dodoc AUTHORS README ChangeLog
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}
+
+src_test() {
+ # FIXME: do an out-of-tree build for tests if USE=-msn
+ if ! use msn; then
+ elog "Tests disabled without msn use flag"
+ return
+ fi
+
+ emake -j1 check
+}