summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-23 14:28:04 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-23 14:28:04 +0000
commit47302e15c9d40f025eada6b57fd0e3be08d046cb (patch)
treecfe899b75843c5d375e24dbc85da5a3e68867085 /net-libs/ccrtp
parentversion bump (diff)
downloadgentoo-2-47302e15c9d40f025eada6b57fd0e3be08d046cb.tar.gz
gentoo-2-47302e15c9d40f025eada6b57fd0e3be08d046cb.tar.bz2
gentoo-2-47302e15c9d40f025eada6b57fd0e3be08d046cb.zip
Version bump, drop old.
(Portage version: 2.1.11.19/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/ccrtp')
-rw-r--r--net-libs/ccrtp/ChangeLog9
-rw-r--r--net-libs/ccrtp/ccrtp-1.5.0.ebuild40
-rw-r--r--net-libs/ccrtp/ccrtp-2.0.3.ebuild (renamed from net-libs/ccrtp/ccrtp-1.5.1.ebuild)28
3 files changed, 23 insertions, 54 deletions
diff --git a/net-libs/ccrtp/ChangeLog b/net-libs/ccrtp/ChangeLog
index 85893d758f00..579b113ac992 100644
--- a/net-libs/ccrtp/ChangeLog
+++ b/net-libs/ccrtp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/ccrtp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ChangeLog,v 1.19 2012/05/05 02:54:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ChangeLog,v 1.20 2012/09/23 14:28:04 pacho Exp $
+
+*ccrtp-2.0.3 (23 Sep 2012)
+
+ 23 Sep 2012; Pacho Ramos <pacho@gentoo.org> +ccrtp-2.0.3.ebuild,
+ -ccrtp-1.5.0.ebuild, -ccrtp-1.5.1.ebuild:
+ Version bump, drop old.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> ccrtp-1.5.0.ebuild,
ccrtp-1.5.1.ebuild, ccrtp-1.6.0.ebuild, ccrtp-1.7.0.ebuild:
@@ -87,4 +93,3 @@
21 Aug 2005; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ccrtp-1.3.4.ebuild:
initial import as per bug #94921. Thanks to Christoph Mockenhaupt
-
diff --git a/net-libs/ccrtp/ccrtp-1.5.0.ebuild b/net-libs/ccrtp/ccrtp-1.5.0.ebuild
deleted file mode 100644
index c73eaa36af29..000000000000
--- a/net-libs/ccrtp/ccrtp-1.5.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ccrtp-1.5.0.ebuild,v 1.8 2012/05/05 02:54:23 jdhore Exp $
-
-inherit multilib eutils
-
-DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
-HOMEPAGE="http://www.gnu.org/software/ccrtp/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-KEYWORDS="amd64 ppc ~ppc64 x86"
-LICENSE="GPL-2"
-IUSE="doc"
-SLOT="0"
-
-RDEPEND=">=dev-cpp/commoncpp2-1.3.0
- dev-libs/libgcrypt"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-stdlib.patch
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README ChangeLog AUTHORS NEWS TODO
- use doc && dohtml -r doc/html/*
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
- ewarn
- ewarn "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
- ewarn
- fi
-}
diff --git a/net-libs/ccrtp/ccrtp-1.5.1.ebuild b/net-libs/ccrtp/ccrtp-2.0.3.ebuild
index e4659d232899..09d5e90a3282 100644
--- a/net-libs/ccrtp/ccrtp-1.5.1.ebuild
+++ b/net-libs/ccrtp/ccrtp-2.0.3.ebuild
@@ -1,40 +1,44 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ccrtp-1.5.1.ebuild,v 1.4 2012/05/05 02:54:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ccrtp-2.0.3.ebuild,v 1.1 2012/09/23 14:28:04 pacho Exp $
-inherit multilib eutils
+EAPI=4
+inherit eutils multilib
DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
HOMEPAGE="http://www.gnu.org/software/ccrtp/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
LICENSE="GPL-2"
IUSE="doc"
SLOT="0"
RDEPEND=">=dev-cpp/commoncpp2-1.3.0
- dev-libs/libgcrypt"
+ dev-libs/libgcrypt
+ >=dev-libs/ucommon-5.0.0"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-stdlib.patch
+src_configure() {
+ econf --disable-static
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README ChangeLog AUTHORS NEWS TODO
+ default
+ prune_libtool_files
use doc && dohtml -r doc/html/*
}
pkg_postinst() {
if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
- elog
elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
- elog
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
fi
}