summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-01-18 19:44:40 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-01-18 19:44:40 +0000
commite5d13f2b0356cc60bf08a4541b3f5011ce0becde (patch)
tree2d4556cc87a44dc330a9c5563c15f49d93288d7e /net-irc
parentAdd USE="png ssl win64" and convert USE flags to $(use_with) #255250 by Johan... (diff)
downloadgentoo-2-e5d13f2b0356cc60bf08a4541b3f5011ce0becde.tar.gz
gentoo-2-e5d13f2b0356cc60bf08a4541b3f5011ce0becde.tar.bz2
gentoo-2-e5d13f2b0356cc60bf08a4541b3f5011ce0becde.zip
Cleanups and monolithic flag support from Daniel Pielmeier
(Portage version: 2.2_rc22/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog8
-rw-r--r--net-irc/quassel/metadata.xml65
-rw-r--r--net-irc/quassel/quassel-0.3.1-r3.ebuild119
-rw-r--r--net-irc/quassel/quassel-9999.ebuild46
4 files changed, 189 insertions, 49 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index d9effd7eeaf5..8b236cf307b8 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.40 2009/01/09 17:53:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.41 2009/01/18 19:44:40 jokey Exp $
+
+*quassel-0.3.1-r3 (18 Jan 2009)
+
+ 18 Jan 2009; <jokey@gentoo.org> metadata.xml, +quassel-0.3.1-r3.ebuild,
+ quassel-9999.ebuild:
+ Cleanups and monolithic flag support from Daniel Pielmeier
09 Jan 2009; Patrick Lauer <patrick@gentoo.org> quassel-9999.ebuild:
Small configure fix from Sput (upstream) for monolithic build
diff --git a/net-irc/quassel/metadata.xml b/net-irc/quassel/metadata.xml
index c7307ee2d51f..c334815f58db 100644
--- a/net-irc/quassel/metadata.xml
+++ b/net-irc/quassel/metadata.xml
@@ -1,34 +1,39 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>net-irc</herd>
- <maintainer>
- <email>daniel.pielmeier@googlemail.com</email>
- <name>Daniel Pielmeier</name>
- </maintainer>
- <maintainer>
- <email>patrick@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="X">
- Build the Qt 4 GUI client for quassel. If this USE flag is
- disabled, the GUI is not built, and cannot be used. You might
- want to disable this on the server, but you need it enabled on
- the client.
- </flag>
- <flag name="phonon">
- Build client with phonon backend support. This enables sound
- playback in client.
- </flag>
- <flag name="server">
- Build the server binary. If this USE flag is disabled, the
- 'core' server binary for quassel is not built, and cannot be
- used. You need this enabled on the server, but you might want to
- disable it on the client.
- </flag>
- <flag name="webkit">
- Use qt-webkit rendering engine for showing url thumbmails and
- for other things that needs webbrowser intergration.
- </flag>
- </use>
+ <herd>net-irc</herd>
+ <maintainer>
+ <email>daniel.pielmeier@googlemail.com</email>
+ <name>Daniel Pielmeier</name>
+ </maintainer>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="monolithic">
+ Build monolitic client. Only useful if one don't want to use
+ quassels client/server model. The server and X flags are probably
+ not needed but it is possible to enable them tooy.
+ </flag>
+ <flag name="phonon">
+ Build client with phonon backend support. This enables sound
+ playback in client.
+ </flag>
+ <flag name="server">
+ Build the server binary. If this USE flag is disabled, the
+ 'core' server binary for quassel is not built, and cannot be
+ used. You need this enabled on the server, but you might want to
+ disable it on the client.
+ </flag>
+ <flag name="webkit">
+ Use qt-webkit rendering engine for showing url thumbmails and
+ for other things that needs webbrowser intergration.
+ </flag>
+ <flag name="X">
+ Build the Qt 4 GUI client for quassel. If this USE flag is
+ disabled, the GUI is not built, and cannot be used. You might
+ want to disable this on the server, but you need it enabled on
+ the client.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/net-irc/quassel/quassel-0.3.1-r3.ebuild b/net-irc/quassel/quassel-0.3.1-r3.ebuild
new file mode 100644
index 000000000000..ffb57a99d96c
--- /dev/null
+++ b/net-irc/quassel/quassel-0.3.1-r3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r3.ebuild,v 1.1 2009/01/18 19:44:40 jokey Exp $
+
+EAPI=2
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Core/client IRC client."
+HOMEPAGE="http://quassel-irc.org/"
+SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+dbus debug monolithic +server +ssl +X"
+
+LANGS="nb_NO da de fr ru"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+RDEPEND="
+ x11-libs/qt-core:4
+ dbus? ( x11-libs/qt-dbus:4 )
+ monolithic? (
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4
+ )
+ !monolithic? (
+ server? (
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ )
+ X? (
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4
+ )
+ )
+ ssl? (
+ dev-libs/openssl
+ x11-libs/qt-core:4[ssl]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6"
+
+DOCS="AUTHORS ChangeLog README"
+
+pkg_setup() {
+ if ! use monolithic && ! use server && ! use X ; then
+ eerror "You have to build at least one of the monolithic client (USE=monolithic),"
+ eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
+ die "monolithic, server and X flag unset."
+ fi
+}
+
+src_compile() {
+# Comment this out and invoke _common_configure_code and cmake manually until cmake-utils.eclass
+# supports space separated strings as arguments for cmake options or quassel changes the
+# separator. Until now multiple languages are not passed to -DLINGUAS and only the first
+# language is considered.
+
+ local mycmakeargs="$(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want X QTCLIENT)
+ $(cmake-utils_use_want X MONO)
+ $(cmake-utils_use_with X WEBKIT)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with ssl OPENSSL)
+ -DOXYGEN_ICONS=Builtin
+ -DQUASSEL_ICONS=Builtin"
+
+ _common_configure_code
+
+ mkdir -p "${WORKDIR}"/${PN}_build
+ pushd "${WORKDIR}"/${PN}_build > /dev/null
+
+ cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
+ ${mycmakeargs} \
+ -DLINGUAS="${LINGUAS}" \
+ "${S}" || die "Cmake failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use server ; then
+ newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
+ newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
+
+ insinto /usr/share/doc/${PF}
+ doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn
+ ewarn "In order to use the quassel init script you must set the"
+ ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
+ ewarn "Note: This is the user who runs the quasselcore and is independent"
+ ewarn "from the users you set up in the quasselclient."
+ elog
+ elog "Adding more than one user or changing username/password is not"
+ elog "possible via the quasselclient yet. If you need to do these things"
+ elog "you have to use the manageusers.py script, which has been installed in"
+ elog "/usr/share/doc/${PF}".
+ elog "Please make sure that the quasselcore is stopped before adding more users."
+ fi
+
+ if ( use server || use monolithic ) && use ssl ; then
+ elog
+ elog "To enable SSL support for client/core connections the quasselcore needs"
+ elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."
+ elog "To create the certificate use the following command:"
+ elog "openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout ~/.quassel/quasselCert.pem -out ~/.quassel/quasselCert.pem"
+ fi
+}
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index df4d073e3981..499678d63edf 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.14 2009/01/09 17:53:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.15 2009/01/18 19:44:40 jokey Exp $
EAPI="2"
@@ -15,7 +15,7 @@ HOMEPAGE="http://quassel-irc.org/"
LICENSE="GPL-3"
KEYWORDS=""
SLOT="0"
-IUSE="dbus debug kde phonon +server +ssl webkit +X"
+IUSE="dbus debug kde monolithic phonon +server +ssl webkit +X"
LANGS="cs da de fr nb_NO ru tr"
for l in ${LANGS}; do
@@ -25,20 +25,30 @@ done
RDEPEND="
x11-libs/qt-core:4
dbus? ( x11-libs/qt-dbus:4 )
- server? (
+ monolithic? (
x11-libs/qt-sql:4[sqlite]
x11-libs/qt-script:4
- )
- ssl? (
- dev-libs/openssl
- x11-libs/qt-core:4[ssl]
- )
- X? (
x11-libs/qt-gui:4
kde? ( >=kde-base/kdelibs-4.1 )
phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
webkit? ( x11-libs/qt-webkit:4 )
)
+ !monolithic? (
+ server? (
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ )
+ X? (
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ )
+ ssl? (
+ dev-libs/openssl
+ x11-libs/qt-core:4[ssl]
+ )
"
DEPEND="${RDEPEND}
>=dev-util/cmake-2.6"
@@ -46,20 +56,21 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog README"
pkg_setup() {
- if ! use server && ! use X ; then
- eerror "You have to build one or both of quassel client or server."
- die "Both server and X USE flags unset."
+ if ! use monolithic && ! use server && ! use X ; then
+ eerror "You have to build at least one of the monolithic client (USE=monolithic),"
+ eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
+ die "monolithic, server and X flag unset."
fi
}
src_configure() {
-# Invoke _common_configure_code, cmake and cmake-utils_src_make
-# manually until cmake-utils.eclass supports space separated strings as arguments for cmake
-# options. Until now multiple languages are not passed to -DLINGUAS and only the first
+# Comment this out and invoke _common_configure_code and cmake manually until cmake-utils.eclass
+# supports space separated strings as arguments for cmake options or quassel changes the
+# separator. Until now multiple languages are not passed to -DLINGUAS and only the first
# language is considered.
local mycmakeargs="$(cmake-utils_use_want server CORE)
$(cmake-utils_use_want X QTCLIENT)
- $(cmake-utils_use_want X MONO)
+ $(cmake-utils_use_want monolithic MONO)
$(cmake-utils_use_with webkit WEBKIT)
$(cmake-utils_use_with dbus DBUS)
$(cmake-utils_use_with kde KDE)
@@ -82,7 +93,6 @@ src_configure() {
cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
${mycmakeargs} \
-DLINGUAS="${LINGUAS}" \
- -DCMAKE_INSTALL_DO_STRIP=OFF \
"${S}" || die "Cmake failed"
}
@@ -114,7 +124,7 @@ pkg_postinst() {
elog "Please make sure that the quasselcore is stopped before adding more users."
fi
- if use server && use ssl ; then
+ if ( use server || use monolithic ) && use ssl ; then
elog
elog "To enable SSL support for client/core connections the quasselcore needs"
elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."