summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2009-02-23 22:47:21 +0000
committerAli Polatel <hawking@gentoo.org>2009-02-23 22:47:21 +0000
commitd31af487b28e7d115f79e5fecde59eb453cd2bc3 (patch)
tree03d129b5d27ca48abf2a742b8637178915ff8674 /net-irc
parentbumb to first openocd release, also tweak the live ebuild, bug #259938 (diff)
downloadgentoo-2-d31af487b28e7d115f79e5fecde59eb453cd2bc3.tar.gz
gentoo-2-d31af487b28e7d115f79e5fecde59eb453cd2bc3.tar.bz2
gentoo-2-d31af487b28e7d115f79e5fecde59eb453cd2bc3.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bip/ChangeLog10
-rw-r--r--net-irc/bip/bip-0.8.0_rc1.ebuild52
-rw-r--r--net-irc/bip/metadata.xml1
3 files changed, 61 insertions, 2 deletions
diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index abe32cfb0c75..b08ff845b1df 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/bip
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.3 2008/10/10 12:06:29 hawking Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.4 2009/02/23 22:47:21 hawking Exp $
+
+*bip-0.8.0_rc1 (24 Feb 2009)
+
+ 24 Feb 2009; Feed your head <alip@gentoo.org> metadata.xml,
+ +bip-0.8.0_rc1.ebuild:
+ Version bump. Add oidentd support. Thanks to Sebastian Mair
*bip-0.7.4-r1 (10 Oct 2008)
diff --git a/net-irc/bip/bip-0.8.0_rc1.ebuild b/net-irc/bip/bip-0.8.0_rc1.ebuild
new file mode 100644
index 000000000000..e422c2a00e0d
--- /dev/null
+++ b/net-irc/bip/bip-0.8.0_rc1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.0_rc1.ebuild,v 1.1 2009/02/23 22:47:21 hawking Exp $
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Multiuser IRC proxy with ssl support"
+HOMEPAGE="http://bip.t1r.net/"
+SRC_URI="http://bip.t1r.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl vim-syntax oidentd"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || ( app-editors/vim
+ app-editors/gvim ) )
+ oidentd? ( >=net-misc/oidentd-2.0 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable ssl) $(use_enable oidentd)
+ # Parallel make fails.
+ # {C,CXX,LD}FLAGS aren't respected, bug 241030.
+ emake CFLAGS="${CFLAGS}" CPPFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin src/bip src/bipmkpw || die "dobin failed"
+
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+ newdoc samples/bip.conf bip.conf.sample || die "newdoc failed"
+ doman bip.1 bip.conf.5 bipmkpw.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins samples/bip.vim || die "doins failed"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/bip.vim || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ elog 'Default configuration file is "~/.bip/bip.conf"'
+ elog "You can find a sample configuration file in"
+ elog "/usr/share/doc/${PF}/bip.conf.sample"
+}
diff --git a/net-irc/bip/metadata.xml b/net-irc/bip/metadata.xml
index ae4bf1f59bd1..7a8bdab45241 100644
--- a/net-irc/bip/metadata.xml
+++ b/net-irc/bip/metadata.xml
@@ -14,5 +14,6 @@
connect from multiple workstations, or when you simply want to have a playback
of what was said while you were away.
</longdescription>
+ <use><flag name='oidentd'>Enable oidentd support</flag></use>
</pkgmetadata>