summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-27 13:46:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-27 13:46:05 +0000
commitbfe189075a55eaa1055d00c71a12004d279fa8b1 (patch)
tree5db32fbaebb300d6b2e008a0feeaea54d8a3cb4f /net-irc
parentStable on x86. (diff)
downloadgentoo-2-bfe189075a55eaa1055d00c71a12004d279fa8b1.tar.gz
gentoo-2-bfe189075a55eaa1055d00c71a12004d279fa8b1.tar.bz2
gentoo-2-bfe189075a55eaa1055d00c71a12004d279fa8b1.zip
Always depend on ruby-gettext when building the gem, so that the data is properly added to the gem. Add a dict USE flag for the dictclient plugin, depending on the new ruby-dict ebuild.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/rbot/ChangeLog10
-rw-r--r--net-irc/rbot/files/digest-rbot-9999-r7 (renamed from net-irc/rbot/files/digest-rbot-9999-r6)0
-rw-r--r--net-irc/rbot/metadata.xml9
-rw-r--r--net-irc/rbot/rbot-9999-r7.ebuild (renamed from net-irc/rbot/rbot-9999-r6.ebuild)17
4 files changed, 27 insertions, 9 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index ea28f00110be..ae6e9feb4f45 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/rbot
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.25 2007/12/26 20:25:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.26 2007/12/27 13:46:04 flameeyes Exp $
+
+*rbot-9999-r7 (27 Dec 2007)
+
+ 27 Dec 2007; Diego Pettenò <flameeyes@gentoo.org> metadata.xml,
+ -rbot-9999-r6.ebuild, +rbot-9999-r7.ebuild:
+ Always depend on ruby-gettext when building the gem, so that the data is
+ properly added to the gem. Add a dict USE flag for the dictclient plugin,
+ depending on the new ruby-dict ebuild.
*rbot-9999-r6 (26 Dec 2007)
diff --git a/net-irc/rbot/files/digest-rbot-9999-r6 b/net-irc/rbot/files/digest-rbot-9999-r7
index e69de29bb2d1..e69de29bb2d1 100644
--- a/net-irc/rbot/files/digest-rbot-9999-r6
+++ b/net-irc/rbot/files/digest-rbot-9999-r7
diff --git a/net-irc/rbot/metadata.xml b/net-irc/rbot/metadata.xml
index cfc061d6a983..d5f7c8bf76ac 100644
--- a/net-irc/rbot/metadata.xml
+++ b/net-irc/rbot/metadata.xml
@@ -31,5 +31,14 @@
to enable the "shortenurl" plugin for rbot. If the USE flag is
disabled the plugin is also disabled by default.
</flag>
+ <flag name="nls">
+ Add dependency over <pkg>dev-ruby/ruby-gettext</pkg>, which is
+ needed for the translation of the bot's messages to work.
+ </flag>
+ <flag name="dict">
+ Add dependency over <pkg>dev-ruby/ruby-dict</pkg>, which is needed
+ to enable the "dict" plugin for rbot. If the USE flag is disabled
+ the plugin is also disabled by default.
+ </flag>
</use>
</pkgmetadata>
diff --git a/net-irc/rbot/rbot-9999-r6.ebuild b/net-irc/rbot/rbot-9999-r7.ebuild
index 7892b4a4b7fc..f674712deca0 100644
--- a/net-irc/rbot/rbot-9999-r6.ebuild
+++ b/net-irc/rbot/rbot-9999-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r6.ebuild,v 1.1 2007/12/26 20:25:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r7.ebuild,v 1.1 2007/12/27 13:46:04 flameeyes Exp $
inherit ruby gems eutils
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.linuxbrit.co.uk/rbot/"
LICENSE="as-is"
SLOT="0"
KEYWORDS=""
-IUSE="spell aspell timezone translator shorturl nls"
+IUSE="spell aspell timezone translator shorturl nls dict"
ILINGUAS="zh ru nl de fr it en ja"
for lang in $ILINGUAS; do
@@ -28,8 +28,9 @@ RDEPEND=">=virtual/ruby-1.8
)
translator? ( dev-ruby/mechanize )
shorturl? ( dev-ruby/shorturl )
- nls? ( dev-ruby/ruby-gettext )"
-DEPEND="nls? ( dev-ruby/ruby-gettext )"
+ nls? ( dev-ruby/ruby-gettext )
+ dict? ( dev-ruby/ruby-dict )"
+DEPEND=""
if [[ ${PV} == "9999" ]]; then
SRC_URI=""
@@ -37,7 +38,8 @@ if [[ ${PV} == "9999" ]]; then
DEPEND="${DEPEND}
dev-ruby/rake
- app-arch/zip"
+ app-arch/zip
+ dev-ruby/ruby-gettext"
IUSE="${IUSE} snapshot"
else
@@ -67,9 +69,7 @@ src_unpack() {
src_compile() {
[[ ${PV} == "9999" ]] || return 0
- if use nls; then
- rake makemo || die "locale generation failed"
- fi
+ rake makemo || die "locale generation failed"
rake || die "Gem generation failed"
}
@@ -107,6 +107,7 @@ src_install() {
use translator || disable_rbot_plugin translator
use shorturl || disable_rbot_plugin shortenurls
+ use dict || disable_rbot_plugin dictclient
# This is unfortunately pretty manual at the moment, but it's just
# to avoid having to run special scripts to package new versions