summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-16 16:37:58 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-16 16:37:58 +0000
commit875e14d4f14db0617939abc6e8c412a107e23844 (patch)
treeb673afc5a48931d040fa940189a193679c651294 /net-irc
parentFixed inheriting gcc, Bug 92745. (diff)
downloadgentoo-2-875e14d4f14db0617939abc6e8c412a107e23844.tar.gz
gentoo-2-875e14d4f14db0617939abc6e8c412a107e23844.tar.bz2
gentoo-2-875e14d4f14db0617939abc6e8c412a107e23844.zip
Added cross-compile support.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/cwirc/ChangeLog7
-rw-r--r--net-irc/cwirc/cwirc-1.8.8.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/net-irc/cwirc/ChangeLog b/net-irc/cwirc/ChangeLog
index 95cb2819e357..490693f05376 100644
--- a/net-irc/cwirc/ChangeLog
+++ b/net-irc/cwirc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/cwirc
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/ChangeLog,v 1.16 2004/09/12 16:19:00 swegener Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/ChangeLog,v 1.17 2005/05/16 16:37:58 swegener Exp $
+
+ 16 May 2005; Sven Wegener <swegener@gentoo.org> cwirc-1.8.8.ebuild:
+ Added cross-compile support.
12 Sep 2004; Sven Wegener <swegener@gentoo.org> -cwirc-1.8.6.ebuild,
-cwirc-1.8.7.ebuild, cwirc-1.8.8.ebuild:
diff --git a/net-irc/cwirc/cwirc-1.8.8.ebuild b/net-irc/cwirc/cwirc-1.8.8.ebuild
index 82c9e677e8a8..225ad406a480 100644
--- a/net-irc/cwirc/cwirc-1.8.8.ebuild
+++ b/net-irc/cwirc/cwirc-1.8.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/cwirc-1.8.8.ebuild,v 1.2 2004/09/12 16:19:00 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/cwirc/cwirc-1.8.8.ebuild,v 1.3 2005/05/16 16:37:58 swegener Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="An X-chat plugin for sending and receiving raw morse code over IRC"
HOMEPAGE="http://webperso.easyconnect.fr/om.the/web/cwirc/"
@@ -19,19 +19,20 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/cwirc-1.7.1-gentoo.patch
- sed -i -e 's:$(STRIP):echo:' Makefile
+ epatch "${FILESDIR}"/cwirc-1.7.1-gentoo.patch
+ sed -i -e 's:$(STRIP):true:' Makefile
}
src_compile() {
- emake CFLAGS="${CFLAGS} -DLINUX" || die "emake failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DLINUX" || die "emake failed"
}
src_install() {
einstall || die "einstall failed"
dodoc README RELEASE_NOTES Changelog
- cp -R schematics/ ${D}/usr/share/doc/${PF}/schematics/
+ docinto schematics
+ dodoc schematics/*
}