summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-28 23:35:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-28 23:35:54 +0000
commit794d9c086d9c13e4e6e044b64293530f564a5362 (patch)
tree9a9e0f390e823ef46df9ff42a7cc95f289aa4b13 /net-irc
parentSupport gmp-allocation checks and thread resource exceptions (diff)
downloadgentoo-2-794d9c086d9c13e4e6e044b64293530f564a5362.tar.gz
gentoo-2-794d9c086d9c13e4e6e044b64293530f564a5362.tar.bz2
gentoo-2-794d9c086d9c13e4e6e044b64293530f564a5362.zip
Bump to 1.0, fixes #258144. Small ebuild modifications thanks to Marco Paolone
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/epic5/ChangeLog10
-rw-r--r--net-irc/epic5/epic5-1.0.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/net-irc/epic5/ChangeLog b/net-irc/epic5/ChangeLog
index 530e6cc8378c..708328fd2272 100644
--- a/net-irc/epic5/ChangeLog
+++ b/net-irc/epic5/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/epic5
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/ChangeLog,v 1.15 2007/11/14 04:11:38 beandog Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/ChangeLog,v 1.16 2009/02/28 23:35:54 patrick Exp $
+
+*epic5-1.0 (28 Feb 2009)
+
+ 28 Feb 2009; Patrick Lauer <patrick@gentoo.org> +epic5-1.0.ebuild:
+ Bump to 1.0, fixes #258144. Small ebuild modifications thanks to Marco
+ Paolone
14 Nov 2007; Steve Dibb <beandog@gentoo.org> epic5-0.3.5.ebuild:
amd64 stable, bug 198872
diff --git a/net-irc/epic5/epic5-1.0.ebuild b/net-irc/epic5/epic5-1.0.ebuild
new file mode 100644
index 000000000000..02c0f6669a50
--- /dev/null
+++ b/net-irc/epic5/epic5-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Epic5 IRC Client"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC5-PRODUCTION/${P}.tar.bz2"
+HOMEPAGE="http://epicsol.org/"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~amd64"
+IUSE="iconv ipv6 perl ssl tcl socks5"
+
+DEPEND=">=sys-libs/ncurses-5.6-r2
+ iconv? ( sys-libs/glibc )
+ perl? ( >=dev-lang/perl-5.8.8-r2 )
+ ssl? ( >=dev-libs/openssl-0.9.8e-r3 )
+ tcl? ( dev-lang/tcl )
+ socks5? ( net-proxy/dante )"
+# ruby? ( >=dev-lang/ruby-1.8.6_p287-r1 ) # fails at the moment
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ econf \
+ --libexecdir=/usr/lib/misc \
+ $(use_with iconv) \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ssl) \
+ $(use_with tcl tcl) \
+ $(use_with socks5) \
+ || die "econf failed"
+ # $(use_with ruby) fails at the moment
+
+ # parallel build failure
+ emake -j1 CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ einstall \
+ sharedir="${D}"/usr/share \
+ libexecdir="${D}"/usr/lib/misc || die "einstall failed"
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+
+ cd "${S}"/doc
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load \
+ nicknames outputhelp README.SSL SILLINESS TS4
+}