summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2008-04-18 16:37:46 +0000
committerDawid Węgliński <cla@gentoo.org>2008-04-18 16:37:46 +0000
commit6f2d36ef3613a09d71d9b82a8e67aa7fb5fc1598 (patch)
tree604a3ce61f21391016f90753ecb0bb3e7b3225c0 /net-irc
parentParallel install does not work, bug 213992 comment 5. (diff)
downloadgentoo-2-6f2d36ef3613a09d71d9b82a8e67aa7fb5fc1598.tar.gz
gentoo-2-6f2d36ef3613a09d71d9b82a8e67aa7fb5fc1598.tar.bz2
gentoo-2-6f2d36ef3613a09d71d9b82a8e67aa7fb5fc1598.zip
Adding gcc-4.3 patch from bug #218273, and ~amd64 keyword
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bobotpp/ChangeLog8
-rw-r--r--net-irc/bobotpp/bobotpp-2.2.2.ebuild15
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.2-gcc43.patch121
3 files changed, 139 insertions, 5 deletions
diff --git a/net-irc/bobotpp/ChangeLog b/net-irc/bobotpp/ChangeLog
index cb7d0024262b..2a940d93f93d 100644
--- a/net-irc/bobotpp/ChangeLog
+++ b/net-irc/bobotpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bobotpp
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/ChangeLog,v 1.19 2007/05/06 12:22:54 genone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/ChangeLog,v 1.20 2008/04/18 16:37:46 cla Exp $
+
+ 18 Apr 2008; Dawid Węgliński <cla@gentoo.org>
+ +files/bobotpp-2.2.2-gcc43.patch, bobotpp-2.2.2.ebuild:
+ Adding gcc-4.3 patch from bug #218273, and ~amd64 keyword
06 May 2007; Marius Mauch <genone@gentoo.org> bobotpp-2.2.2.ebuild:
Replacing einfo with elog
diff --git a/net-irc/bobotpp/bobotpp-2.2.2.ebuild b/net-irc/bobotpp/bobotpp-2.2.2.ebuild
index 2a32c1d5f4ce..0f180075de6d 100644
--- a/net-irc/bobotpp/bobotpp-2.2.2.ebuild
+++ b/net-irc/bobotpp/bobotpp-2.2.2.ebuild
@@ -1,17 +1,26 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/bobotpp-2.2.2.ebuild,v 1.4 2007/05/06 12:22:54 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/bobotpp-2.2.2.ebuild,v 1.5 2008/04/18 16:37:46 cla Exp $
+
+inherit eutils
DESCRIPTION="A flexible IRC bot scriptable in scheme"
HOMEPAGE="http://unknownlamer.org/code/bobot.html"
SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="ppc x86"
+KEYWORDS="ppc x86 ~amd64"
IUSE="guile"
DEPEND="guile? ( dev-scheme/guile )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/bobotpp-2.2.2-gcc43.patch"
+}
+
src_compile() {
econf $(use_enable guile scripting) || die "econf failed"
emake || die "emake failed"
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.2-gcc43.patch b/net-irc/bobotpp/files/bobotpp-2.2.2-gcc43.patch
new file mode 100644
index 000000000000..5627c9a6cb97
--- /dev/null
+++ b/net-irc/bobotpp/files/bobotpp-2.2.2-gcc43.patch
@@ -0,0 +1,121 @@
+diff -NrU5 bobotpp-2.2.2.orig/source/Channel.C bobotpp-2.2.2/source/Channel.C
+--- bobotpp-2.2.2.orig/source/Channel.C 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/Channel.C 2008-04-18 16:31:08.000000000 +0200
+@@ -23,10 +23,11 @@
+
+ #include "Macros.H"
+ #include "Utils.H"
+ #include "Channel.H"
+ #include "StringTokenizer.H"
++#include <cstdlib>
+ #ifdef USESCRIPTS
+ #include "Interp.H"
+ #endif
+
+ Channel::Channel(ServerConnection *c,
+diff -NrU5 bobotpp-2.2.2.orig/source/DCCManager.H bobotpp-2.2.2/source/DCCManager.H
+--- bobotpp-2.2.2.orig/source/DCCManager.H 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/DCCManager.H 2008-04-18 16:32:55.000000000 +0200
+@@ -22,10 +22,11 @@
+ #include <list>
+ #include "DCCPerson.H"
+ #include "DCCConnection.H"
+ #include "UserCommands.H"
+ #include "String.H"
++#include <sys/types.h>
+
+ typedef std::map<String, DCCPerson*, std::less<String> > DCC_MAP;
+
+ // Manages all active DCC connections and allows you to send a message
+ // to each one using the string representation of the user's address
+diff -NrU5 bobotpp-2.2.2.orig/source/Parser.C bobotpp-2.2.2/source/Parser.C
+--- bobotpp-2.2.2.orig/source/Parser.C 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/Parser.C 2008-04-18 16:34:48.000000000 +0200
+@@ -21,10 +21,11 @@
+ #include "config.h"
+ #endif
+
+ #include <sys/types.h>
+ #include <netinet/in.h>
++#include <cstdlib>
+
+ #include "StringTokenizer.H"
+ #include "Parser.H"
+ #include "UserCommands.H"
+ #include "Commands.H"
+diff -NrU5 bobotpp-2.2.2.orig/source/ServerQueue.C bobotpp-2.2.2/source/ServerQueue.C
+--- bobotpp-2.2.2.orig/source/ServerQueue.C 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/ServerQueue.C 2008-04-18 16:36:01.000000000 +0200
+@@ -19,11 +19,11 @@
+
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif
+
+-//#include <limits>
++#include <climits>
+ #include "ServerQueue.H"
+ #include "Utils.H"
+
+ ServerQueue::ServerQueue(Socket * s, bool d)
+ : Queue(s,d), penalty(0)
+diff -NrU5 bobotpp-2.2.2.orig/source/ShitList.C bobotpp-2.2.2/source/ShitList.C
+--- bobotpp-2.2.2.orig/source/ShitList.C 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/ShitList.C 2008-04-18 16:37:12.000000000 +0200
+@@ -24,10 +24,11 @@
+ #include <fstream>
+
+ #include "ShitList.H"
+ #include "StringTokenizer.H"
+ #include "Utils.H"
++#include <cstdlib>
+
+ ShitList::ShitList(String filename)
+ : listFileName(filename)
+ {
+ #ifdef HAVE_STL_CLEAR
+diff -NrU5 bobotpp-2.2.2.orig/source/String.C bobotpp-2.2.2/source/String.C
+--- bobotpp-2.2.2.orig/source/String.C 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/String.C 2008-04-18 16:39:18.000000000 +0200
+@@ -21,10 +21,11 @@
+
+ #include <cstring>
+ #include <cctype>
+ #include <sstream>
+ #include <iostream>
++#include <cstdlib>
+
+ String::String()
+ {
+ }
+
+diff -NrU5 bobotpp-2.2.2.orig/source/UserCommands.C bobotpp-2.2.2/source/UserCommands.C
+--- bobotpp-2.2.2.orig/source/UserCommands.C 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/UserCommands.C 2008-04-18 16:40:39.000000000 +0200
+@@ -30,10 +30,11 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
+ #include <cstdlib>
++#include <cstring>
+ #ifndef _X_OPEN_SOURCE
+ #define _X_OPEN_SOURCE
+ #endif
+ #ifndef _X_OPEN_SOURCE_EXTENDED
+ #define _X_OPEN_SOURCE_EXTENDED 1
+diff -NrU5 bobotpp-2.2.2.orig/source/UserList.C bobotpp-2.2.2/source/UserList.C
+--- bobotpp-2.2.2.orig/source/UserList.C 2008-04-18 16:19:56.000000000 +0200
++++ bobotpp-2.2.2/source/UserList.C 2008-04-18 16:41:08.000000000 +0200
+@@ -17,10 +17,11 @@
+ // Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ // 02110-1301, USA.
+
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
+
+ #include "UserList.H"
+ #include "StringTokenizer.H"
+ #include "Utils.H"
+