summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2013-01-27 07:31:25 +0000
committerNathan Phillip Brink <binki@gentoo.org>2013-01-27 07:31:25 +0000
commit6bbec2d57dc1c59927f5c360e8d53ad14eaebba7 (patch)
treeebafbb3f9fd857167adfcadabf200aec27305aca /net-irc
parentbump to EAPI=4, patch ldaptor-prem_test.patch to disable 1 test premature to ... (diff)
downloadgentoo-2-6bbec2d57dc1c59927f5c360e8d53ad14eaebba7.tar.gz
gentoo-2-6bbec2d57dc1c59927f5c360e8d53ad14eaebba7.tar.bz2
gentoo-2-6bbec2d57dc1c59927f5c360e8d53ad14eaebba7.zip
Create /var/run/unrealircd in the initscript instead of when installing the package, fixing bug #453598 by Flameeyes (and supporting tmpfs /var/run).
(Portage version: 2.2.0_alpha161-r1/cvs/Linux x86_64, signed Manifest commit with key 743A52E86BA81050)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/unrealircd/ChangeLog9
-rw-r--r--net-irc/unrealircd/files/unrealircd.initd13
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.10.ebuild8
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.9.ebuild8
4 files changed, 26 insertions, 12 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index 989787c12c44..cb57fe40ff60 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/unrealircd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.97 2012/12/26 18:54:02 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.98 2013/01/27 07:31:25 binki Exp $
+
+ 27 Jan 2013; Nathan Phillip Brink <binki@gentoo.org> files/unrealircd.initd,
+ unrealircd-3.2.10.ebuild, unrealircd-3.2.9.ebuild:
+ Create /var/run/unrealircd in the initscript instead of when installing the
+ package, fixing bug #453598 by Flameeyes (and supporting tmpfs /var/run).
*unrealircd-3.2.10 (26 Dec 2012)
diff --git a/net-irc/unrealircd/files/unrealircd.initd b/net-irc/unrealircd/files/unrealircd.initd
index eb39a57080e6..356e4e1cf5ec 100644
--- a/net-irc/unrealircd/files/unrealircd.initd
+++ b/net-irc/unrealircd/files/unrealircd.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/files/unrealircd.initd,v 1.2 2011/12/21 18:25:03 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/files/unrealircd.initd,v 1.3 2013/01/27 07:31:25 binki Exp $
extra_started_commands="reload"
@@ -16,6 +16,15 @@ depend() {
}
start() {
+ UNREALIRCD_PIDFILEDIR=${UNREALIRCD_PIDFILE%/*}
+ if ! [ -d "${UNREALIRCD_PIDFILEDIR}" ]; then
+ ebegin "Creating ${UNREALIRCD_PIDFILEDIR} for ${SVCNAME}"
+ mkdir "${UNREALIRCD_PIDFILEDIR}" \
+ && chown :unrealircd "${UNREALIRCD_PIDFILEDIR}" \
+ && chmod 770 "${UNREALIRCD_PIDFILEDIR}"
+ eend $?
+ fi
+
ebegin "Starting ${SVCNAME}"
start-stop-daemon --start --quiet --exec /usr/bin/unrealircd \
--user ${UNREALIRCD_USER} --pidfile "${UNREALIRCD_PIDFILE}" -- -f "${UNREALIRCD_CONF}" ${UNREALIRCD_OPTS}
diff --git a/net-irc/unrealircd/unrealircd-3.2.10.ebuild b/net-irc/unrealircd/unrealircd-3.2.10.ebuild
index c6af92143db5..ca646b283186 100644
--- a/net-irc/unrealircd/unrealircd-3.2.10.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.2.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.10.ebuild,v 1.1 2012/12/26 18:54:02 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.10.ebuild,v 1.2 2013/01/27 07:31:25 binki Exp $
EAPI=4
@@ -74,7 +74,7 @@ src_configure() {
}
src_install() {
- keepdir /var/{lib,log,run}/unrealircd
+ keepdir /var/{lib,log}/unrealircd
newbin src/ircd unrealircd
@@ -110,7 +110,7 @@ src_install() {
newconfd "${FILESDIR}"/unrealircd.confd-r1 unrealircd
fperms 700 /etc/unrealircd
- fowners -R unrealircd /{etc,var/{lib,log,run}}/unrealircd
+ fowners -R unrealircd /{etc,var/{lib,log}}/unrealircd
}
pkg_postinst() {
diff --git a/net-irc/unrealircd/unrealircd-3.2.9.ebuild b/net-irc/unrealircd/unrealircd-3.2.9.ebuild
index 01b4cfe11d88..6052d37ba53f 100644
--- a/net-irc/unrealircd/unrealircd-3.2.9.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.9.ebuild,v 1.7 2012/05/03 06:27:13 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.9.ebuild,v 1.8 2013/01/27 07:31:25 binki Exp $
EAPI=4
@@ -77,7 +77,7 @@ src_configure() {
}
src_install() {
- keepdir /var/{lib,log,run}/unrealircd
+ keepdir /var/{lib,log}/unrealircd
newbin src/ircd unrealircd
@@ -115,7 +115,7 @@ src_install() {
newconfd "${FILESDIR}"/unrealircd.confd-r1 unrealircd
fperms 700 /etc/unrealircd
- fowners -R unrealircd /{etc,var/{lib,log,run}}/unrealircd
+ fowners -R unrealircd /{etc,var/{lib,log}}/unrealircd
}
pkg_postinst() {