summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2003-08-30 17:34:06 +0000
committerBrad Laue <brad@gentoo.org>2003-08-30 17:34:06 +0000
commit3c64684b6c2264de835a1ee511be8eff2fe8bfa3 (patch)
tree22aa425e224a75deab3df4a85739170e1c5075b7 /net-irc/xchat-systray
parentInitial import of xchat-systray (diff)
downloadgentoo-2-3c64684b6c2264de835a1ee511be8eff2fe8bfa3.tar.gz
gentoo-2-3c64684b6c2264de835a1ee511be8eff2fe8bfa3.tar.bz2
gentoo-2-3c64684b6c2264de835a1ee511be8eff2fe8bfa3.zip
Initial import of xchat-systray
Diffstat (limited to 'net-irc/xchat-systray')
-rw-r--r--net-irc/xchat-systray/ChangeLog9
-rw-r--r--net-irc/xchat-systray/Manifest4
-rw-r--r--net-irc/xchat-systray/files/digest-xchat-systray-2.3.11
-rw-r--r--net-irc/xchat-systray/metadata.xml5
-rw-r--r--net-irc/xchat-systray/xchat-systray-2.3.1.ebuild30
5 files changed, 48 insertions, 1 deletions
diff --git a/net-irc/xchat-systray/ChangeLog b/net-irc/xchat-systray/ChangeLog
new file mode 100644
index 000000000000..0e05dbbecb2e
--- /dev/null
+++ b/net-irc/xchat-systray/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-irc/xchat-systray
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/ChangeLog,v 1.1 2003/08/30 17:34:03 brad Exp $
+
+*xchat-systray-2.3.1 (30 Aug 2003)
+
+ 30 Aug 2003; Brad Laue <brad@gentoo.org> xchat-systray-2.3.1.ebuild:
+ Added xchat-systray, a system tray control for X-Chat 2.
+
diff --git a/net-irc/xchat-systray/Manifest b/net-irc/xchat-systray/Manifest
index 2ded3087b11f..9220950c35ab 100644
--- a/net-irc/xchat-systray/Manifest
+++ b/net-irc/xchat-systray/Manifest
@@ -1,2 +1,4 @@
-MD5 d64fdca0d64aa63dd704ea743d3a25cd xchat-systray-2.3.1.ebuild 763
+MD5 c2b4dd4896c15e1f3ec926a8547e350c ChangeLog 389
+MD5 cff2aa76a5157e3acda4985a55ee80ff xchat-systray-2.3.1.ebuild 798
+MD5 3cdab9930cd9a4108a975d417483d04e metadata.xml 180
MD5 9a65d335f20aacff5764eae11d496abc files/digest-xchat-systray-2.3.1 77
diff --git a/net-irc/xchat-systray/files/digest-xchat-systray-2.3.1 b/net-irc/xchat-systray/files/digest-xchat-systray-2.3.1
new file mode 100644
index 000000000000..f7ea591f597f
--- /dev/null
+++ b/net-irc/xchat-systray/files/digest-xchat-systray-2.3.1
@@ -0,0 +1 @@
+MD5 7e829994bf963f20dccad30f47ca3c8d xchat-systray-plugin_2.3.1.tar.gz 68112
diff --git a/net-irc/xchat-systray/metadata.xml b/net-irc/xchat-systray/metadata.xml
new file mode 100644
index 000000000000..f68c4ced170f
--- /dev/null
+++ b/net-irc/xchat-systray/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>brad@gentoo.org</maintainer>
+</pkgmetadata>
diff --git a/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild b/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild
new file mode 100644
index 000000000000..5895d1e57437
--- /dev/null
+++ b/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild,v 1.1 2003/08/30 17:34:03 brad Exp $
+
+S=${WORKDIR}/${PN}-plugin_${PV}
+DESCRIPTION="KDE/GNOME system tray plugin for X-Chat."
+SRC_URI="http://blight.altervista.org/Downloads/${PN}-plugin_${PV}.tar.gz"
+HOMEPAGE="http://blight.altervista.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/gtk+-2.0.3
+ sys-devel/gettext"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ >=net-irc/xchat-2.0.3"
+
+src_compile() {
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+ insinto /usr/lib/xchat/plugins
+ doins systray.so
+}