summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-08-01 20:42:18 +0000
committerSven Wegener <swegener@gentoo.org>2006-08-01 20:42:18 +0000
commit3fa33f322d6122ab5d1f19f920be116553a1930f (patch)
treed0d3cf9c7c3d796583846912a38beb4c8799009a /net-irc/rhapsody/rhapsody-0.28b.ebuild
parentAssigned package to VDR-Project. (diff)
downloadgentoo-2-3fa33f322d6122ab5d1f19f920be116553a1930f.tar.gz
gentoo-2-3fa33f322d6122ab5d1f19f920be116553a1930f.tar.bz2
gentoo-2-3fa33f322d6122ab5d1f19f920be116553a1930f.zip
Version bump.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'net-irc/rhapsody/rhapsody-0.28b.ebuild')
-rw-r--r--net-irc/rhapsody/rhapsody-0.28b.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-irc/rhapsody/rhapsody-0.28b.ebuild b/net-irc/rhapsody/rhapsody-0.28b.ebuild
new file mode 100644
index 000000000000..fec530373f8c
--- /dev/null
+++ b/net-irc/rhapsody/rhapsody-0.28b.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rhapsody/rhapsody-0.28b.ebuild,v 1.1 2006/08/01 20:42:18 swegener Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="IRC client intended to be displayed on a text console"
+HOMEPAGE="http://rhapsody.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.0"
+
+src_compile() {
+ ./configure -i /usr/share/rhapsody || die "configure failed"
+ emake CC="$(tc-getCC)" LOCALFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin rhapsody || die "dobin failed"
+
+ insinto /usr/share/rhapsody/help
+ doins help/*.hlp || die "doins failed"
+
+ dodoc docs/CHANGELOG || die "dodoc failed"
+}