summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-11-27 02:26:19 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-11-27 02:26:19 +0000
commita960731b38f7836cdff0a2ff4e4ca3de9bf23b50 (patch)
tree70552966305c818160e94203f60b1d35703c5381 /net-irc/irssi
parentVersion Bump. (diff)
downloadgentoo-2-a960731b38f7836cdff0a2ff4e4ca3de9bf23b50.tar.gz
gentoo-2-a960731b38f7836cdff0a2ff4e4ca3de9bf23b50.tar.bz2
gentoo-2-a960731b38f7836cdff0a2ff4e4ca3de9bf23b50.zip
Fixed glib dep
Diffstat (limited to 'net-irc/irssi')
-rw-r--r--net-irc/irssi/ChangeLog8
-rw-r--r--net-irc/irssi/irssi-0.8.6-r6.ebuild80
-rw-r--r--net-irc/irssi/irssi-0.8.8.ebuild6
3 files changed, 90 insertions, 4 deletions
diff --git a/net-irc/irssi/ChangeLog b/net-irc/irssi/ChangeLog
index 60839949b823..ab0aed8f5938 100644
--- a/net-irc/irssi/ChangeLog
+++ b/net-irc/irssi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/irssi
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.35 2003/11/23 20:12:05 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.36 2003/11/27 02:26:19 gregf Exp $
+
+*irssi-0.8.6-r6 (26 Nov 2003)
+
+ 26 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> irssi-0.8.6-r6.ebuild:
+ Removed --with-bot, no used anymore and it was broken. Forced usage of glib2.
+ This closes bug #33603.
23 Nov 2003; Martin Holzer <mholzer@gentoo.org> irssi-0.8.8.ebuild,
files/irssi-0.8.8-configure.patch:
diff --git a/net-irc/irssi/irssi-0.8.6-r6.ebuild b/net-irc/irssi/irssi-0.8.6-r6.ebuild
new file mode 100644
index 000000000000..40219bc28815
--- /dev/null
+++ b/net-irc/irssi/irssi-0.8.6-r6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.6-r6.ebuild,v 1.1 2003/11/27 02:26:19 gregf Exp $
+
+IUSE="nls ipv6 perl ssl"
+
+inherit perl-module
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support."
+SRC_URI="http://irssi.org/files/${P}.tar.bz2"
+HOMEPAGE="http://irssi.org/"
+
+DEPEND=">=dev-libs/glib-2.2.1
+ sys-libs/ncurses
+ >=sys-apps/sed-4
+ perl? ( dev-lang/perl )
+ ssl? ( dev-libs/openssl )
+ !net-irc/irssi-cvs
+ socks5? ( >=net-misc/dante-1.1.13 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha hppa mips amd64 ia64"
+
+src_unpack() {
+ unpack ${A}
+
+ # Ugly hack to work around compression of the html files.
+ # Remove this if prepalldocs is changed to avoid gzipping html files.
+ cd ${S} && \
+ sed -i \
+ -e 's/[^ ]\+\.html//g' docs/Makefile.in || \
+ die "sed doc/Makefile.in failed"
+
+ epatch ${FILESDIR}/irssi-0.8.6-configure.patch
+}
+
+src_compile() {
+ # Note: there is an option to build a GUI for irssi, but according
+ # to the website the GUI is no longer developed, so that option is
+ # not used here.
+ local myconf="--with-glib2 --without-servertest --with-proxy --with-ncurses"
+
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_with perl`"
+ myconf="${myconf} `use_enable ipv6`"
+ myconf="${myconf} `use_with socks5 socks`"
+ if use ssl; then
+ myconf="${myconf} --with-openssl-include=/usr --with-openssl-libs=/usr"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ myflags=""
+
+ if use perl; then
+ cd ${S}/src/perl/common; perl-module_src_prep
+ cd ${S}/src/perl/irc; perl-module_src_prep
+ cd ${S}/src/perl/textui; perl-module_src_prep
+ cd ${S}/src/perl/ui; perl-module_src_prep
+ cd ${S}
+ fi
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ gnulocaledir=${D}/usr/share/locale \
+ ${myflags} \
+ install || die
+
+ prepalldocs
+ dodoc AUTHORS ChangeLog README TODO NEWS
+ cd ${S}/docs
+ dohtml -r . || die "dohtml failed"
+}
diff --git a/net-irc/irssi/irssi-0.8.8.ebuild b/net-irc/irssi/irssi-0.8.8.ebuild
index 00ef00418a6f..24cc6ec3f93e 100644
--- a/net-irc/irssi/irssi-0.8.8.ebuild
+++ b/net-irc/irssi/irssi-0.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.8.ebuild,v 1.2 2003/11/23 20:12:05 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.8.ebuild,v 1.3 2003/11/27 02:26:19 gregf Exp $
IUSE="nls ipv6 perl ssl"
@@ -10,7 +10,7 @@ DESCRIPTION="A modular textUI IRC client with IPv6 support."
SRC_URI="http://irssi.org/files/${P}.tar.bz2"
HOMEPAGE="http://irssi.org/"
-DEPEND=">=dev-libs/glib-1.2
+DEPEND=">=dev-libs/glib-2.2.1
sys-libs/ncurses
>=sys-apps/sed-4
perl? ( dev-lang/perl )
@@ -40,7 +40,7 @@ src_compile() {
# Note: there is an option to build a GUI for irssi, but according
# to the website the GUI is no longer developed, so that option is
# not used here.
- local myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
+ local myconf="--with-glib2 --without-servertest --with-proxy --with-ncurses"
myconf="${myconf} `use_enable nls`"
myconf="${myconf} `use_with perl`"