summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-21 19:52:44 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-21 19:52:44 +0000
commitf305fb8ccfd142d731082f3b345d5c871448a305 (patch)
tree65292b490a10743e1fd227a2fe51a998287d53bf /net-irc/eiwic
parentdev-python/ctypes and net-zope/verbosesecurity have been deleted. (diff)
downloadgentoo-2-f305fb8ccfd142d731082f3b345d5c871448a305.tar.gz
gentoo-2-f305fb8ccfd142d731082f3b345d5c871448a305.tar.bz2
gentoo-2-f305fb8ccfd142d731082f3b345d5c871448a305.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/eiwic')
-rw-r--r--net-irc/eiwic/ChangeLog9
-rw-r--r--net-irc/eiwic/eiwic-1.1.4.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/net-irc/eiwic/ChangeLog b/net-irc/eiwic/ChangeLog
index 6bb7e5c4e5aa..e881fedeb751 100644
--- a/net-irc/eiwic/ChangeLog
+++ b/net-irc/eiwic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/eiwic
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eiwic/ChangeLog,v 1.5 2009/02/09 16:58:10 angelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eiwic/ChangeLog,v 1.6 2010/05/21 19:52:44 angelos Exp $
+
+*eiwic-1.1.4 (21 May 2010)
+
+ 21 May 2010; Christoph Mende <angelos@gentoo.org> +eiwic-1.1.4.ebuild:
+ Version bump
09 Feb 2009; Christoph Mende <angelos@gentoo.org>
+files/eiwic-1.1.3-ldflags.patch, eiwic-1.1.3.ebuild:
diff --git a/net-irc/eiwic/eiwic-1.1.4.ebuild b/net-irc/eiwic/eiwic-1.1.4.ebuild
new file mode 100644
index 000000000000..4631b73b8639
--- /dev/null
+++ b/net-irc/eiwic/eiwic-1.1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eiwic/eiwic-1.1.4.ebuild,v 1.1 2010/05/21 19:52:44 angelos Exp $
+
+inherit autotools eutils multilib flag-o-matic
+
+DESCRIPTION="A modular IRC bot written in C"
+HOMEPAGE="http://lordi.styleliga.org/eiwic/"
+SRC_URI="http://lordi.styleliga.org/eiwic/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc ipv6 rss"
+
+DEPEND="rss? ( media-libs/raptor )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "/^set MODULE_PATH/s:modules:/usr/$(get_libdir)/eiwic:" sample.conf
+ sed -i "/^load MODULE/s:$:.so:" sample.conf
+ epatch "${FILESDIR}"/${PN}-1.1.3-ldflags.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug vv-debug) \
+ $(use_enable ipv6)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README NEWS TODO sample.conf
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need a configuration file to run eiwic"
+ einfo "A sample configuration was installed to"
+ einfo "/usr/share/doc/${PF}/"
+ echo
+ if use debug; then
+ einfo "For debugging options please see eiwic -h"
+ echo
+ fi
+}