summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-27 10:40:18 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-27 10:40:18 +0000
commitdef45f8a2451cea4b11d83b3dc10e42d9ad323cb (patch)
tree1a2d3ef48ced8cee9bbf0eaa937ba6fed7389c5d /net-im
parentAdd patch which makes multi linguas build working, fixes bug #400955. (diff)
downloadgentoo-2-def45f8a2451cea4b11d83b3dc10e42d9ad323cb.tar.gz
gentoo-2-def45f8a2451cea4b11d83b3dc10e42d9ad323cb.tar.bz2
gentoo-2-def45f8a2451cea4b11d83b3dc10e42d9ad323cb.zip
Add patch which makes multi linguas build working, fixes bug #400955.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ktp-contact-applet/ChangeLog9
-rw-r--r--net-im/ktp-contact-applet/files/ktp-contact-applet-0.3.0-fix-multi-linguas.patch26
-rw-r--r--net-im/ktp-contact-applet/ktp-contact-applet-0.3.0-r1.ebuild (renamed from net-im/ktp-contact-applet/ktp-contact-applet-0.3.0.ebuild)6
3 files changed, 39 insertions, 2 deletions
diff --git a/net-im/ktp-contact-applet/ChangeLog b/net-im/ktp-contact-applet/ChangeLog
index 1686176a1032..d2a058c860d2 100644
--- a/net-im/ktp-contact-applet/ChangeLog
+++ b/net-im/ktp-contact-applet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/ktp-contact-applet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-contact-applet/ChangeLog,v 1.1 2012/01/25 22:53:25 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-contact-applet/ChangeLog,v 1.2 2012/01/27 10:40:18 johu Exp $
+
+*ktp-contact-applet-0.3.0-r1 (27 Jan 2012)
+
+ 27 Jan 2012; Johannes Huber <johu@gentoo.org>
+ +files/ktp-contact-applet-0.3.0-fix-multi-linguas.patch,
+ +ktp-contact-applet-0.3.0-r1.ebuild, -ktp-contact-applet-0.3.0.ebuild:
+ Add patch which makes multi linguas build working, fixes bug #400955.
*ktp-contact-applet-0.3.0 (25 Jan 2012)
diff --git a/net-im/ktp-contact-applet/files/ktp-contact-applet-0.3.0-fix-multi-linguas.patch b/net-im/ktp-contact-applet/files/ktp-contact-applet-0.3.0-fix-multi-linguas.patch
new file mode 100644
index 000000000000..76f33adfb297
--- /dev/null
+++ b/net-im/ktp-contact-applet/files/ktp-contact-applet-0.3.0-fix-multi-linguas.patch
@@ -0,0 +1,26 @@
+From 74fa1e45d27ec25263f828bdacfac236e6a280d4 Mon Sep 17 00:00:00 2001
+From: Johannes Huber <johu@gentoo.org>
+Date: Fri, 27 Jan 2012 11:17:36 +0100
+Subject: [PATCH] Add cmake policy to handle multi lang build.
+
+---
+ CMakeLists.txt | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0b34038..653ede2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,6 +2,9 @@ project(ktp-contact-applet)
+
+ cmake_minimum_required(VERSION 2.8)
+
++# Workaround to handle multi language build
++cmake_policy(SET CMP0002 OLD)
++
+ set(CMAKE_MODULE_PATH
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules"
+ ${CMAKE_MODULE_PATH}
+--
+1.7.8.4
+
diff --git a/net-im/ktp-contact-applet/ktp-contact-applet-0.3.0.ebuild b/net-im/ktp-contact-applet/ktp-contact-applet-0.3.0-r1.ebuild
index 64c1a9e881a5..1cf6d9ecd0c0 100644
--- a/net-im/ktp-contact-applet/ktp-contact-applet-0.3.0.ebuild
+++ b/net-im/ktp-contact-applet/ktp-contact-applet-0.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-contact-applet/ktp-contact-applet-0.3.0.ebuild,v 1.1 2012/01/25 22:53:25 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-contact-applet/ktp-contact-applet-0.3.0-r1.ebuild,v 1.1 2012/01/27 10:40:18 johu Exp $
EAPI=4
@@ -29,3 +29,7 @@ DEPEND="
RDEPEND="${DEPEND}
>=net-im/ktp-contact-list-${PV}
"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-multi-linguas.patch"
+)