summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-05-29 07:57:50 +0000
committerPeter Volkov <pva@gentoo.org>2009-05-29 07:57:50 +0000
commitddc8b6558a5f4ee513ab23f4bcbcd7278dfbaa60 (patch)
treebd9c7d6e7b6766a1d8457c14e7c9df7ef9a47dff /net-im
parentStabilize =sys-kernel/hardened-sources-2.6.28-r9 and remove 2.6.28-r6. (diff)
downloadgentoo-2-ddc8b6558a5f4ee513ab23f4bcbcd7278dfbaa60.tar.gz
gentoo-2-ddc8b6558a5f4ee513ab23f4bcbcd7278dfbaa60.tar.bz2
gentoo-2-ddc8b6558a5f4ee513ab23f4bcbcd7278dfbaa60.zip
Version bump to development version, bug #271091, thank Dennis Schridde for report and Vadim Efimov for ebuild. The return of USE=extras, now from http://code.google.com/p/psi-dev.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog11
-rw-r--r--net-im/psi/psi-0.13_rc1.ebuild124
2 files changed, 133 insertions, 2 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index d4a885d934f4..e29bfb8734c0 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/psi
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.157 2009/03/23 10:11:10 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.158 2009/05/29 07:57:50 pva Exp $
+
+*psi-0.13_rc1 (29 May 2009)
+
+ 29 May 2009; Peter Volkov <pva@gentoo.org> +psi-0.13_rc1.ebuild:
+ Version bump to development version, bug #271091, thank Dennis Schridde
+ for report and Vadim Efimov for ebuild. The return of USE=extras, now from
+ http://code.google.com/p/psi-dev.
23 Mar 2009; Peter Volkov <pva@gentoo.org>
+files/psi-0.12.1-build-error.patch, -psi-0.12.ebuild, psi-0.12.1.ebuild:
diff --git a/net-im/psi/psi-0.13_rc1.ebuild b/net-im/psi/psi-0.13_rc1.ebuild
new file mode 100644
index 000000000000..408c0524b2ae
--- /dev/null
+++ b/net-im/psi/psi-0.13_rc1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.13_rc1.ebuild,v 1.1 2009/05/29 07:57:50 pva Exp $
+
+EAPI="2"
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_rc/-rc}"
+
+LANGPACK_VER="20090217"
+
+DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
+HOMEPAGE="http://psi-im.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}-langs-${LANGPACK_VER}.tar.bz2
+ extras? ( mirror://gentoo/${PN}-extra-patches-r504.tar.bz2
+ mirror://gentoo/${PN}-extra-iconsets-r504.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt dbus debug doc spell ssl xscreensaver extras"
+RESTRICT="test"
+
+LANGS="cs de eo es_ES fr it mk pl pt_BR ru uk ur_PK vi zh zh_TW"
+for LNG in ${LANGS}; do
+ IUSE="${IUSE} linguas_${LNG}"
+ #SRC_URI="${SRC_URI} http://psi-im.org/download/lang/psi_${LNG/ur_PK/ur_pk}.qm"
+done
+
+COMMON_DEPEND=">=x11-libs/qt-gui-4.4:4[qt3support,dbus?]
+ app-crypt/qca:2
+ spell? ( app-text/aspell )
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( >=app-crypt/qca-gnupg-2.0.0_beta2 )
+ ssl? ( >=app-crypt/qca-ossl-2.0.0_beta2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use extras; then
+ # some patches from psi+ project http://code.google.com/p/psi-dev
+ ewarn "You're about to build heavily patched version of Psi called Psi+."
+ ewarn "It has really nice features but still under heavy development."
+ ewarn "Take a look at homepage for more info: http://code.google.com/p/psi-dev"
+ ewarn "If you wish to disable some patches just put"
+ ewarn "MY_EPATCH_EXCLUDE=\"list of patches\""
+ ewarn "into /etc/portage/env/${CATEGORY}/${PN} file."
+ ebeep
+
+ EPATCH_EXCLUDE="${MY_EPATCH_EXCLUDE} 280-psi-application-info.diff" \
+ EPATCH_SUFFIX="diff" EPATCH_FORCE="yes" epatch
+ sed -e 's/\(^#define PROG_CAPS_NODE \).*/\1"http:\/\/psi-dev.googlecode.com\/caps";/' \
+ -e 's:\(^#define PROG_NAME "Psi\):\1+:' \
+ -i src/applicationinfo.cpp || die
+ fi
+}
+
+src_configure() {
+ # disable growl as it is a MacOS X extension only
+ local myconf="--prefix=/usr --qtdir=/usr"
+ myconf="${myconf} --disable-growl --disable-bundled-qca"
+ use debug && myconf="${myconf} --enable-debug"
+ use dbus || myconf="${myconf} --disable-qdbus"
+ use spell || myconf="${myconf} --disable-aspell"
+ use xscreensaver || myconf="${myconf} --disable-xss"
+
+ # cannot use econf because of non-standard configure script
+ ./configure ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ eqmake4 ${PN}.pro
+
+ SUBLIBS="-L/usr/${get_libdir}/qca2" emake || die "emake failed"
+
+ if use doc; then
+ cd doc
+ mkdir -p api # 259632
+ make api_public || die "make api_public failed"
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+
+ # this way the docs will be installed in the standard gentoo dir
+ newdoc iconsets/roster/README README.roster || die
+ newdoc iconsets/system/README README.system || die
+ newdoc certs/README README.certs || die
+ dodoc README || die
+
+ if use doc; then
+ cd doc
+ dohtml -r api || die "dohtml failed"
+ fi
+
+ # install translations
+ cd "${WORKDIR}/${PN}-langs"
+ insinto /usr/share/${PN}/
+ for LNG in ${LANGS}; do
+ if use linguas_${LNG}; then
+ doins ${PN}_${LNG/ur_PK/ur_pk}.qm || die
+ fi
+ done
+
+ if use extras; then
+ cp -a "${WORKDIR}"/iconsets/* "${D}"/usr/share/${PN}/iconsets/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use extras; then
+ ewarn "You've built Psi+ version of Psi (USE=extras)."
+ ewarn "Do not report any bugs upstream, until you manage"
+ ewarn "to reproduce them with USE=-extras. Thank you."
+ fi
+}