summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-28 03:40:44 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-28 03:40:44 +0000
commitb2c4f59f9789a7f0a3c7a7bb02da98c15ae745f8 (patch)
tree4d90b88e5c7baec0af78716ece741f26290c6d4e /net-im
parentSet python active version to 2. (diff)
downloadgentoo-2-b2c4f59f9789a7f0a3c7a7bb02da98c15ae745f8.tar.gz
gentoo-2-b2c4f59f9789a7f0a3c7a7bb02da98c15ae745f8.tar.bz2
gentoo-2-b2c4f59f9789a7f0a3c7a7bb02da98c15ae745f8.zip
Set active python version to 2.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pymsn-t/ChangeLog8
-rw-r--r--net-im/pymsn-t/pymsn-t-0.11.3-r3.ebuild10
2 files changed, 13 insertions, 5 deletions
diff --git a/net-im/pymsn-t/ChangeLog b/net-im/pymsn-t/ChangeLog
index e3306e1267e2..1440b6b7249d 100644
--- a/net-im/pymsn-t/ChangeLog
+++ b/net-im/pymsn-t/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/pymsn-t
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/ChangeLog,v 1.25 2012/12/28 16:14:49 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/ChangeLog,v 1.26 2013/05/28 03:40:44 floppym Exp $
+
+ 28 May 2013; Mike Gilbert <floppym@gentoo.org> pymsn-t-0.11.3-r3.ebuild:
+ Set active python version to 2.
28 Dec 2012; Samuli Suominen <ssuominen@gentoo.org>
-files/pymsn-t-0.11.2-initd, -pymsn-t-0.11.3.ebuild,
@@ -131,4 +134,3 @@
+files/pymsn-t-0.9.2-arguments.patch, +files/pymsn-t.initd,
+pymsn-t-0.9.2.ebuild:
Initial import see bug #88597 for more info
-
diff --git a/net-im/pymsn-t/pymsn-t-0.11.3-r3.ebuild b/net-im/pymsn-t/pymsn-t-0.11.3-r3.ebuild
index dde819d14ae6..17689859b5ae 100644
--- a/net-im/pymsn-t/pymsn-t-0.11.3-r3.ebuild
+++ b/net-im/pymsn-t/pymsn-t-0.11.3-r3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/pymsn-t-0.11.3-r3.ebuild,v 1.3 2011/10/09 13:50:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/pymsn-t-0.11.3-r3.ebuild,v 1.4 2013/05/28 03:40:44 floppym Exp $
EAPI="3"
+PYTHON_DEPEND="2"
inherit eutils multilib python
@@ -23,6 +24,11 @@ RDEPEND="${DEPEND}
>=dev-python/twisted-web-0.7.0
>=dev-python/imaging-1.1"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}/${P}-protocol-version.patch"
epatch "${FILESDIR}/${P}-unexpected-xfr.patch"