summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKathryn Kulick <gothgirl@gentoo.org>2006-10-23 22:55:55 +0000
committerKathryn Kulick <gothgirl@gentoo.org>2006-10-23 22:55:55 +0000
commit8bd4a7f9a440417fafe5d386e4deb099b51245d8 (patch)
tree07f5ae0e148b8b71a3d1193b78fc680a901da228 /net-im
parentRemoved old versions of www-apache/mod_mono, rewritten the 70_mod_mono.conf f... (diff)
downloadgentoo-2-8bd4a7f9a440417fafe5d386e4deb099b51245d8.tar.gz
gentoo-2-8bd4a7f9a440417fafe5d386e4deb099b51245d8.tar.bz2
gentoo-2-8bd4a7f9a440417fafe5d386e4deb099b51245d8.zip
adding patch re bug#152353 to fix use flags
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/files/digest-gaim-2.0.0_beta4-r23
-rw-r--r--net-im/gaim/files/gaim-2.0.0_beta4-configure.patch79
-rw-r--r--net-im/gaim/gaim-2.0.0_beta4-r2.ebuild239
4 files changed, 327 insertions, 1 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 2c6b69880cd6..2149d387d0f4 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.418 2006/10/23 01:24:13 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.419 2006/10/23 22:55:55 gothgirl Exp $
+
+*gaim-2.0.0_beta4-r2 (23 Oct 2006)
+
+ 23 Oct 2006; gothgirl <gothgirl@gentoo.org> +gaim-2.0.0_beta4-r2.ebuild:
+ adding patch re bug#152353 to fix use flags
*gaim-2.0.0_beta4-r1 (23 Oct 2006)
diff --git a/net-im/gaim/files/digest-gaim-2.0.0_beta4-r2 b/net-im/gaim/files/digest-gaim-2.0.0_beta4-r2
new file mode 100644
index 000000000000..db30a0a3dd8a
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-2.0.0_beta4-r2
@@ -0,0 +1,3 @@
+MD5 ddf49cb3f95febdd26bf2214875446e6 gaim-2.0.0beta4.tar.bz2 6298151
+RMD160 c9c5931fc2b2bf1c5bc524e6dc2b68c28a6570f1 gaim-2.0.0beta4.tar.bz2 6298151
+SHA256 08436e3fcb4caa61b92551e5e2c092ea94caae6520d50c479a164b93caedb820 gaim-2.0.0beta4.tar.bz2 6298151
diff --git a/net-im/gaim/files/gaim-2.0.0_beta4-configure.patch b/net-im/gaim/files/gaim-2.0.0_beta4-configure.patch
new file mode 100644
index 000000000000..37b345ecbf03
--- /dev/null
+++ b/net-im/gaim/files/gaim-2.0.0_beta4-configure.patch
@@ -0,0 +1,79 @@
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 17552)
++++ configure.ac (working copy)
+@@ -186,27 +186,27 @@
+ AC_ARG_ENABLE(screensaver,
+ [AC_HELP_STRING([--disable-screensaver],
+ [compile without X screensaver extension (used to detect idleness)])],
+- enable_screensaver="no", enable_screensaver="yes")
++ enable_screensaver="$enableval", enable_screensaver="yes")
+ AC_ARG_ENABLE(sm,
+ [AC_HELP_STRING([--disable-sm],
+ [compile without X session management support])],
+- enable_sm="no", enable_sm="yes")
++ enable_sm="$enableval", enable_sm="yes")
+ AC_ARG_ENABLE(startup-notification,
+ [AC_HELP_STRING([--disable-startup-notification],
+ [compile without startup notification support])],
+- enable_startup_notification="no", enable_startup_notification="yes")
++ enable_startup_notification="$enableval", enable_startup_notification="yes")
+ AC_ARG_ENABLE(gtkspell,
+ [AC_HELP_STRING([--disable-gtkspell],
+ [compile without GtkSpell automatic spell checking])],
+- enable_gtkspell="no", enable_gtkspell="yes")
++ enable_gtkspell="$enableval", enable_gtkspell="yes")
+ AC_ARG_ENABLE(gevolution,
+ [AC_HELP_STRING([--disable-gevolution],
+ [compile without the Gaim Evolution plugin])],
+- enable_gevolution="no", enable_gevolution="yes")
++ enable_gevolution="$enableval", enable_gevolution="yes")
+ AC_ARG_ENABLE(cap,
+ [AC_HELP_STRING([--disable-cap],
+ [compile without Contact Availability Prediction plugin])],
+- enable_cap="no", enable_cap="yes")
++ enable_cap="$enableval", enable_cap="yes")
+
+
+ AC_PATH_XTRA
+@@ -455,7 +455,7 @@
+ dnl #######################################################################
+ AC_ARG_ENABLE(gstreamer,
+ [AC_HELP_STRING([--disable-gstreamer], [compile without GStreamer audio support])],
+- enable_gst="no", enable_gst="yes")
++ enable_gst="$enableval", enable_gst="yes")
+ PKG_CHECK_MODULES(GSTREAMER, [gstreamer-0.10], , [
+ AC_MSG_RESULT(no)
+ enable_gst="no"
+@@ -1564,7 +1564,7 @@
+ dnl # Check for Tcl
+ dnl #######################################################################
+ AC_ARG_ENABLE(tcl, [AC_HELP_STRING([--disable-tcl],
+- [compile without Tcl scripting])], enable_tcl="no", enable_tcl="yes")
++ [compile without Tcl scripting])], enable_tcl="$enableval", enable_tcl="yes")
+ AC_ARG_WITH(tclconfig, [AC_HELP_STRING([--with-tclconfig=DIR],
+ [directory containing tclConfig.sh])])
+
+@@ -1633,7 +1633,7 @@
+ dnl # Check for Tk
+ dnl #######################################################################
+ AC_ARG_ENABLE(tk, [AC_HELP_STRING([--disable-tk],
+- [compile without Tcl support for Tk])], enable_tk="no", enable_tk="yes")
++ [compile without Tcl support for Tk])], enable_tk="$enableval", enable_tk="yes")
+ AC_ARG_WITH(tkconfig, [AC_HELP_STRING([--with-tkconfig=DIR],
+ [directory containing tkConfig.sh])])
+
+@@ -1812,11 +1812,11 @@
+ AC_ARG_ENABLE(doxygen,
+ [AC_HELP_STRING([--disable-doxygen],
+ [enable documentation with doxygen])],
+- enable_doxygen="no", enable_doxygen="yes")
++ enable_doxygen="$enableval", enable_doxygen="yes")
+ AC_ARG_ENABLE(dot,
+ [AC_HELP_STRING([--enable-dot],
+ [enable graphs in doxygen via 'dot'])],
+- enable_dot="no", enable_dot="yes")
++ enable_dot="$enableval", enable_dot="yes")
+
+ if test "x$enable_doxygen" = xyes; then
+ AC_CHECK_PROG(DOXYGEN, doxygen, true, false)
diff --git a/net-im/gaim/gaim-2.0.0_beta4-r2.ebuild b/net-im/gaim/gaim-2.0.0_beta4-r2.ebuild
new file mode 100644
index 000000000000..a795cfc91e57
--- /dev/null
+++ b/net-im/gaim/gaim-2.0.0_beta4-r2.ebuild
@@ -0,0 +1,239 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta4-r2.ebuild,v 1.1 2006/10/23 22:55:55 gothgirl Exp $
+
+inherit flag-o-matic eutils toolchain-funcs debug multilib mono autotools perl-app gnome2
+
+MY_PV=${P/_beta/beta}
+#MY_PV="2.0.0beta3.1"
+#MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avahi bonjour cjk crypt dbus debug doc eds gadu gnutls gstreamer meanwhile mono nas nls perl silc spell startup-notification tcl tk xscreensaver custom-flags ssl qq msn gadu"
+
+RDEPEND="
+ bonjour? ( !avahi? ( net-misc/howl )
+ avahi? ( net-dns/avahi ) )
+ dbus? ( >=sys-apps/dbus-0.35
+ >=dev-lang/python-2.4 )
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ gstreamer? ( media-libs/gstreamer
+ media-libs/gst-plugins-good )
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ perl? ( >=dev-lang/perl-5.8.2-r1 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ gadu? ( net-libs/libgadu )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ )
+ msn? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ )
+ meanwhile? ( net-libs/meanwhile )
+ silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
+ eds? ( gnome-extra/evolution-data-server )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
+ startup-notification? ( >=x11-libs/startup-notification-0.5 )
+ mono? ( dev-lang/mono )
+ doc? ( app-doc/doxygen )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ dev-libs/libxml2"
+
+DEPEND="$RDEPEND
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PDEPEND="crypt? ( >=x11-plugins/gaim-encryption-3.0_beta5 )"
+
+S="${WORKDIR}/${MY_PV}"
+
+# Enable Default protocols
+DYNAMIC_PRPLS="irc,jabber,msn,oscar,yahoo,zephyr,simple"
+
+# List of plugins
+# app-accessibility/festival-gaim
+# net-im/gaim-blogger
+# net-im/gaim-bnet
+# net-im/gaim-meanwhile
+# net-im/gaim-snpp
+# x11-plugins/autoprofile
+# x11-plugins/gaim-assistant
+# x11-plugins/gaim-encryption
+# x11-plugins/gaim-extprefs
+# x11-plugins/gaim-latex
+# x11-plugins/gaim-otr
+# x11-plugins/gaim-rhythmbox
+# x11-plugins/gaim-xmms-remote
+# x11-plugins/gaimosd
+# x11-plugins/guifications
+
+
+print_gaim_warning() {
+ ewarn
+ ewarn "This is a beta release! Please back up everything in your .gaim"
+ ewarn "directory. We're looking for lots of feedback on this release"
+ ewarn "especially what you love about it and what you hate about it."
+ ewarn
+ ewarn "If you are merging ${MY_P} from an earlier version, you may need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ einfo
+ if use custom-flags; then
+ einfo "Note that you have chosen NOT TO FILTER UNSTABLE C[XX]FLAGS."
+ einfo "DO NOT file bugs with GENTOO or UPSTREAM while using custom-flags"
+ einfo
+ else
+ einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
+ einfo
+ fi
+
+ if use silc; then
+ einfo "To be able to connect to silc network, you need to run"
+ einfo "\`usermod -c \"comment\"\` as user as which you are running gaim,"
+ einfo "where \"comment\" is either your real name if you want show it"
+ einfo "on silc or any othe not empty string."
+ einfo
+ fi
+ ebeep 5
+ epause 3
+}
+
+pkg_setup() {
+ print_gaim_warning
+
+ if use bonjour && use avahi && ! built_with_use net-dns/avahi howl-compat ; then
+ eerror
+ eerror You need to rebuild net-dns/avahi with USE=howl-compat in order
+ eerror to enable howl support for the bonjour protocol in gaim.
+ eerror
+ die "Configure failed"
+ fi
+
+ if use gadu && built_with_use net-libs/libgadu ssl ; then
+ eerror
+ eerror You need to rebuild net-libs/libgadu with USE=-ssl in order
+ eerror enable gadu gadu support in gaim.
+ eerror
+ die "Configure failed"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/"${P}"-dbus.patch
+ epatch "${FILESDIR}"/"${P}"-configure.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ # Stabilize things, for your own good
+ if ! use custom-flags; then
+ strip-flags
+ fi
+ replace-flags -O? -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+
+ if use gadu; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},gg"
+ myconf="${myconf} --with-gadu-includes=."
+ myconf="${myconf} --with-gadu-libs=."
+ fi
+
+ if use silc; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},silc"
+ fi
+
+ if use qq; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},qq"
+ fi
+
+ if use meanwhile; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},sametime"
+ fi
+
+ if use bonjour; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},bonjour"
+ fi
+
+
+ if use ssl || use msn ; then
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no --enable-gnutls=yes"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=yes"
+ fi
+ else
+ einfo "No SSL support selected"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=no"
+ fi
+
+ if use xscreensaver ; then
+ myconf="${myconf} --x-includes=/usr/include/X11"
+ fi
+
+ G2CONF=" \
+ $(use_enable nls) \
+ $(use_enable perl) \
+ $(use_enable spell gtkspell) \
+ $(use_enable startup-notification) \
+ $(use_enable tcl) \
+ $(use_enable tk) \
+ $(use_enable mono) \
+ $(use_enable debug) \
+ $(use_enable dbus) \
+ $(use_enable meanwhile) \
+ $(use_enable nas) \
+ $(use_enable eds gevolution) \
+ $(use_enable gstreamer) \
+ $(use_enable doc doxygen) \
+ "--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
+ ${myconf} " || die "Configuration failed"
+
+ # This is a tempory fix until Makefile is fixed!!
+ if use mono; then
+ MAKEOPTS="-j1" gnome2_src_compile || die "Make failed"
+ else
+ gnome2_src_compile || die "Make failed"
+ fi
+}
+
+src_install() {
+ gnome2_src_install || die "Install failed"
+ use perl && fixlocalpod
+ dodoc AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ print_gaim_warning
+}