summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-23 20:19:29 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-23 20:19:29 +0000
commit06b28768bccaf9a990470ee281327f0af7ee8ab3 (patch)
tree7b5af04f3967baa132e4c10ff5e67f950944ab09 /net-im
parentUse mirror://github. (diff)
downloadgentoo-2-06b28768bccaf9a990470ee281327f0af7ee8ab3.tar.gz
gentoo-2-06b28768bccaf9a990470ee281327f0af7ee8ab3.tar.bz2
gentoo-2-06b28768bccaf9a990470ee281327f0af7ee8ab3.zip
net-im/gajim: Add backport fix for https://secunia.com/advisories/48695/, #412215
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/ChangeLog6
-rw-r--r--net-im/gajim/files/gajim-0.15-SA48695.patch24
-rw-r--r--net-im/gajim/gajim-0.15-r1.ebuild3
-rw-r--r--net-im/gajim/gajim-0.15.ebuild100
4 files changed, 31 insertions, 102 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 84e0ee1f8ccf..b37608e7056f 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.135 2012/04/23 19:50:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.136 2012/04/23 20:19:29 jlec Exp $
+
+ 23 Apr 2012; Justin Lecher <jlec@gentoo.org> -gajim-0.15.ebuild,
+ gajim-0.15-r1.ebuild, +files/gajim-0.15-SA48695.patch:
+ Add backport fix for https://secunia.com/advisories/48695/, #412215
*gajim-0.15-r1 (23 Apr 2012)
diff --git a/net-im/gajim/files/gajim-0.15-SA48695.patch b/net-im/gajim/files/gajim-0.15-SA48695.patch
new file mode 100644
index 000000000000..93ee69ed1c3a
--- /dev/null
+++ b/net-im/gajim/files/gajim-0.15-SA48695.patch
@@ -0,0 +1,24 @@
+Index: src/common/latex.py
+===================================================================
+--- src/common/latex.py (revision 13591)
++++ src/common/latex.py (revision 13759)
+@@ -60,6 +60,17 @@
+ def get_tmpfile_name():
+ random.seed()
+- int_ = random.randint(0, 100)
+- return os.path.join(gettempdir(), 'gajimtex_' + int_.__str__())
++ while(nb < 100):
++ int_ = random.randint(0, 10000)
++ filename = os.path.join(gettempdir(), 'gajimtex_' + int_.__str__())
++ # Check if a file to not overwrite it
++ ok = True
++ extensions = ['.tex', '.log', '.aux', '.dvi']
++ for ext in extensions:
++ if os.path.exists(filename + ext):
++ ok = False
++ break
++ if ok:
++ return filename
++ return filename
+
+ def write_latex(filename, str_):
diff --git a/net-im/gajim/gajim-0.15-r1.ebuild b/net-im/gajim/gajim-0.15-r1.ebuild
index a79bf354824a..1997317608a6 100644
--- a/net-im/gajim/gajim-0.15-r1.ebuild
+++ b/net-im/gajim/gajim-0.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.15-r1.ebuild,v 1.1 2012/04/23 19:50:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.15-r1.ebuild,v 1.2 2012/04/23 20:19:29 jlec Exp $
EAPI=4
@@ -71,6 +71,7 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}"/${P}-plugin.patch \
+ "${FILESDIR}"/${P}-SA48695.patch \
"${FILESDIR}"/0.14-python-version.patch \
"${FILESDIR}"/0.14.1-testing.patch
echo '#!/bin/sh' > config/py-compile
diff --git a/net-im/gajim/gajim-0.15.ebuild b/net-im/gajim/gajim-0.15.ebuild
deleted file mode 100644
index df724d5f1e6d..000000000000
--- a/net-im/gajim/gajim-0.15.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.15.ebuild,v 1.2 2012/03/26 23:13:11 naota Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="sqlite xml"
-
-inherit eutils python versionator
-
-DESCRIPTION="Jabber client written in PyGTK"
-HOMEPAGE="http://www.gajim.org/"
-SRC_URI="http://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="avahi crypt dbus gmail gnome kde idle jingle libnotify networkmanager nls spell srv X xhtml"
-
-REQUIRED_USE="
- libnotify? ( dbus )
- avahi? ( dbus )"
-
-COMMON_DEPEND="
- dev-python/pygtk:2
- x11-libs/gtk+:2"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40.1
- dev-util/pkgconfig
- >=sys-devel/gettext-0.17-r1"
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyasn1
- dev-python/pyopenssl
- crypt? (
- app-crypt/gnupg
- dev-python/pycrypto
- )
- dbus? (
- dev-python/dbus-python
- dev-libs/dbus-glib
- libnotify? ( dev-python/notify-python )
- avahi? ( net-dns/avahi[dbus,gtk,python] )
- )
- gmail? ( net-dns/bind-tools )
- gnome? (
- dev-python/libgnome-python
- dev-python/gnome-keyring-python
- dev-python/egg-python
- )
- idle? ( x11-libs/libXScrnSaver )
- jingle? ( net-libs/farsight2[python] )
- kde? ( kde-base/kwallet )
- networkmanager? (
- dev-python/dbus-python
- net-misc/networkmanager
- )
- srv? (
- || (
- dev-python/libasyncns-python
- net-dns/bind-tools )
- )
- spell? ( app-text/gtkspell:2 )
- xhtml? ( dev-python/docutils )"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/0.14-python-version.patch \
- "${FILESDIR}"/0.14.1-testing.patch
- echo '#!/bin/sh' > config/py-compile
-}
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_with X x) \
- --docdir="/usr/share/doc/${PF}" \
- --libdir="$(python_get_sitedir)" \
- --enable-site-packages
-}
-
-src_install() {
- default
-
- rm "${D}/usr/share/doc/${PF}/README.html" || die
- dohtml README.html
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}