summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-11-26 22:50:42 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-11-26 22:50:42 +0000
commitb60f9a8197a10405b694f33180aed2e48ed8eb86 (patch)
tree6b8f824e920581383dd4bd99a02a4ee6c1b39e0c /net-im/tmsnc
parentSync with overlay. (diff)
downloadgentoo-2-b60f9a8197a10405b694f33180aed2e48ed8eb86.tar.gz
gentoo-2-b60f9a8197a10405b694f33180aed2e48ed8eb86.tar.bz2
gentoo-2-b60f9a8197a10405b694f33180aed2e48ed8eb86.zip
Version Bump. Removed nls support from this version since it no longer use it.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-im/tmsnc')
-rw-r--r--net-im/tmsnc/ChangeLog7
-rw-r--r--net-im/tmsnc/Manifest12
-rw-r--r--net-im/tmsnc/files/digest-tmsnc-0.3.11
-rw-r--r--net-im/tmsnc/tmsnc-0.3.1.ebuild35
4 files changed, 44 insertions, 11 deletions
diff --git a/net-im/tmsnc/ChangeLog b/net-im/tmsnc/ChangeLog
index d82907e9f557..215e207da0a9 100644
--- a/net-im/tmsnc/ChangeLog
+++ b/net-im/tmsnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/tmsnc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/ChangeLog,v 1.4 2005/11/14 14:09:02 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/ChangeLog,v 1.5 2005/11/26 22:50:42 metalgod Exp $
+
+*tmsnc-0.3.1 (26 Nov 2005)
+
+ 26 Nov 2005; Luis Medinas <metalgod@gentoo.org> +tmsnc-0.3.1.ebuild:
+ Version Bump. Removed nls support from this version since it no longer use it.
14 Nov 2005; Luis Medinas <metalgod@gentoo.org> -tmsnc-0.2.4.ebuild,
tmsnc-0.2.5.ebuild:
diff --git a/net-im/tmsnc/Manifest b/net-im/tmsnc/Manifest
index 26489e705f53..75aa412522f2 100644
--- a/net-im/tmsnc/Manifest
+++ b/net-im/tmsnc/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 c77f9a43957e90189bed35b357aaeaae ChangeLog 753
MD5 8b105b1aef1e3ecc9a59746e20db13b1 files/digest-tmsnc-0.2.5 63
MD5 96107b54f248cf1898d8720e668a7de5 files/digest-tmsnc-0.3.0 63
+MD5 6a436ea94e34182e572199ac1006c4b5 files/digest-tmsnc-0.3.1 63
MD5 a9df75e0d6358c894c7236055a417c7d metadata.xml 583
MD5 13c20485194caf694513157208803978 tmsnc-0.2.5.ebuild 1112
MD5 7fdad03e80cdcf82a35be1c2d8c39512 tmsnc-0.3.0.ebuild 1113
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDeJqowUpWvClEHQoRApcEAJsFK4ceLNlJSRcq1ZPsFgGMPJwC3QCdETee
-uAbF8MsD7FK612Oewu0IuQs=
-=572B
------END PGP SIGNATURE-----
+MD5 0081ffc959c6e817d54fea4a092c35c8 tmsnc-0.3.1.ebuild 1032
diff --git a/net-im/tmsnc/files/digest-tmsnc-0.3.1 b/net-im/tmsnc/files/digest-tmsnc-0.3.1
new file mode 100644
index 000000000000..014016367d36
--- /dev/null
+++ b/net-im/tmsnc/files/digest-tmsnc-0.3.1
@@ -0,0 +1 @@
+MD5 3b30e5dab0b1b679d2b945c3a5713636 tmsnc-0.3.1.tar.gz 163015
diff --git a/net-im/tmsnc/tmsnc-0.3.1.ebuild b/net-im/tmsnc/tmsnc-0.3.1.ebuild
new file mode 100644
index 000000000000..86c8e63d536e
--- /dev/null
+++ b/net-im/tmsnc/tmsnc-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/tmsnc-0.3.1.ebuild,v 1.1 2005/11/26 22:50:42 metalgod Exp $
+
+DESCRIPTION="TMSNC is a textbased MSN client written in C."
+HOMEPAGE="http://tmsnc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tmsnc/${P}.tar.gz"
+
+LICENSE="IRPDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl talkfilters"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.4
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ talkfilters? ( >=app-text/talkfilters-2.3.4 )"
+
+src_compile() {
+ local myconf
+ use ssl \
+ || myconf="${myconf} --without-ssl"
+ use talkfilters \
+ || myconf="${myconf} --without-talkfilters"
+ econf ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}
+pkg_postinst() {
+ einfo "If you want talkfilters support you need to add"
+ einfo "USE=talkfilters to enable support in this package"
+}