summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-10-01 00:31:18 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-10-01 00:31:18 +0000
commit0f381d46b018d8ff54a888f2e1465c2fcc02d13f (patch)
tree8af627158b4f3af7e869de3d2d33b0682aeb3e55 /net-im/tmsnc
parentFix bug 66133 (add missing inherit). (diff)
downloadgentoo-2-0f381d46b018d8ff54a888f2e1465c2fcc02d13f.tar.gz
gentoo-2-0f381d46b018d8ff54a888f2e1465c2fcc02d13f.tar.bz2
gentoo-2-0f381d46b018d8ff54a888f2e1465c2fcc02d13f.zip
Version Bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-im/tmsnc')
-rw-r--r--net-im/tmsnc/ChangeLog7
-rw-r--r--net-im/tmsnc/Manifest16
-rw-r--r--net-im/tmsnc/files/digest-tmsnc-0.2.51
-rw-r--r--net-im/tmsnc/tmsnc-0.2.5.ebuild38
4 files changed, 49 insertions, 13 deletions
diff --git a/net-im/tmsnc/ChangeLog b/net-im/tmsnc/ChangeLog
index faa19cc01dd2..16ea575ea916 100644
--- a/net-im/tmsnc/ChangeLog
+++ b/net-im/tmsnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/tmsnc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/ChangeLog,v 1.1 2005/09/06 00:56:19 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/ChangeLog,v 1.2 2005/10/01 00:31:18 metalgod Exp $
+
+*tmsnc-0.2.5 (01 Oct 2005)
+
+ 01 Oct 2005; Luis Medinas <metalgod@gentoo.org> +tmsnc-0.2.5.ebuild:
+ Version Bump.
*tmsnc-0.2.4 (06 Sep 2005)
diff --git a/net-im/tmsnc/Manifest b/net-im/tmsnc/Manifest
index 0af0bb9763be..926f8a66f86f 100644
--- a/net-im/tmsnc/Manifest
+++ b/net-im/tmsnc/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 177f04d7f9b9d0fdb6098ea18ba57eb6 tmsnc-0.2.4.ebuild 1113
MD5 36f66a009fb5b92f99a38268b1aeef78 ChangeLog 377
-MD5 fb5cdbfe31d6f8753f77a5d0868b5ff4 files/digest-tmsnc-0.2.4 63
MD5 a9df75e0d6358c894c7236055a417c7d metadata.xml 583
-MD5 177f04d7f9b9d0fdb6098ea18ba57eb6 tmsnc-0.2.4.ebuild 1113
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDHWdpI1lqEGTUzyQRAlNmAKCjuq5e4L8SpqH9sI/rI1D7rnq3kACg1VDa
-4QVYcWtmY/N23wEPQgPtN88=
-=1wdt
------END PGP SIGNATURE-----
+MD5 9bb36348c2f94730f20e24feac7ab623 tmsnc-0.2.5.ebuild 1018
+MD5 fb5cdbfe31d6f8753f77a5d0868b5ff4 files/digest-tmsnc-0.2.4 63
+MD5 8b105b1aef1e3ecc9a59746e20db13b1 files/digest-tmsnc-0.2.5 63
diff --git a/net-im/tmsnc/files/digest-tmsnc-0.2.5 b/net-im/tmsnc/files/digest-tmsnc-0.2.5
new file mode 100644
index 000000000000..1094da582a21
--- /dev/null
+++ b/net-im/tmsnc/files/digest-tmsnc-0.2.5
@@ -0,0 +1 @@
+MD5 3943b017d071a6fd42835d15bb40347d tmsnc-0.2.5.tar.gz 213481
diff --git a/net-im/tmsnc/tmsnc-0.2.5.ebuild b/net-im/tmsnc/tmsnc-0.2.5.ebuild
new file mode 100644
index 000000000000..7f0bc6815e83
--- /dev/null
+++ b/net-im/tmsnc/tmsnc-0.2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/tmsnc-0.2.5.ebuild,v 1.1 2005/10/01 00:31:18 metalgod Exp $
+
+DESCRIPTION="TMSNC is a textbased MSN client written in C."
+HOMEPAGE="http://tmsnc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tmsnc/${P}.tar.gz"
+
+LICENSE="IRPDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls ssl talkfilters"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.4
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ talkfilters? ( >=app-text/talkfilters-2.3.4 )"
+
+src_compile() {
+ local myconf
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use ssl \
+ || myconf="${myconf} --without-ssl"
+ use talkfilters \
+ || myconf="${myconf} --without-talkfilters"
+ econf ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}
+pkg_postinst() {
+ einfo "If you want talkfilters support you need to add"
+ einfo "USE=talkfilters to enable support in this package"
+}