summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-03-04 23:53:30 +0000
committerOlivier Crête <tester@gentoo.org>2009-03-04 23:53:30 +0000
commitc80d7a4b633349a4b6946b523e6e1ab17f477e41 (patch)
tree94ded5c0ea87b4555b50d871a11780cb0b575d41 /net-im/pidgin
parentUpdate dependency to do >=perl-5.8.8 instead of ~perl-5.8.8 w.r.t. bug 261135. (diff)
downloadgentoo-2-c80d7a4b633349a4b6946b523e6e1ab17f477e41.tar.gz
gentoo-2-c80d7a4b633349a4b6946b523e6e1ab17f477e41.tar.bz2
gentoo-2-c80d7a4b633349a4b6946b523e6e1ab17f477e41.zip
Version bump, update ICQ patch, remove gnome2.eclass EAPI 2 compat code
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/ChangeLog9
-rw-r--r--net-im/pidgin/files/pidgin-2.5.4-icq.patch46
-rw-r--r--net-im/pidgin/pidgin-2.5.4-r1.ebuild6
-rw-r--r--net-im/pidgin/pidgin-2.5.4.ebuild6
-rw-r--r--net-im/pidgin/pidgin-2.5.5.ebuild173
5 files changed, 212 insertions, 28 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index 3dd7bfe7ef25..1229b4d5e5cf 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.85 2009/02/20 17:23:27 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.86 2009/03/04 23:53:29 tester Exp $
+
+*pidgin-2.5.5 (04 Mar 2009)
+
+ 04 Mar 2009; Olivier Crête <tester@gentoo.org>
+ files/pidgin-2.5.4-icq.patch, pidgin-2.5.4.ebuild, pidgin-2.5.4-r1.ebuild,
+ +pidgin-2.5.5.ebuild:
+ Version bump, update ICQ patch, remove gnome2.eclass EAPI 2 compat code
20 Feb 2009; Olivier Crête <tester@gentoo.org>
+files/pidgin-2.5.4-icq-messages-magic.patch, pidgin-2.5.4-r1.ebuild:
diff --git a/net-im/pidgin/files/pidgin-2.5.4-icq.patch b/net-im/pidgin/files/pidgin-2.5.4-icq.patch
index 3af838499c79..77f128059df1 100644
--- a/net-im/pidgin/files/pidgin-2.5.4-icq.patch
+++ b/net-im/pidgin/files/pidgin-2.5.4-icq.patch
@@ -1,19 +1,31 @@
-diff -urN pidgin-2.5.4.orig/libpurple/protocols/oscar/flap_connection.c pidgin-2.5.4/libpurple/protocols/oscar/flap_connection.c
---- pidgin-2.5.4.orig/libpurple/protocols/oscar/flap_connection.c 2009-02-04 10:58:55.000000000 +0300
-+++ pidgin-2.5.4/libpurple/protocols/oscar/flap_connection.c 2009-02-04 11:13:55.000000000 +0300
-@@ -317,12 +317,15 @@
- {
- FlapConnection *conn;
+--- pidgin-2.5.4/libpurple/protocols/oscar/flap_connection.c.orig 2009-01-23 00:09:41.000000000 +0500
++++ pidgin-2.5.4/libpurple/protocols/oscar/flap_connection.c 2009-01-23 16:12:00.000000000 +0500
+@@ -1052,10 +1052,27 @@
+ byte_stream_destroy(&bs);
+ }
-+ static const guint FlapLoginSeqs[] = { 5695, 23595, 23620, 23049, 0x2886, 0x2493, 23620, 23049, 2853, 17372, 1255, 1796, 1657, 13606, 1930, 23918, 31234, 30120, 0x1BEA, 0x5342, 0x30CC, 0x2294, 0x5697,0x25FA, 0x3303, 0x078A, 0x0FC5, 0x25D6, 0x26EE,0x7570, 0x7F33, 0x4E94, 0x07C9, 0x7339, 0x42A8 };
++guint16
++generate_flap_sequence()
++{
++ guint32 n = g_random_int(), s = 0, i;
++ for (i = n; i >>= 3; s += i);
++ return (((0 - s) ^ (guint)n) & 7 ^ n) + 3;
++}
+
- conn = g_new0(FlapConnection, 1);
- conn->od = od;
- conn->buffer_outgoing = purple_circ_buffer_new(0);
- conn->fd = -1;
- conn->subtype = -1;
- conn->type = type;
-+ conn->seqnum_out = FlapLoginSeqs[g_random_int_range(0, (sizeof FlapLoginSeqs) / (sizeof FlapLoginSeqs[0]))] - 1;
-
- od->oscar_connections = g_slist_prepend(od->oscar_connections, conn);
-
+ void
+ flap_connection_send(FlapConnection *conn, FlapFrame *frame)
+ {
+- frame->seqnum = ++(conn->seqnum_out);
++ if (frame->channel == 0x01)
++ {
++ frame->seqnum = generate_flap_sequence();
++ conn->seqnum_out = frame->seqnum;
++ } else
++ frame->seqnum = ++(conn->seqnum_out);
++
++ purple_debug_info("oscar", "Sent FLAP seqid=%d\n",
++ frame->seqnum);
++
+ sendframe_flap(conn, frame);
+ flap_frame_destroy(frame);
+ }
diff --git a/net-im/pidgin/pidgin-2.5.4-r1.ebuild b/net-im/pidgin/pidgin-2.5.4-r1.ebuild
index e81b8fc2d26b..9add6a2b7aad 100644
--- a/net-im/pidgin/pidgin-2.5.4-r1.ebuild
+++ b/net-im/pidgin/pidgin-2.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.4-r1.ebuild,v 1.2 2009/02/20 17:23:27 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.4-r1.ebuild,v 1.3 2009/03/04 23:53:29 tester Exp $
EAPI=2
@@ -167,10 +167,6 @@ src_configure() {
#$(use_enable mono) \
}
-src_compile() {
- emake || die "make failed"
-}
-
src_install() {
gnome2_src_install
use perl && fixlocalpod
diff --git a/net-im/pidgin/pidgin-2.5.4.ebuild b/net-im/pidgin/pidgin-2.5.4.ebuild
index b3d825a279bf..9fd5fb42f0bf 100644
--- a/net-im/pidgin/pidgin-2.5.4.ebuild
+++ b/net-im/pidgin/pidgin-2.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.4.ebuild,v 1.4 2009/01/21 01:12:51 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.4.ebuild,v 1.5 2009/03/04 23:53:29 tester Exp $
EAPI=2
@@ -162,10 +162,6 @@ src_configure() {
#$(use_enable mono) \
}
-src_compile() {
- emake || die "make failed"
-}
-
src_install() {
gnome2_src_install
use perl && fixlocalpod
diff --git a/net-im/pidgin/pidgin-2.5.5.ebuild b/net-im/pidgin/pidgin-2.5.5.ebuild
new file mode 100644
index 000000000000..c9666d561bd3
--- /dev/null
+++ b/net-im/pidgin/pidgin-2.5.5.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.5.ebuild,v 1.1 2009/03/04 23:53:29 tester Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://pidgin.im/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="bonjour dbus debug doc eds gadu gnutls +gstreamer meanwhile"
+IUSE="${IUSE} networkmanager nls perl silc tcl tk spell qq gadu"
+IUSE="${IUSE} +gtk sasl ncurses groupwise prediction zephyr" # mono"
+
+RDEPEND="
+ bonjour? ( net-dns/avahi )
+ dbus? ( >=dev-libs/dbus-glib-0.71
+ >=dev-python/dbus-python-0.71
+ >=sys-apps/dbus-0.90
+ >=dev-lang/python-2.4 )
+ gtk? (
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ >=x11-libs/gtk+-2.0
+ >=x11-libs/startup-notification-0.5
+ x11-libs/libXScrnSaver
+ eds? ( gnome-extra/evolution-data-server ) )
+ >=dev-libs/glib-2.0
+ gstreamer? ( =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10* )
+ perl? ( >=dev-lang/perl-5.8.2-r1 )
+ gadu? ( net-libs/libgadu[ssl] )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ meanwhile? ( net-libs/meanwhile )
+ silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
+ zephyr? ( >=app-crypt/mit-krb5-1.3.6-r1[krb4] )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ dev-libs/libxml2
+ networkmanager? ( net-misc/networkmanager )
+ prediction? ( =dev-db/sqlite-3* )
+ ncurses? ( sys-libs/ncurses[unicode] )"
+ # Mono support crashes pidgin
+ #mono? ( dev-lang/mono )"
+
+DEPEND="$RDEPEND
+ dev-lang/perl
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ gtk? ( x11-proto/scrnsaverproto )
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+# Enable Default protocols
+DYNAMIC_PRPLS="irc,jabber,oscar,yahoo,simple,msn,myspace"
+
+# List of plugins
+# app-accessibility/pidgin-festival
+# net-im/librvp
+# x11-plugins/guifications
+# x11-plugins/pidgin-encryption
+# x11-plugins/pidgin-extprefs
+# x11-plugins/pidgin-hotkeys
+# x11-plugins/pidgin-latex
+# x11-plugins/pidgin-libnotify
+# x11-plugins/pidgin-otr
+# x11-plugins/pidgin-rhythmbox
+# x11-plugins/purple-plugin_pack
+# x11-themes/pidgin-smileys
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ einfo
+ elog "You did not pick the ncurses or gtk use flags, only libpurple"
+ elog "will be built."
+ einfo
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.5.4-icq.patch
+}
+
+src_configure() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [[ "`gcc-version`" == "3.2" ]] && filter-flags -msse2
+
+ local myconf
+
+ if use gadu; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},gg"
+ myconf="${myconf} --with-gadu-includes=."
+ myconf="${myconf} --with-gadu-libs=."
+ fi
+
+ if use silc; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},silc"
+ fi
+
+ if use qq; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},qq"
+ fi
+
+ if use meanwhile; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},sametime"
+ fi
+
+ if use bonjour; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},bonjour"
+ fi
+
+ if use groupwise; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},novell"
+ fi
+
+ if use zephyr; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},zephyr"
+ fi
+
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no --enable-gnutls=yes"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=yes"
+ fi
+
+ econf \
+ $(use_enable ncurses consoleui) \
+ $(use_enable nls) \
+ $(use_enable perl) \
+ $(use_enable gtk gtkui) \
+ $(use_enable gtk startup-notification) \
+ $(use_enable gtk screensaver) \
+ $(use_enable gtk sm) \
+ $(use_enable tcl) \
+ $(use_enable spell gtkspell) \
+ $(use_enable tk) \
+ $(use_enable debug) \
+ $(use_enable dbus) \
+ $(use_enable meanwhile) \
+ $(use_enable eds gevolution) \
+ $(use_enable gstreamer) \
+ $(use_enable sasl cyrus-sasl ) \
+ $(use_enable doc doxygen) \
+ $(use_enable prediction cap) \
+ $(use_enable networkmanager nm) \
+ $(use_with zephyr krb4) \
+ $(use_enable bonjour avahi) \
+ "--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
+ --disable-mono \
+ --x-includes=/usr/include/X11 \
+ ${myconf} || die "Configuration failed"
+ #$(use_enable mono) \
+}
+
+src_install() {
+ gnome2_src_install
+ use perl && fixlocalpod
+ dodoc AUTHORS HACKING INSTALL NEWS README ChangeLog
+}