summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-05-31 01:09:29 +0000
committerDon Seiler <rizzo@gentoo.org>2004-05-31 01:09:29 +0000
commitcc4a08731190a6a5442a977494bdfd0ad41a110e (patch)
treec4e6ca687e33748e688501e4c2b71d7d61ca599e /net-im/gaim
parentAdded exim to new mailwrapper list (diff)
downloadgentoo-2-cc4a08731190a6a5442a977494bdfd0ad41a110e.tar.gz
gentoo-2-cc4a08731190a6a5442a977494bdfd0ad41a110e.tar.bz2
gentoo-2-cc4a08731190a6a5442a977494bdfd0ad41a110e.zip
Version bump
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/Manifest2
-rw-r--r--net-im/gaim/files/digest-gaim-0.781
-rw-r--r--net-im/gaim/gaim-0.78.ebuild123
4 files changed, 132 insertions, 1 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index a0d476224794..8f1261a002d8 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.179 2004/05/26 20:43:00 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.180 2004/05/31 01:08:38 rizzo Exp $
+
+*gaim-0.78 (30 May 2004)
+
+ 30 May 2004; Don Seiler <rizzo@gentoo.org>; +gaim-0.78.ebuild:
+ Version bump
26 May 2004; Don Seiler <rizzo@gentoo.org>; gaim-0.77-r2.ebuild:
Making use of 'noaudio' USE flag to disable audio. Closes Bug #51955. Thanks
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 0fee7b047d35..7ffdec1825bc 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,3 +1,4 @@
+MD5 71e54313d2ccc0256ee67358e8f0ce5e gaim-0.78.ebuild 3982
MD5 112ffe11353a192e8e160728bb305608 gaim-0.77.ebuild 4041
MD5 1b332d24ed4e517a3b587f840c551acc gaim-0.75-r10.ebuild 3678
MD5 7cd81686b057123d285aa821e366518b gaim-0.77-r2.ebuild 4496
@@ -6,6 +7,7 @@ MD5 19b3cafbbe380403d46cccc45a984b80 metadata.xml 481
MD5 4989dc76d941288934c783f52931762d files/gaim-0.75-static-prpls.patch 3710
MD5 76d3a02120c18747eb5c3335dc17b16d files/gaim-0.77-plugin-prefs.patch 3926
MD5 4bc83ad48d260db208fcae372c2bb291 files/digest-gaim-0.77 63
+MD5 f07855631a1ef3f986568b772f335865 files/digest-gaim-0.78 63
MD5 3a5e6167d13c4a44a8618c12629d777e files/gaim-0.77-c99.patch 4790
MD5 a714a5babbb4387f5a5516f75548528a files/gaim-0.76cvs-yahoo-misc-fixes-1.diff 3105
MD5 6590ac50c358f619973c6226219a5422 files/gaim-0.77-64bit_goodness.patch 4544
diff --git a/net-im/gaim/files/digest-gaim-0.78 b/net-im/gaim/files/digest-gaim-0.78
new file mode 100644
index 000000000000..fb5c8eabe831
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.78
@@ -0,0 +1 @@
+MD5 079f3286333ed51cc72c65b5efe1b989 gaim-0.78.tar.bz2 4219726
diff --git a/net-im/gaim/gaim-0.78.ebuild b/net-im/gaim/gaim-0.78.ebuild
new file mode 100644
index 000000000000..4d1b9eec4c23
--- /dev/null
+++ b/net-im/gaim/gaim-0.78.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.78.ebuild,v 1.1 2004/05/31 01:08:38 rizzo Exp $
+
+inherit flag-o-matic eutils gcc
+use debug && inherit debug
+
+IUSE="nls perl spell nas debug crypt cjk gnutls"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~mips ~hppa"
+
+DEPEND=">=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.8.2-r1
+ !<dev-perl/ExtUtils-MakeMaker-6.17 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ dev-libs/nss
+ gnutls? ( net-libs/gnutls )"
+PDEPEND="crypt? ( >=net-im/gaim-encryption-2.26 )"
+
+pkg_setup() {
+ ewarn
+ ewarn "If you are merging ${P} from an earlier version, you will need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ for TICKER in 1 2 3 4 5; do
+ # Double beep here.
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+ sleep 8
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch
+}
+
+src_compile() {
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ use gnutls && {
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/lib"
+ } || myconf="${myconf} --enable-gnutls=no"
+
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+ myconf="${myconf} --with-nspr-libs=/usr/lib"
+ myconf="${myconf} --with-nss-libs=/usr/lib"
+
+ econf ${myconf} || die "Configuration failed"
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+
+ # Copy header files for gaim plugin use
+ dodir /usr/include/gaim/src
+ cp config.h ${D}/usr/include/gaim/
+ cd ${S}/src
+ tar cf - *.h | (cd ${D}/usr/include/gaim/src ; tar xvf -)
+ assert "Failed to install header files to /usr/include/gaim"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are merging ${P} from an earlier version, you will need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ for TICKER in 1 2 3 4 5; do
+ # Double beep here.
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+ sleep 8
+}