summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-03-02 19:54:53 +0000
committerKevin McCarthy <signals@gentoo.org>2011-03-02 19:54:53 +0000
commiteea2cbdc5102da8c9ef7c4288a5f5ed4ebed936f (patch)
tree570695d6d87b3ef23d756631caa62936dc7deccd /net-im/ekg
parentRemoved old (diff)
downloadgentoo-2-eea2cbdc5102da8c9ef7c4288a5f5ed4ebed936f.tar.gz
gentoo-2-eea2cbdc5102da8c9ef7c4288a5f5ed4ebed936f.tar.bz2
gentoo-2-eea2cbdc5102da8c9ef7c4288a5f5ed4ebed936f.zip
Slotted gtk+ depend and EAPI=2 bump to support it.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'net-im/ekg')
-rw-r--r--net-im/ekg/ChangeLog5
-rw-r--r--net-im/ekg/ekg-1.8_rc1.ebuild14
2 files changed, 12 insertions, 7 deletions
diff --git a/net-im/ekg/ChangeLog b/net-im/ekg/ChangeLog
index ac719c7ad68f..90d84514eb77 100644
--- a/net-im/ekg/ChangeLog
+++ b/net-im/ekg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/ekg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.45 2011/02/26 19:43:22 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.46 2011/03/02 19:54:53 signals Exp $
+
+ 02 Mar 2011; Kevin McCarthy <signals@gentoo.org> ekg-1.8_rc1.ebuild:
+ Slotted gtk+ depend and EAPI=2 bump to support it.
26 Feb 2011; Kevin McCarthy <signals@gentoo.org> ekg-1.7.ebuild,
ekg-1.8_rc1.ebuild:
diff --git a/net-im/ekg/ekg-1.8_rc1.ebuild b/net-im/ekg/ekg-1.8_rc1.ebuild
index 686a6377726d..a77980d72aaf 100644
--- a/net-im/ekg/ekg-1.8_rc1.ebuild
+++ b/net-im/ekg/ekg-1.8_rc1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.8_rc1.ebuild,v 1.4 2011/02/26 19:43:22 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.8_rc1.ebuild,v 1.5 2011/03/02 19:54:53 signals Exp $
+EAPI=2
inherit autotools eutils
IUSE="gif gtk jpeg ncurses python readline spell ssl threads zlib"
@@ -25,22 +26,20 @@ RDEPEND="net-libs/libgadu
spell? ( >=app-text/aspell-0.50.3 )
gif? ( media-libs/giflib )
jpeg? ( virtual/jpeg )
- gtk? ( >=x11-libs/gtk+-2.0 )"
+ gtk? ( x11-libs/gtk+:2 )"
DEPEND=">=sys-devel/automake-1.7
>=sys-devel/autoconf-2.50
${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-gtkutil-button-decl.patch"
epatch "${FILESDIR}/${P}-as-needed.patch"
epatch "${FILESDIR}/${P}-gtk.patch"
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf="--enable-ioctld --disable-static --enable-dynamic"
if use ncurses; then
myconf="$myconf --enable-force-ncurses"
@@ -60,6 +59,9 @@ src_compile() {
`use_enable ssl openssl` \
`use_enable gtk ui-gtk` \
|| die
+}
+
+src_compile() {
emake || die
}