summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2010-04-26 09:54:43 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2010-04-26 09:54:43 +0000
commitca17c4987cd6e2c39a3d7ddcfa98c9a3d8d70467 (patch)
tree1b2f854fafdebd31d4cc73bdaa50af984d671dca /net-ftp
parentVersion bump. Make sure we don't depend on perl unconditionally. (diff)
downloadgentoo-2-ca17c4987cd6e2c39a3d7ddcfa98c9a3d8d70467.tar.gz
gentoo-2-ca17c4987cd6e2c39a3d7ddcfa98c9a3d8d70467.tar.bz2
gentoo-2-ca17c4987cd6e2c39a3d7ddcfa98c9a3d8d70467.zip
no need collision protect inside ebuild any more, breaks binary packages (bug #300139)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpbase/ChangeLog11
-rw-r--r--net-ftp/ftpbase/ftpbase-0.01-r2.ebuild49
2 files changed, 58 insertions, 2 deletions
diff --git a/net-ftp/ftpbase/ChangeLog b/net-ftp/ftpbase/ChangeLog
index b8c7d495eaa1..1a9a71c73d1f 100644
--- a/net-ftp/ftpbase/ChangeLog
+++ b/net-ftp/ftpbase/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/ftpbase
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.22 2008/05/24 13:41:08 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.23 2010/04/26 09:54:43 haubi Exp $
+
+*ftpbase-0.01-r2 (26 Apr 2010)
+
+ 26 Apr 2010; Michael Haubenwallner <haubi@gentoo.org>
+ +ftpbase-0.01-r2.ebuild:
+ no need collision protect inside ebuild any more, breaks binary packages
+ (bug #300139)
24 May 2008; Markus Meier <maekke@gentoo.org> ftpbase-0.01-r1.ebuild:
amd64 stable, bug #222151
diff --git a/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild b/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild
new file mode 100644
index 000000000000..529427966f71
--- /dev/null
+++ b/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild,v 1.1 2010/04/26 09:54:43 haubi Exp $
+
+inherit eutils pam
+
+DESCRIPTION="FTP layout package"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="pam"
+
+DEPEND="pam? ( virtual/pam )
+ !<net-ftp/proftpd-1.2.10-r6
+ !<net-ftp/pure-ftpd-1.0.20-r2
+ !<net-ftp/vsftpd-2.0.3-r1"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ # Check if home exists
+ local exists=false
+ [[ -d "${ROOT}home/ftp" ]] && exists=true
+
+ # Add our default ftp user
+ enewgroup ftp 21
+ enewuser ftp 21 -1 /home/ftp ftp
+
+ # If home did not exist and does now then we created it in the enewuser
+ # command. Now we have to change it's permissions to something sane.
+ if [[ ${exists} == "false" && -d "${ROOT}home/ftp" ]] ; then
+ chown root:ftp "${ROOT}"home/ftp
+ fi
+}
+
+src_install() {
+ # The ftpusers file is a list of people who are NOT allowed
+ # to use the ftp service.
+ insinto /etc
+ doins "${FILESDIR}/ftpusers" || die
+
+ # Ideally we would create the home directory here with a dodir.
+ # But we cannot until bug #9849 is solved - so we kludge in pkg_postinst()
+
+ newpamd "${FILESDIR}/ftp-pamd-include" ftp
+}