summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-12-26 01:27:58 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-12-26 01:27:58 +0000
commitb221e57ba7a3dcacb755de11a96c084b733572dc (patch)
tree88ed7b7b5e9f0a9f08e5537eb5f2ce7b6d8ef71c /net-ftp
parentversion bump (diff)
downloadgentoo-2-b221e57ba7a3dcacb755de11a96c084b733572dc.tar.gz
gentoo-2-b221e57ba7a3dcacb755de11a96c084b733572dc.tar.bz2
gentoo-2-b221e57ba7a3dcacb755de11a96c084b733572dc.zip
version bump
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/Manifest2
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.6.111
-rw-r--r--net-ftp/lftp/lftp-2.6.11.ebuild53
3 files changed, 55 insertions, 1 deletions
diff --git a/net-ftp/lftp/Manifest b/net-ftp/lftp/Manifest
index 07e804de1d97..871737b7a757 100644
--- a/net-ftp/lftp/Manifest
+++ b/net-ftp/lftp/Manifest
@@ -1,5 +1,5 @@
MD5 3cb710545c1a1e95da03ddf0c2d5e9b8 lftp-2.6.10.ebuild 1346
-MD5 ed6fe659eb4d4a1bf82853c0f1ba245b lftp-2.6.11.ebuild 1353
+MD5 261a23572f5d24b59f6dd64520ee6f0f lftp-2.6.11.ebuild 1354
MD5 1670ba811415e89e9969cc9466206053 ChangeLog 5317
MD5 0000187694fd92f30e8669216ab2d7a4 files/digest-lftp-2.6.10 65
MD5 d640fa2520c5748b7ebfba9feeae8f91 files/digest-lftp-2.6.11 65
diff --git a/net-ftp/lftp/files/digest-lftp-2.6.11 b/net-ftp/lftp/files/digest-lftp-2.6.11
new file mode 100644
index 000000000000..cd123e7ea393
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.6.11
@@ -0,0 +1 @@
+MD5 58e67606046174175e8cdee4c74fdaf7 lftp-2.6.11.tar.bz2 1187882
diff --git a/net-ftp/lftp/lftp-2.6.11.ebuild b/net-ftp/lftp/lftp-2.6.11.ebuild
new file mode 100644
index 000000000000..c3bdfdfbae6c
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.11.ebuild,v 1.1 2003/12/26 01:23:22 pyrania Exp $
+
+IUSE="ssl socks5 nls"
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf}
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}