summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-19 13:24:46 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-19 13:24:46 +0000
commita1c3127d68a6769037ff017b37b7232e27c4a035 (patch)
tree31e497646c0e5d10e73379330985d0d6f62ec89f /net-ftp
parentPure-ftpd, new version, previous one was ancient, removed it (diff)
downloadgentoo-2-a1c3127d68a6769037ff017b37b7232e27c4a035.tar.gz
gentoo-2-a1c3127d68a6769037ff017b37b7232e27c4a035.tar.bz2
gentoo-2-a1c3127d68a6769037ff017b37b7232e27c4a035.zip
missed the ebuild itself :o)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.8_beta.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.8_beta.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.8_beta.ebuild
new file mode 100644
index 000000000000..a0e7340cc544
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.8_beta.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.8_beta.ebuild,v 1.1 2002/01/19 13:24:46 verwilst Exp $
+
+S="${WORKDIR}/pure-ftpd-1.0.8"
+SRC_URI="http://prdownloads.sourceforge.net/pureftpd/pure-ftpd-1.0.8-beta.tar.gz"
+DESCRIPTION="Pure-FTPd is a fast, production-quality, standard-conformant FTP server"
+
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam )
+ mysql? ( >=dev-db/mysql )
+ postgres? ( >=dev-db/postgresql )
+ ldap? ( >=net-nds/openldap )"
+
+src_compile() {
+ local myconf
+ cd ${S}
+ use pam && myconf="${myconf} --with-pam"
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+ use ldap && myconf="${myconf} --with-ldap"
+ ./configure --prefix=/usr --with-altlog --with-puredb \
+ --with-extauth --with-throttling --with-ratios \
+ --with-quotas --with-welcomemsg --with-cookie \
+ --with-uploadscript --with-virtualhosts \
+ --with-virtualchroot --with-diraliases \
+ --host=${CHOST} ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ cp ${FILESDIR}/ftpusers ${D}/etc/ftpusers
+ cp ${FILESDIR}/pure-ftpd.conf_d ${D}/etc/conf.d/pure-ftpd.conf
+ cp ${FILESDIR}/pure-ftpd.rc6 ${D}/etc/init.d/pure-ftpd
+ chmod 644 ${D}/etc/init.d/pure-ftpd
+
+}